August 05, 2021, 11:32:59 am

PIC-MAXI-WEB patch?

Started by hua, September 18, 2012, 10:19:23 pm

Previous topic - Next topic

hua

Hi;

I have pic18f97j60 based PIC-MAXI-WEB(rev.b) board, I correctly followed the steps for patching the TCP Demo Application but nothing changed in demo project. Everything is same. First i tried TCP/IP Stack 5.31 and then the other versions,no result! any idea? or Is there anyone has patched TCP/IP Demo Project for PIC-MAXI-WEB board?

LubOlimex

You need to unblock the application and run it as administrator. Since the patch does modifications to existing files it gets recognized as malicious software and might get blocked.

Unfortunately, distributing modified Microchip Application Libraries for profit is against the law, so I can't provide you with patched version.

I will e-mail you with further instructions.

Lub/OLIMEX
Technical support and documentation manager at Olimex

olimex

to clarify we used to have patched version on our web for download before and have been contacted by Microchip law dept asking us to remove it as they want all customers to Agree with their terms before download the TCP-IP stack form their web site, so we had to remove and offer not only patch

xyster

I have problem with patch:

I:

1.- install librery with stack v5.31 on c:/Microchip Solutions v2010-10-19
2.- make a new folder on desktop
3.- in this new folder put "Microchip" and "TCPIP Demo App" folders from the library
4.- Unzip the patch in this folder
5.- all archive that say "Readme.txt" is here folder
6.- execute as administrator the "apply-patch.bat"
7.- put any key
8.- This say: "The system can not find the file specified"

What am I doing wrong?


LubOlimex

Hello guys,

I've repacked the examples. Now you don't have to apply patches, but you have to accept the license agreement: https://www.olimex.com/Products/PIC/Development/PIC-MAXI-WEB/resources/PIC-MAXI-WEB.zip.

https://www.olimex.com/Products/PIC/Development/PIC-MAXI-WEB/

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

Acuario

Hi,
I downloaded the patched code, unpacked the project and installed the C18 (v3.43) compiler from the Microchip site.

I imported the project from the old MPLAB format to mplab X v1.41 using the wizard.

When I build the project I get an error:

"C:\Program Files (x86)\Microchip\mplabc18\v3.43\bin\mplink.exe"    -p18f97j60  -w  -m".map" -w -l"../../../../../../mcc18_v3.34/lib"  -z__MPLAB_BUILD=1  -u_CRUNTIME -l "C:\Program Files (x86)\Microchip\mplabc18\v3.43\bin"\\..\\lib  -o dist/default/production/PIC_MAXI_WEB_5_31.X.production.cof  build/default/production/_ext/1295770447/Announce.o build/default/production/_ext/1295770447/ARP.o build/default/production/_ext/1295770447/AutoIP.o build/default/production/_ext/1295770447/BerkeleyAPI.o build/default/production/_ext/1295770447/Delay.o build/default/production/_ext/1295770447/DHCP.o build/default/production/_ext/1295770447/DHCPs.o build/default/production/_ext/1295770447/DNS.o build/default/production/_ext/1295770447/DNSs.o build/default/production/_ext/1295770447/DynDNS.o build/default/production/_ext/1295770447/ENC28J60.o build/default/production/_ext/1295770447/ENCX24J600.o build/default/production/_ext/1295770447/ETH97J60.o build/default/production/_ext/1295770447/FTP.o build/default/production/_ext/1295770447/Hashes.o build/default/production/_ext/1295770447/Helpers.o build/default/production/_ext/1295770447/HTTP2.o build/default/production/_ext/1295770447/ICMP.o build/default/production/_ext/1295770447/IP.o build/default/production/_ext/1295770447/LCDBlocking.o build/default/production/_ext/1295770447/MPFS2.o build/default/production/_ext/1295770447/NBNS.o build/default/production/_ext/1295770447/Reboot.o build/default/production/_ext/1295770447/SMTP.o build/default/production/_ext/1295770447/SNMP.o build/default/production/_ext/1295770447/SNTP.o build/default/production/_ext/1295770447/SPIEEPROM.o build/default/production/_ext/1295770447/SPIFlash.o build/default/production/_ext/1295770447/SPIRAM.o build/default/production/_ext/1295770447/StackTsk.o build/default/production/_ext/1295770447/TCP.o build/default/production/_ext/1295770447/TCPPerformanceTest.o build/default/production/_ext/1295770447/Telnet.o build/default/production/_ext/1295770447/TFTPc.o build/default/production/_ext/1295770447/Tick.o build/default/production/_ext/1295770447/UART2TCPBridge.o build/default/production/_ext/1295770447/UART.o build/default/production/_ext/1295770447/UDP.o build/default/production/_ext/1295770447/UDPPerformanceTest.o build/default/production/_ext/1472/CustomHTTPApp.o build/default/production/_ext/1472/CustomSNMPApp.o build/default/production/_ext/1472/MainDemo.o build/default/production/_ext/1472/BerkeleyTCPClientDemo.o build/default/production/_ext/1472/BerkeleyTCPServerDemo.o build/default/production/_ext/1472/BerkeleyUDPClientDemo.o build/default/production/_ext/1472/GenericTCPClient.o build/default/production/_ext/1472/GenericTCPServer.o build/default/production/_ext/1472/LegacyHTTPApp.o build/default/production/_ext/1472/PingDemo.o build/default/production/_ext/1472/SMTPDemo.o build/default/production/_ext/1472/UARTConfig.o   
MPLINK 4.44, Linker
Device Database Version 1.9
Copyright (c) 1998-2011 Microchip Technology Inc.
Error - section '.udata_UDP.o' can not fit the section. Section '.udata_UDP.o' length=0x00000124
Errors    : 1

make[2]: *** [dist/default/production/PIC_MAXI_WEB_5_31.X.production.hex] Error 1
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2

Any idea what is going on?

Thanks