pic-maxi-web strange beaviour

Started by thecorsoguy, October 12, 2012, 09:30:36 AM

Previous topic - Next topic



I've just bought a pic-maxi-web from mouser electronics.
As soon as I receive it I try to use it with the preloaded application (the display say version 5.00). Also if the address was correct, and my router see the board connected, I was not able to see it with the browser. I was able to use the serial port terminal, change parameters, but no web and no ftp connection. Also no ping.

I download the latest path from you web-site and I put on the board the last version (I use a pickit2 on mplab to load it). Now the board switch on, show version 5.31 on the display, and I was able to use the serial port terminal and change parameters. But, also if the DHCP is disable, the board has a very strange beaviour.

If I switch on without the network cable connected it show the correct static address I put ( but as soon as I connect the cable the address change to

If I switch on with the cable connected it show the address and after few seconds again

I tried on two different network, both provided with DHCP server, and I test with DHCP activated or not, but I have allways the same beaviour. Also if I try to use the option 9 on the serial terminal to load the webpages, simply to board go back to the menĂº, so I have to way to try to load it again.

Could you help me?


David Carter

I also have a similar problem.

When I run the software supplied with the board, v5.00 everything works fine. Access via the web browser, serial port etc.

If I compile the 5.31 software from the Microchip website, the software boots up, but appears to lock up, the IP address does not appear, and the serial port does not work, no website access.

If I compile version 5.20 (oldest version available on Microchip), I get a similar story to thecorsoguy. Serial port access but option 9 does not work, no website access and the ip address appears to change.

Anybody any ideas pleasE?


Hi David,

my problem was little different. My board was not working with every version.

I test a lot, also I check the network traffic with wireshark. Was clear that the board sends packet but was not able to receive it, also if the led on the net pluf was blinking.

I find out a microchip datasheet talking about pin swap, and I found out the solution. I re-make the network cable swapping pin 3 and 6, and now the board is working. This board has no pin swap device, and probably my router has some strange connection inside. The strange thing is that I have this problem in two completely different networks.

For your problem this is what I can suggest (based on my experience and on what I have read around):
- You need a completely new installation of 5.31
- You have to path it using the files you can download from olimex. You have to run the patch batch from a prompt you run with administrative priviledge, or it not work
- You have to use old C18 compiler if you want to recompile a working 5.31 version. I use the version 3.36. Newer, as I know, create strange software beaviour
- The option 9 is not working because the new HTTP server (the HTTP2 server in the code) that is the one active by default in the latest version, don't support it (as I see in the code). So you can't use this option with that configuration but only the upload via webpages mpfsupload).

Hope this help.




Hey guys,

First of all I want to say that hardware-wise PIC-MAXI-WEB is one of my favorite boards - it has virtually endless possibilities.

@David You need to manually apply the changes on the newer Microchip stack so it fits our hardware. The board can't run the stack out-of-the-box. You can't apply the patch either since every Microchip TCP/IP release has a different file and folder structure.

@Luca Glad you got it working! PIC doesn't like crossover cables. Only straight ones.

@Both A lot of the functionality of boards with Ethernet connector depend on your router, switch, firewall, dhcp or network settings in general. Always be sure they are configured properly.

The good news is we are converting and updating the example for the newest TCP/IP stack from the latest Microchip Application Libraries as we did with two other PIC boards - PIC-WEB and PIC-GSM. My predictions are the new example will be available in a month time.

Best regards,

Technical support and documentation manager at Olimex

David Carter

Hi there,
Thank you both for your answers. It is nice to have some support at the start of all this.

I am afraid I am no further along though...

I cannot find out how to download an older version of the mplab c18?
There only seems to be upgrades out there.
I have downloaded the lite version 3.43, so I think this is why it is not working?

How do I manually apply the changes to the stack please?

Sorry for the basic questions, and thanks in advance for any replies.



I got from there


I also download the stack from the old version on microchip and then I follow the instruction on the patch you can download from the olimex site. The only think you have to remember is that you have to open a prompt with administrative right and then run from there the patch program.