OLINUXINO-Micro not booting on SD, 2.5V missing

Started by GuiQuad06, December 14, 2022, 04:55:53 PM

Previous topic - Next topic



I just bought some imx233-olinuxino-micro board for having fun and making personnal projects.

I burn a SD Card (8Gb) with a core-image-minimal very basic image by following the user manual. I let bootstrap as factory (boot by SD by Default).

I got this message looping on the DEBUG UART :
"Data Abort

I really have no idea on what is it going on, but, I ran basic static tests on the board and it seems that the 2V5 generated by the internal imx233 DCDC is missing !

Have you guys ever met this issue ?

Thanks & Regards


What is that Linux image that you tried? First try with the official image from this archive:


Extract the archive and download the image to the card with BalenaEtcher.
Technical support and documentation manager at Olimex


Hello ,

Thanks for quick answer LubOlimex, I just tried this image, and I got another loop on the Terminal :

PowerPrep start initialize power...
Battery Voltage = 2.04V
No battery or bad battery detected!!!.Disabling battery voltage measurements.
LLCJun 14 201614:59:00
EMI_CTRL 0x1C084040
FRAC 0x92926192
power 0x00820710
Frac 0x92926192
start change cpu freq
hbus 0x00000003
cpu 0x00010001

As I said previously, i am using a factory olinuxino-micro board, and the 2p5 voltage is missing (generated by imx233 DCDC and feeding the DDR). Which could explain the crash maybe at the memory boot process. I am using 5V / 1A jack supply.

Thanks & Regards,


Umm, this is not very typical. Did you try with another power supply?

Every board passes a number of tests here, including empirical one that boots Linux. How did you receive a board that doesn't boot. Maybe the board got damaged somehow? I have no idea.

I tested the same board and Linux image here. It seems to boot just fine. It looks like this:

PowerPrep start initialize power...
Battery Voltage = 0.64V
No battery or bad battery detected!!!.Disabling battery voltage measurements.
LLCJun 14 201614:59:00
EMI_CTRL 0x1C084040
FRAC 0x92926192
power 0x00820710
Frac 0x92926192
start change cpu freq
hbus 0x00000003
cpu 0x00010001
LLLLLLLFCLJUncompressing Linux... done, booting the kernel.
Initializing cgroup subsys cpuset

Initializing cgroup subsys cpu

Linux version 2.6.35-8-ARCH+ (nobody@fermium) (gcc version 4.7.1 20120721 (prerelease) (GCC) ) #1 PREEMPT Fri Sep 21 17:02:25 UTC 2012

CPU: ARM926EJ-S [41069265] revision 5 (ARMv5TEJ), cr=00053177

CPU: VIVT data cache, VIVT instruction cache

Machine: iMX233-OLinuXino low cost board

Memory policy: ECC disabled, Data cache writeback

INITRD: 0x40400000+0x00400000 overlaps in-use memory region - disabling initrd

Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256

Kernel command line: noinitrd console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc

PID hash table entries: 256 (order: -2, 1024 bytes)

Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)

Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)

allocated 327680 bytes of page_cgroup

please try 'cgroup_disable=memory' option if you don't want memory cgroups

Memory: 64MB = 64MB total

Memory: 60500k/60500k available, 5036k reserved, 0K highmem

Virtual kernel memory layout:

    vector  : 0xffff0000 - 0xffff1000   (   4 kB)

    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)

    DMA     : 0xfde00000 - 0xffe00000   (  32 MB)

    vmalloc : 0xc4800000 - 0xf0000000   ( 696 MB)

    lowmem  : 0xc0000000 - 0xc4000000   (  64 MB)

    modules : 0xbf000000 - 0xc0000000   (  16 MB)

      .init : 0xc0008000 - 0xc0028000   ( 128 kB)

      .text : 0xc0028000 - 0xc03af000   (3612 kB)

      .data : 0xc03ca000 - 0xc03f6000   ( 176 kB)

SLUB: Genslabs=11, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1

Hierarchical RCU implementation.

RCU-based detection of stalled CPUs is disabled.

Verbose stalled-CPUs detection is disabled.


Console: colour dummy device 80x30

console [ttyAMA0] enabled

Calibrating delay loop... 226.09 BogoMIPS (lpj=1130496)

pid_max: default: 32768 minimum: 301

Security Framework initialized

Mount-cache hash table entries: 512

Initializing cgroup subsys ns

Initializing cgroup subsys cpuacct

Initializing cgroup subsys memory

Initializing cgroup subsys devices

Initializing cgroup subsys freezer

CPU: Testing write buffer coherency: ok

devtmpfs: initialized

regulator: core version 0.5

NET: Registered protocol family 16

regulator: vddd: 800 <--> 1575 mV at 1550 mV fast normal

regulator: vdddbo: 800 <--> 1575 mV fast normal

regulator: vdda: 1500 <--> 2275 mV at 1750 mV fast normal

regulator: vddio: 2800 <--> 3575 mV at 3300 mV fast normal

regulator: overall_current: fast normal

regulator: mxs-duart-1: fast normal

regulator: mxs-bl-1: fast normal

regulator: mxs-i2c-1: fast normal

regulator: mmc_ssp-1: fast normal

regulator: mmc_ssp-2: fast normal

regulator: charger-1: fast normal

regulator: power-test-1: fast normal

regulator: cpufreq-1: fast normal

i.MX IRAM pool: 28 KB@0xc4808000

usb: DR gadget (utmi) registered

bio: create slab <bio-0> at 0

SCSI subsystem initialized

usbcore: registered new interface driver usbfs

usbcore: registered new interface driver hub

usbcore: registered new device driver usb

Advanced Linux Sound Architecture Driver Version 1.0.23.

Switching to clocksource mxs clock source

NET: Registered protocol family 2

IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

TCP established hash table entries: 2048 (order: 2, 16384 bytes)

TCP bind hash table entries: 2048 (order: 1, 8192 bytes)

TCP: Hash tables configured (established 2048 bind 2048)

TCP reno registered

UDP hash table entries: 256 (order: 0, 4096 bytes)

UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)

NET: Registered protocol family 1

Bus freq driver module loaded

VFS: Disk quotas dquot_6.5.2

Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)

msgmni has been set to 118

alg: No test for stdrng (krng)

cryptodev: driver loaded.

Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)

io scheduler noop registered

io scheduler deadline registered

io scheduler cfq registered (default)

Console: switching to colour frame buffer device 90x30

mxs-duart.0: ttyAMA0 at MMIO 0x80070000 (irq = 0) is a DebugUART

mxs-auart.1: ttySP1 at MMIO 0x8006c000 (irq = 24) is a mxs-auart.1

Found APPUART 3.0.0

brd: module loaded

loop: module loaded

usbmon: debugfs is not available

ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver

fsl-ehci fsl-ehci: Freescale On-Chip EHCI Host Controller

fsl-ehci fsl-ehci: new USB bus registered, assigned bus number 1

fsl-ehci fsl-ehci: irq 11, io base 0x80080000

fsl-ehci fsl-ehci: USB 2.0 started, EHCI 1.00

usb usb1: New USB device found, idVendor=1d6b, idProduct=0002

usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1

usb usb1: Product: Freescale On-Chip EHCI Host Controller

usb usb1: Manufacturer: Linux 2.6.35-8-ARCH+ ehci_hcd

usb usb1: SerialNumber: fsl-ehci

hub 1-0:1.0: USB hub found

hub 1-0:1.0: 1 port detected

Initializing USB Mass Storage driver...

usbcore: registered new interface driver usb-storage

USB Mass Storage support registered.

usbcore: registered new interface driver libusual

ARC USBOTG Device Controller driver (1 August 2005)

udc: request mem region for fsl-usb2-udc failed

fsl-usb2-udc: probe of fsl-usb2-udc failed with error -16

mice: PS/2 mouse device common for all mice

MXS RTC driver v1.0 hardware v2.0.0

mxs-rtc mxs-rtc.0: rtc core: registered mxs-rtc as rtc0

i2c /dev entries driver

WARNING : No battery connected !

Aborting power driver initialization

mxs-battery: probe of mxs-battery.0 failed with error 1

mxs watchdog: initialized, heartbeat 19 sec

mxs-mmc: MXS SSP Controller MMC Interface driver

ssp_set_rate: error -110

mxs-mmc mxs-mmc.0: mmc0: MXS SSP MMC DMAIRQ 14 ERRIRQ 15

dcp dcp.0: DCP crypto enabled.!

mxs-adc-audio mxs-adc-audio.0: MXS ADC/DAC Audio Codec

No device for DAI mxs adc/dac

No device for DAI mxs adc/dac

asoc: mxs adc/dac <-> mxs adc/dac mapping ok

ALSA device list:

  #0: MXS EVK (mxs adc/dac)

TCP cubic registered

NET: Registered protocol family 10

IPv6 over IPv4 tunneling driver

NET: Registered protocol family 17

registered taskstats version 1

mxs-rtc mxs-rtc.0: setting system clock to 1970-01-01 00:00:09 UTC (9)

Waiting for root device /dev/mmcblk0p2...

mmc0: new high speed SDHC card at address 0007

mmcblk0: mmc0:0007 SD04G 3.70 GiB

 mmcblk0: p1 p2 p3

EXT4-fs (mmcblk0p2): recovery complete

EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null)

VFS: Mounted root (ext2 filesystem) on device 179:2.

devtmpfs: mounted

Freeing init memory: 128K

INIT: version 2.88 booting

 > Arch Linux ARM
 > http://www.archlinuxarm.org

:: Mounting Root Read-Only    [BUSY] EXT4-fs (mmcblk0p2): re-mounted. Opts: barrier=1,data=ordered

:: Adjusting system time and setting kernel timezone    [BUSY]    [DONE]
:: Starting UDev Daemon    [BUSY] <30>systemd-udevd[63]: starting version 186

:: Triggering UDev uevents    [BUSY]    [DONE]
:: Loading User-specified Modules    [BUSY]    [DONE]
:: Waiting for UDev uevents to be processed    [BUSY]    [DONE]
:: Configuring Virtual Consoles    [BUSY]    [DONE]
:: Bringing up loopback interface    [BUSY]    [DONE]
:: Unlocking encrypted volumes    [BUSY]    [DONE]
:: Checking Filesystems    [BUSY]    [DONE]
:: Remounting Root and API filesystems    [BUSY] EXT4-fs (mmcblk0p2): re-mounted. Opts: barrier=1,data=ordered

:: Mounting Local Filesystems    [BUSY]    [DONE]
:: Activating Swap    [BUSY]    [DONE]
:: Configuring Time Zone    [BUSY]    [DONE]
:: Initializing Random Seed    [BUSY]    [DONE]
:: Removing Leftover Files    [BUSY]    [DONE]
:: Setting Hostname: alarm    [BUSY]    [DONE]
:: Saving dmesg Log    [BUSY]    [DONE]

INIT: Entering runlevel: 3

:: Starting Syslog-NG    [BUSY]    [DONE]
:: Starting Network    [BUSY]
Error: unknown interface in /etc/rc.conf: `usb0'
:: Mounting Network Filesystems    [BUSY]    [DONE]
:: Starting crond daemon    [BUSY]    [DONE]
:: Starting Secure Shell Daemon    [BUSY]    [DONE]

Arch Linux 2.6.35-8-ARCH+ (ttyAMA0)

alarm login:
Technical support and documentation manager at Olimex