Just assembled, booted a few times, but now doesn't.

Started by machinaut, October 09, 2022, 02:09:58 pm

Previous topic - Next topic

machinaut

I just assembled the kit, and was playing around with it, and managed to get it on the wifi and load some web pages.  I rebooted it a few times and that worked fine.

I tried to make a SD card with the experimental nixos here: https://www.olimex.com/forum/index.php?topic=7186.0 and booted it, but it looks like nothing happened.

When I came back to it a few hours later it was dead, and the power button doesn't turn it on.  (It still doesn't)

The only thing that seems to trigger any activity is plugging in the power supply, which outputs the following over serial and then it dies.

I downloaded the official latest linux image and flashed that to a microSD card and tried to boot from it (by plugging in power), and as far as I can tell that doesn't do anything either.

Any pointers for how to debug or fix would be appreciated.

Serial output from failed boot:
HELLO! BOOT0 is starting!
boot0 commit : 8
boot0 version : 4.0.0
set pll start
set pll end
rtc[0] value = 0x00000000
rtc[1] value = 0x00000000
rtc[2] value = 0x00000000
rtc[3] value = 0x0000a101
rtc[4] value = 0x00000000
rtc[5] value = 0x00000000
DRAM driver version: V1.0
DRAM Type = 3 (2:DDR2,3:DDR3,6:LPDDR2,7:LPDDR3)
DRAM clk = 552 MHz
DRAM zq value: 003b3bbb
rsb_send_initseq: rsb clk 400Khz -> 3Mhz
PMU: AXP81X
ddr voltage = 1500 mv
DRAM init OK
DRAM size = 2048 MB
DRAM init ok
dram size =2048
card boot number = 0, boot0 copy = 0
card no is 0
sdcard 0 line count 4
[mmc]: mmc driver ver 2015-05-08 20:06
[mmc]: sdc0 spd mode error, 2
[mmc]: Wrong media type 0x00000000
[mmc]: ***Try SD card 0***
[mmc]: HSSDR52/SDR25 4 bit
[mmc]: 50000000 Hz
[mmc]: 60906 MB
[mmc]: ***SD/MMC 0 init OK!!!***
sdcard 0 init ok
The size of uboot is 000f0000.
sum=1559c7f1
src_sum=1559c7f1
Succeed in loading uboot from sdmmc flash.
boot0: start load other image
boot0: Loading BL3-1
Loading file 0 at address 0x40000000,size 0x0000b400 success
boot0: Loading scp
Loading file 2 at address 0x00040000,size 0x00019c00 success
set arisc reset to de-assert state
Ready to disable icache.
J9=�    Configuring SPC Controller
NOTICE:  BL3-1: v1.0(debug):0bc348a
NOTICE:  BL3-1: Built : 01:16:30, Jan  4 2017
NOTICE:  BL3-1 commit: 0bc348ab272ad81a4faf128ef38f4724f36fded6

INFO:    BL3-1: Initializing runtime services
INFO:    BL3-1: Preparing for EL3 exit to normal world
INFO:    BL3-1: Next image address = 0x4a000000
INFO:    BL3-1: Next image spsr = 0x1d3


U-Boot 2014.07-5-a64 (Jan 21 2019 - 12:28:58) Allwinner Technology

uboot commit : cc00073832254617ccad07946ea594ea75ef3ef4

rsb: secure monitor exist
[      0.385]pmbus:   ready
[      0.387][ARISC] :arisc initialize
[      0.834][ARISC] :arisc_dvfs_cfg_vf_table: support only one vf_table
[SCP] :sunxi-arisc driver begin startup 2
[SCP] :arisc_para size:1a8
[SCP] :arisc version: [v0.1.76]
[SCP] :sunxi-arisc driver v1.10 is starting
[      1.001][ARISC] :sunxi-arisc driver startup succeeded
[      1.046]PMU: AXP81X
[      1.048]PMU: AXP81X found
bat_vol=4183, ratio=95
[      1.055]PMU: dcdc2 1100
[      1.058]PMU: cpux 1008 Mhz,AXI=336 Mhz
PLL6=600 Mhz,AHB1=200 Mhz, APB1=100Mhz AHB2=300Mhz MBus=400Mhz
device_type = 3253, onoff=1
dcdc1_vol = 3300, onoff=1
dcdc2_vol = 1100, onoff=1
dcdc5_vol = 1350, onoff=1
dcdc6_vol = 1100, onoff=1
aldo1_vol = 2800, onoff=0
aldo2_vol = 1800, onoff=1
aldo3_vol = 3000, onoff=1
dldo1_vol = 3300, onoff=0
dldo2_vol = 2500, onoff=1
dldo3_vol = 1200, onoff=1
dldo4_vol = 3300, onoff=1
eldo1_vol = 1800, onoff=1
eldo2_vol = 1800, onoff=0
eldo3_vol = 1800, onoff=0
fldo1_vol = 1200, onoff=0
fldo2_vol = 1100, onoff=1
gpio0_vol = 3100, onoff=1
vbus not exist
normal dc exist, limit to dc
run key detect
no key found
no uart input
DRAM:  2 GiB
fdt addr: 0xb6ebada0
Relocation Offset is: 75f0d000
In:    serial
Out:   serial
Err:   serial
gic: sec monitor mode
[      1.405]start
drv_disp_init
init_clocks: finish init_clocks.
fdt_get_one_gpio lcd0.lcd_gpio_2 fail
fdt_get_one_gpio lcd0.lcd_gpio_3 fail
fdt_get_one_gpio lcd0.lcd_gpio_scl fail
fdt_get_one_gpio lcd0.lcd_gpio_sda fail
pwm_request: reg = 0x1c21400.pchip->pwm = 0
reg_busy_offset=0, reg_busy_shift = 0, reg_enable_offset = 0
request pwm success, pwm = 0!
sunxi_pwm_config: reg_shift = 0, reg_width = 4, prescale temp = 20, pres=0
PWM _TEST: duty_ns=4980468, period_ns=5000000, freq=200, per_scal=1, period_reg=0x3e703e4
enable power vcc-hdmi-33, ret=0
drv_disp_init finish
boot_disp.output_disp=0
boot_disp.output_type=1
boot_disp.output_mode=4
fetch script data boot_disp.auto_hpd fail
disp0 device type(1) enable
disp 0, clk: pll(456000000),clk(456000000),dclk(76000000) dsi_rate(456000000)
     clk real:pll(456923076),clk(456923076),dclk(76153846) dsi_rate(0)
enable power vcc-pd, ret=0
[      2.625]end
workmode = 0,storage type = 1
[      2.630]MMC:        0
[mmc]: mmc driver ver 2016-09-19 14:00:00
[      2.666]ANX9807 Chip found
[      2.772]..................................clock is detected.
[      2.801]..................................clock is stable.
sunxi_pwm_config: reg_shift = 0, reg_width = 4, prescale temp = 70, pres=0
PWM _TEST: duty_ns=4980469, period_ns=5000000, freq=200, per_scal=1, period_reg=0x3e703e4
sunxi_pwm_config: reg_shift = 0, reg_width = 4, prescale temp = 70, pres=0
PWM _TEST: duty_ns=4980469, period_ns=5000000, freq=200, per_scal=1, period_reg=0x3e703e4
SUNXI SD/MMC: 0
[mmc]: 50 MHz...
[mmc]: sample: 53 - 188(ps)
[mmc]: 100 MHz...
[mmc]: sample: 27 - 185(ps)
[mmc]: 200 MHz...
[mmc]: sample: 13 - 192(ps)
[mmc]: media type 0x0
[mmc]: Wrong media type 0x0
[mmc]: ************Try SD card 0************
[mmc]: host caps: 0x27
[mmc]: MID 03 PSN 85a48027
[mmc]: PNM SN64G -- 0x53-4e-36-34-47
[mmc]: PRV 8.6
[mmc]: MDT m-8 y-2022
[mmc]: speed mode     : HSSDR52/SDR25
[mmc]: clock          : 50000000 Hz
[mmc]: bus_width      : 4 bit
[mmc]: user capacity  : 60906 MB
[mmc]: ************SD/MMC 0 init OK!!!************
[mmc]: erase_grp_size      : 0x1WrBlk*0x200=0x200 Byte
[mmc]: secure_feature      : 0x0
[mmc]: secure_removal_type : 0x0
[      3.379]sunxi flash init ok
reading uboot.env

** Unable to read "uboot.env" from mmc0:1 **
Using default environment

--------fastboot partitions--------
mbr not exist
base bootcmd=run mmcbootcmd
bootcmd set setargs_mmc
key 0
recovery key high 10, low 10
fastboot key high 4, low 4
no misc partition is found
to be run cmd=run mmcbootcmd
update dtb dram start
update dtb dram  end
serial is: 0400503442181819010e
Teres: has ANX9807 chip
Model: teres
PowerBus = 2(0: not exist 1:vBus 2:acBus 3:vBus&acBus)
Battery Voltage=4099, Ratio=95
power trigger
sunxi_bmp_charger_display
reading bat\battery_charge.bmp
89334 bytes read in 10 ms (8.5 MiB/s)
bmp file buffer: 0x41000000, bmp_info.buffer: 47400000
fetch script data boot_disp.output_full fail
screen_id =0, screen_width =1366, screen_height =768
frame buffer address 47400036
set next system normal
drv_disp_exit
[mmc]: MMC Device 2 not found
[mmc]: mmc 2 not find, so not exit
[      7.118]power off
set power off vol to default

LubOlimex

Which image did you use to prepare the card? Is it the one in this archive:

https://ftp.olimex.com/Allwinner_Images/A64-Teres/linux/xenial-teres-bspkernel-20190121_144941_EET-1_hdmi_out_v1_5.zip

Can you try using the free version of balenaEtcher to prepare the card?

Is the the same result?
Technical support and documentation manager at Olimex

machinaut

Yes that is the image and yes balena etcher to flash the card.

Also now (somehow) booting from a card works.  I still don't know what's up with the EMMC, and I would be interested in any guidance for how to decode the UBOOT logs.

LubOlimex

Few pointers:

Did you run the script to transfer it to the eMMC? Does it report any problems?

Is the eMMC visible and accessible when you boot from the card?
Technical support and documentation manager at Olimex