Welcome, Guest

Author Topic: kernel 4.4 no network  (Read 2332 times)

RL_Lange

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
kernel 4.4 no network
« on: January 19, 2017, 01:08:00 PM »
Hello to all,

following problem:
i take the newest official release image (release 5 (Debian 8 Jessie and kernel 4.4.21) and it works.
Now i try to compile the kernel after this guide: "https://www.olimex.com/wiki/AM335x#Kernel"
After finished i changed the zImage (+ modules) and started the board. The Kernel starts an run.
But the network is not working.

/etc/init.d/networking start
/etc/init.d/networking status -->
Jan 01 00:00:07 AM335x networking[113]: bugs on either our web page at www.i...e
Jan 01 00:00:07 AM335x networking[113]: before submitting a bug.  These page...r
Jan 01 00:00:07 AM335x networking[113]: process and the information we find ....
Jan 01 00:00:07 AM335x networking[113]: exiting.
Jan 01 00:00:07 AM335x networking[113]: Failed to bring up eth0.
Jan 01 00:00:08 AM335x networking[113]: Cannot find device "eth1"
Jan 01 00:00:08 AM335x networking[113]: Failed to bring up eth1.
Jan 01 00:00:08 AM335x networking[113]: done.
Jan 01 00:00:08 AM335x systemd[1]: Started LSB: Raise network interfaces..
Jan 01 00:00:33 AM335x systemd[1]: Started LSB: Raise network interfaces..

Can someone help me or has a suitable defconfig for me?
Thanks and best regards
Rene
« Last Edit: January 19, 2017, 04:04:47 PM by RL_Lange »

RL_Lange

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: kernel 4.4 no network
« Reply #1 on: January 20, 2017, 04:15:22 PM »
hi all,

my solution:
the bb-kernel works for me: https://www.olimex.com/forum/index.php?topic=4942.0 -> thanks vinifr

I think the ti-linux-kernel is missing a patch with changes in this file: /drivers/net/ethernet/ti/cpsw.c


Rene

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1752
  • Karma: +45/-2
Re: kernel 4.4 no network
« Reply #2 on: February 03, 2017, 10:36:56 AM »
Which dtb are you using?

There are four dtb files generated. Two of them have NO networking enabled, namely am335x-olimex-som.dtb and am335x-olimex-som-nand.dtb.

Make sure that you use am335x-olimex-som-evb.dtb  (or am335x-olimex-som-evb-nand.dtb if you use a board with extra NAND).

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

thom_nic

  • Newbie
  • *
  • Posts: 28
  • Karma: +1/-0
Re: kernel 4.4 no network
« Reply #3 on: February 03, 2017, 10:19:11 PM »
Issue is not missing pin definitions in the DTS, but possibly missing code in drivers/net/ethernet/ti/cpsw.c ?

I was using the correct -evb.dtb and still had no ethernet - device was not present.

yagabey

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: kernel 4.4 no network
« Reply #4 on: March 10, 2018, 09:00:07 PM »
Hi all,

Is there a fix for this issue on  ti-linux-kernel