Olimex Support Forum

OLinuXino Android / Linux boards and System On Modules => AM3352 => Topic started by: RL_Lange on January 19, 2017, 01:08:00 pm

Title: kernel 4.4 no network
Post by: RL_Lange on January 19, 2017, 01:08:00 pm
Hello to all,

following problem:
i take the newest official release image (release 5 (Debian 8 Jessie and kernel 4.4.21) and it works.
Now i try to compile the kernel after this guide: "https://www.olimex.com/wiki/AM335x#Kernel"
After finished i changed the zImage (+ modules) and started the board. The Kernel starts an run.
But the network is not working.

/etc/init.d/networking start
/etc/init.d/networking status -->
Jan 01 00:00:07 AM335x networking[113]: bugs on either our web page at www.i...e
Jan 01 00:00:07 AM335x networking[113]: before submitting a bug.  These page...r
Jan 01 00:00:07 AM335x networking[113]: process and the information we find ....
Jan 01 00:00:07 AM335x networking[113]: exiting.
Jan 01 00:00:07 AM335x networking[113]: Failed to bring up eth0.
Jan 01 00:00:08 AM335x networking[113]: Cannot find device "eth1"
Jan 01 00:00:08 AM335x networking[113]: Failed to bring up eth1.
Jan 01 00:00:08 AM335x networking[113]: done.
Jan 01 00:00:08 AM335x systemd[1]: Started LSB: Raise network interfaces..
Jan 01 00:00:33 AM335x systemd[1]: Started LSB: Raise network interfaces..

Can someone help me or has a suitable defconfig for me?
Thanks and best regards
Rene
Title: Re: kernel 4.4 no network
Post by: RL_Lange on January 20, 2017, 04:15:22 pm
hi all,

my solution:
the bb-kernel works for me: https://www.olimex.com/forum/index.php?topic=4942.0 -> thanks vinifr

I think the ti-linux-kernel is missing a patch with changes in this file: /drivers/net/ethernet/ti/cpsw.c


Rene
Title: Re: kernel 4.4 no network
Post by: LubOlimex on February 03, 2017, 10:36:56 am
Which dtb are you using?

There are four dtb files generated. Two of them have NO networking enabled, namely am335x-olimex-som.dtb and am335x-olimex-som-nand.dtb.

Make sure that you use am335x-olimex-som-evb.dtb  (or am335x-olimex-som-evb-nand.dtb if you use a board with extra NAND).

Best regards,
Lub/OLIMEX
Title: Re: kernel 4.4 no network
Post by: thom_nic on February 03, 2017, 10:19:11 pm
Issue is not missing pin definitions in the DTS, but possibly missing code in drivers/net/ethernet/ti/cpsw.c ?

I was using the correct -evb.dtb and still had no ethernet - device was not present.
Title: Re: kernel 4.4 no network
Post by: yagabey on March 10, 2018, 09:00:07 pm
Hi all,

Is there a fix for this issue on  ti-linux-kernel