Wifi issues on A13-OLINUXINO-WIFI board

Started by hoyle, June 23, 2013, 07:33:38 PM

Previous topic - Next topic


Maybe that image is setting wrong voltage somewhere?  Who made the image and what voltages does it set I wonder?

People have made mistakes before around that, such as mixing parts of cubieboard & cubietruck.

If you're lucky it simply doesn't work at all but if unlucky then it "works" - sort of - and then later you find maybe things like hot chips.

As I recall it's u-boot in these images that sets the volts and it uses data specific to the board design but it's quite easy to have wrong values.

Similar issues with memory timings/etc e.g. LIME2 is not same as LIME.



Hi John,

Just looking at my A13 board, there's what appears to be a 3V/5V set of jumper pads near the wifi module, fixed at 5V. On the wifi daughter board, at the very bottom, there's a 3V/5V jumper pad set that's also fixed at 5V. So it appears that both are set for 5V, for what it's worth.



Dear all,

After read all of pages, I finally think about something... I write today because as you, I have this connection problem that crashes wifi as soon as the data stream increases. First I wanted to know exactly when it failed to caractérize the fault. In fact, my connection to the console over SSH worked perfectly but, as you, when I tryed an "apt-get update", the wifi crashed.
I first thank about a bottle neck (that is the track to follow I think). Then, I tryed to download a piece by limiting the transfert rate : wget --limit-rate http://... . (If my theory of bottle neck is correct, low rates should work). I started with 1ko/s transfert rate a download a 11Mo file. And it succed. Then I increased the rate to 2ko/s and 5ko/s. At 5ko/s it failed.
After validating this bottle-neck theory, I tried to check first what I could. I found that the speed of usb port was not the same for each.
cat /sys/bus/usb/devices/usb1/speed -> 480
cat /sys/bus/usb/devices/usb2/speed -> 480
cat /sys/bus/usb/devices/usb3/speed -> 12

Even if I don't really know what is the port used by the wifi dongle, I would imagine that a limitation could be possible.

In order to get arround this, I thought about unsolder the wifi dongle, solder an USB plug and try it on the port usb1.

That is what I did and It works now as expected. Here is a console extract where I downloaded a file that crashed previously :

root@a13-OLinuXino:~# wget https://nodejs.org/dist/v4.2.1/node-v4.2.1-linux-x86.tar.gz
--2015-10-15 19:07:00--  https://nodejs.org/dist/v4.2.1/node-v4.2.1-linux-x86.tar.gz
Resolving nodejs.org (nodejs.org)...,, 2400:cb00:2048:1::6814:162e, ...
Connecting to nodejs.org (nodejs.org)||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 11231892 (11M) [application/gzip]
Saving to: `node-v4.2.1-linux-x86.tar.gz.1'

100%[==========================================================>] 11,231,892   719K/s   in 16s

We can see here that 11Mo @ 700Ko/sec works perfectly.

I have now an usb port less but I have wifi... so, please, if you can help me to find out how to set correctly the usb speed it could be great.