Serial USB Problem

Started by Tymoti, September 26, 2015, 11:15:10 AM

Previous topic - Next topic



I have Olimex-A13-SOM with wifi-4gb shield.
I have buy this Usb serial cable

Before I used other board (No Olimex), so i installed FTDI Driver.
I follow this topic Using USB-Serial-Cable-F on a Mac...? on this forum
And before reading this topic, i follow this instruction : PL2303 Serial USB on OSX Lion, USB Serial Console for Raspberry Pi on Mac OSX Lion: Olimex USB Serial Cable and INSTALLING A USB SERIAL ADAPTER ON MAC OS X.

But nothing work, i have already white page in my terminal.

I don't understand why, the drivers are installed :
➜  /dev  ls *usb*
cu.usbserial  tty.usbserial

And, I test on my ubuntu, it's same thing.
And on my Windows 10 with putty :

On windows I Installed the Olimex drivers gave on usb-serial-cable-F

I don't understand why it doesn't work.
My olimex is broke ?

Have a nice week end


sound more like a problem with the usb - serial converter then the board, to test connect the green with white wire and if you type something in your terminal you must see it on the screen


Hi Gerrit,

Thanks you for your answer but, I don't understand what should I do, exactly ?

Thanks you.


the green and white wire from Usb serial cable if you connect them together like with a piece blanc wire, then everything you type in the terminal loops back, if it does then you know the usb serial cable is working al right


Thank you Gerrit,

I tried, so when I write "Hello World" and press Enter, but the terminal doesn't return the words.

So, my usb cable doesn't work ?


it does echo every time you type a letter not just after you press enter, just look what happens without the loop


I don't understand sorry.
what do you mean for "just look what happens without the loop"

Thanks you


if you remove the wire do you still get anything on your screen when you type


I don't know how it is with Linux or MAC, but I know that if you plug in this Prolific USB Serial device into a Windows PC you get this error in the driver. If you reboot your PC with the device still connected, the problem is solved. Don't know why, but this works for me.



Thanks you for your answers.

I resolved my problem when I change cable for FTDI cable :)

I tried win 10 and mac Yosemite.