Wifi issues on A13-OLINUXINO-WIFI board

Started by hoyle, June 23, 2013, 07:33:38 PM

Previous topic - Next topic


And what you mean with help?  :) I have same ifconfig output many times like yours. And many times the connection was broken and errors like one message before... After a whole day playing now mostly only errors. I also have a original SD card and I have a lot with other images too. Everywhere same issue from the first minutes. Android too. I will order tomorrow a other board `cause I want to work and test. Some days and I can check the other board too.


I tested if I comment the auto lines in /etc/network/interfaces than no more enumerate problem. But still can´t connect to a network.

"iwlist wlan6 scanning" found nothing

If I try to connect to a essid with iwconfig (iwconfig wlan6 essid MYSSID) answers "operation not permitted" he? Till now I tested about 5 linux image without any change. I tested with different supply too. If I try to make a apt-get update, upgrade the board restarting mostly after 1-2 minute work. I think something really wrong.


That was all one hw issue. I resoldered first the 2 ram BGA. But the problem was same. And now I resoldered the A13 too. Now everything fine. I hade a lot of restart. If I started X than the board was just every time froozen. Now with the same SD card without change everything running fine.


Its been a while since i was working on the a13, still got the problem with the wifi. I started fresh this is what happened, i have the 7" touch screen on the A13-OLINUXINO-WIFI board with the android 800x480 image on it. the wifi connected and stayed conected until i connected to the play store and the wifi cut out i'm going to try a few things this week to narrow down the issue, but i'm still stumped any help would be appeciated i am a beginer trying to learn.


I still think it's a hardware problem, no one reported a correct operation.


Did you fully disable all power save?



   We are still seeing issues with the wifi for A13 allwinner wifi board using the debian image. We have diabled the power save. I did not see a fix posted yet, any one found a way around ? Also is this wifi router specific ? We are thinking of deploying this to customer sites and we cannot dictate what routers they might have. Is this is bad board (in terms of varied wifi) to begin with ?



What issues?  What happens?  Think and gather actual data.  No-one seems to know if this is software (which it may well be) or hardware.  I doubt it's hardware as it's a very ordinary device.

If you can't figure out how to get data I think it may be worthwhile to join the linux-sunxi list and ask how to go about debugging it.

Also, does it work under Android, with it's annoying (for this) powersave etc full off?  Because if it does then you know it's a software problem.

Apparently Olimex don't see it, so that doesn't help us choose between hardware/software.

If this were an issue for me I'd try to set up more than one board in more than one physical location with different PSUs, routers etc and see if every one always failed, hoping to get clues.

Also, as USB wifi boards are crazily cheap I'd try some others.



I wish this issue would be solved... I am having the same issue. I am running the suggested Debian Image from an SD card... Android Image is also onboard on the chip memory. I am having the exact same problem... wifi connects... as soon as any traffic starts to travel through the wifi, the connection fails and I must reboot to get it back. The time is so short, I cannot even apt-get update, much less apt-get upgrade. This is very very frustrating! I checked in the /etc/modprobe.d/*.conf files and the recommended power mgmnt entries were already in place...

Suggestions... Please!


OK, I adjusted the security settings on my Cisco router and now it works!  Turns out my router was kicking my board out of the network for packet flooding...


Thanks for posting that - someone else may find it helpful!


Michel De Meester


Same over here, wifi module gets really hot and stops working normally (reconnecting all time).

I completely disconnected the board (only connected to VGA display) from power supply (12VDC 1500mA) and battery, waited 'till the wifi module cooled down and restarted everything.

System is playing streaming audio overnight without any problems and wifi module isn't hot anymore.

Started a few times the http://speedtest.telenet.be to generate some intense traffic, the module warms up in a very short time and the wifi connection problems starts immediately.

As an absolute SOC newbie I have no idea what can cause this strange behavior but I'm sure there are some smart people here who can solve this annoying problem.

I have a A20 board runnig seamless and hope I can do the same with the A13 in a place where it's impossible to place a wired Ethernet connection.

Thanks in advance



Quote from: Clem on July 17, 2013, 08:31:54 PM
Thanks but that's not solving the issue.

Hello I've the same problem actually the WIFI connection works but as soon as you try to do an apt-get upgrade or install in other words to fetch data from the web. The WIFI is disconnected.

I think it's because the WIFI PCB becomes too warm. Personaly I can't stand the finger above it.

I try to make an apt-get upgrade by blowing on it and put the board on a cool room about 20°C with air flow.
And it's work.


I had the same WIFI issue (dropping and coming back constantly after a few minutes) on my debian image, and for me blacklisting the rtl8192cu module did the trick. This module produced a kernel Oops on boot, yet was still loaded later on. Now only the 8192cu module comes up, and the connection is perfect even under heavy load.
This is not on the official Olimex image, mine's a debian running in NAND from linux-sunxi 3.4.79, but the issue may be the same on the official image ?


Hi everybody!!
Hi have the same problem with the wifi. The chip is very hot and after a lot of minutes the wifi disconnect, and wakes up just after one reboot.
I'v the last A13_debian_34_75_WIFI_RALINK_GCC_GPIO_X_I2C_100KHz_UVC_TS_FTDI_video_release_9.7z on two same boards with the same problem!
With the NAND android... it's the same!!
HW problem!?!?!?!

What i can do to solve the issue?

(Per gli amici italiani)
Ciao a tutti!!
Ho lo stesso problema cin il WIFI. Il chip è bollente e dopo qualche minuto il wifi si disconnette e si riconnette solo dopo un reboot.
Ho l'ultima distribuzione A13_debian_34_75_WIFI_RALINK_GCC_GPIO_X_I2C_100KHz_UVC_TS_FTDI_video_release_9.7z su due schede identiche ed hanno entrambe lo stesso problema!
Con Android sulla NAND... è lo stesso.

Come posso risolvere il problema/rottura di palle!?



Brand new A13 wifi board with debian image. Wifi runs until you start to downolad data (e.g. install imagemagic with aptitude) the wifi signal strength then drops and the wifi disconnects. When you go back to the wifi access point locater the one you were using is no longer visible. When you select it using the hidden access point function it watns you to re-entering the password for the access point.

Cured with a reboot but then it starts again the next time you do something more with the wifi then ssh to the machine for a terminal session.

Does anybody have a fix or a way to use a usb dongle to access wifi connectivity. I have a client project that needs WiFi and if it doesn't work the Olimex A13 board goes in the bin and we use a Gumstix or a BeagleBone. No time to waste on faulty hardware/software.

Just as an update I have the 8192cu.conf mod in place, a heatsink on the wifi chip and a fan blowing on the heatsink. Still dies in the same way.


If you plug in an Edimax (like the EW-7811UN) it will work without any changes with the last releases. Like all Ethernet chips, it gets warm, but it dissipates the heat through the USB casing.  Just use ifconfig -a to find the new wlanx and change the /etc/network/interfaces file (and comment out the onboard wlanx).
If your problem was really the hardware, you should be able to work with this.