[HowTo] Cross compile Qt5

Started by Cosik, October 27, 2014, 11:17:52 am

Previous topic - Next topic

habanas

December 08, 2014, 06:01:29 pm #15 Last Edit: December 09, 2014, 10:51:35 am by habanas
Hi Cosik
that's my command and result of ./configure , make and make install

./configure -opengl es2 -device linux-a20olimex-g++ -device-option CROSS_COMPILE=/home/preparation/gcc-linaro-arm-linux-gnueabihf-4.8-2013.09_linux/bin/arm-linux-gnueabihf- -sysroot /mnt/a20/ -opensource -confirm-license -optimized-qmake -release -make libs -prefix /opt/qt5.3.2olim2 -no-pch -nomake examples -nomake tests -no-xcb -eglfs -v >logconf.log 2>&1
result (logconf.log) :
https://drive.google.com/file/d/0B-9HldMPXk75SlktTFhVUVA0MFk/view?usp=sharing
and config.summary :
https://drive.google.com/file/d/0B-9HldMPXk75ZHNPMDR5bmxERHM/view?usp=sharing

make >makeconf.log 2>&1 -> result (makeconf.log) :
https://drive.google.com/file/d/0B-9HldMPXk75eVl6bHVobmNxT1k/view?usp=sharing

make install >installconf.log 2>&1 -> result (installconf.log):
https://drive.google.com/file/d/0B-9HldMPXk75TjNGWk44d2Fmc28/view?usp=sharing

Cosik

Hi,

Sorry but I still didn't see anything usefully in this log. I don't know solution of yours problem.

Last thing which you could try is update libc on Lime to version equal or higher to version of your PC.

habanas

Ok thanks for your try Cosik :)
I'm going to try update  libc on my board .

Cosik

So pleas show version of libc on yours PC and Lime before update. If it will help please also let me know. It will mean that this step is also necessary.

habanas

How or where i can find my libc version  i try to search on /lib/* but i cant find libc on my PC or Lime .
And obviously if I progress i will come back to post solution .

Cosik

Quote from: habanas on December 10, 2014, 11:02:28 am
How or where i can find my libc version  i try to search on /lib/* but i cant find libc on my PC or Lime .
And obviously if I progress i will come back to post solution .


You could do it with aptitude:
aptitude show libc6

or dpkg:
dpkg -l | grep libc6

habanas

result on my Lime :

aptitude show libc6
Package: libc6
State: installed
Automatically installed: no
Multi-Arch: same
Version: 2.13-38+deb7u6
Priority: required
Section: libs
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture: armhf
Uncompressed Size: 8,305 k
Depends: libc-bin (= 2.13-38+deb7u6), libgcc1
Suggests: glibc-doc, debconf | debconf-2.0, locales
Conflicts: prelink (<= 0.0.20090311-1), tzdata (< 2007k-1), tzdata-etch
Breaks: locales (< 2.13), locales-all (< 2.13), nscd (< 2.13)
Provides: glibc-2.13-1
Description: Embedded GNU C Library: Shared libraries
Contains the standard libraries that are used by nearly all programs on the
system. This package includes shared versions of the standard C library and the
standard math library, as well as many others.
Homepage: http://www.eglibc.org


root@a20-OLinuXino:~# dpkg -l | grep libc6
ii  libc6:armhf                           2.13-38+deb7u6                     armhf        Embedded GNU C Library: Shared libraries
ii  libc6-dev:armhf                       2.13-38+deb7u6                     armhf        Embedded GNU C Library: Development Libraries and Header Files


result on my PC

aptitude show libc6
Paquet : libc6                               
État: installé
Automatiquement installé: non
Multiarchitecture : même
Version : 2.13-38+deb7u6
Priorité : nécessaire
Section : libs
Responsable : GNU Libc Maintainers <debian-glibc@lists.debian.org>
Architecture : amd64
Taille décompressée : 9 687 k
Dépend: libc-bin (= 2.13-38+deb7u6), libgcc1
Suggère: glibc-doc, debconf | debconf-2.0, locales
Est en conflit: prelink (<= 0.0.20090311-1), prelink (<=
                0.0.20090311-1), tzdata (< 2007k-1), tzdata (<
                2007k-1), tzdata-etch, tzdata-etch
Casse: locales (< 2.13), locales (< 2.13), locales-all (< 2.13),
       locales-all (< 2.13), lsb-core (<= 3.2-27), lsb-core (<=
       3.2-27), nscd (< 2.13), nscd (< 2.13), libc6 (!= 2.13-38+deb7u6)
Remplace: libc6-amd64, libc6-amd64, libc6 (< 2.13-38+deb7u6)
Fournit: glibc-2.13-1
Description : Embedded GNU C Library: Shared libraries
Contains the standard libraries that are used by nearly all programs
on the system. This package includes shared versions of the standard C
library and the standard math library, as well as many others.
Site : http://www.eglibc.org


root@debian:/home/p# dpkg -l | grep libc6
ii  libc6:amd64                           2.13-38+deb7u6                     amd64        Embedded GNU C Library: Shared libraries
ii  libc6:i386                            2.13-38+deb7u6                     i386         Embedded GNU C Library: Shared libraries
ii  libc6-armhf-cross                     2.13-38                            all          Embedded GNU C Library: Shared libraries (for cross-compiling)
ii  libc6-dev:amd64                       2.13-38+deb7u6                     amd64        Embedded GNU C Library: Development Libraries and Header Files
ii  libc6-dev-armhf-cross                 2.13-38                            all          Embedded GNU C Library: Development Libraries and Header Files (for cross-compiling)
ii  libc6-i386                            2.13-38+deb7u6                     amd64        Embedded GNU C Library: 32-bit shared libraries for AMD64
ii  libc6-i686:i386                       2.13-38+deb7u6                     i386         Embedded GNU C Library: Shared libraries [i686 optimized]


Cosik

Hmmm, I compiled it with libc6 2.19, you could try to update it, but I'm not sure if it will help.

habanas

i'm trying to update libc6 but there can't up to 2.19
i need to remove and reinstall libc6 ?

habanas

ok
just add
deb http://ftp.de.debian.org/debian sid main  to  /etc/apt/sources.list
and  update, upgrade

Cosik

Quote from: habanas on December 10, 2014, 01:24:01 pm
ok
just add
deb http://ftp.de.debian.org/debian sid main  to  /etc/apt/sources.list
and  update, upgrade


hmmm, I think that was not so good idea. Is yours board still running?

habanas

it's the only one solution I've found to update libc6 on my Pc and Lime
So, now i've same libc6 v 2.19 on my board and PC I'm going to try recompile :)

habanas

alright !
Christmas has passed so i return on my compilation.
after update my libc6 i'm trying to recompile, but again i have same error at the compilation.
So I trying to reproduce u'r step on linux debian 32 bits (not 64 bits) and I dont know why ? it finally works fine .

thank you very much for your help cosik .

sm2wmv

March 13, 2015, 02:30:08 am #28 Last Edit: March 13, 2015, 02:35:01 am by sm2wmv
I am having trouble with this when trying to compile QT5.

Running configuration tests...
Warning: Disabling pkg-config since PKG_CONFIG_LIBDIR is not set.
Warning: Disabling pkg-config since PKG_CONFIG_SYSROOT_DIR is not set.
The OpenGL ES 2.0 functionality test failed!
You might need to modify the include and library search paths by editing
QMAKE_INCDIR_OPENGL_ES2, QMAKE_LIBDIR_OPENGL_ES2 and QMAKE_LIBS_OPENGL_ES2 in

I am not able to find or figure out how to get or build the opengl es2 libs for ARM.

How I configure,
./configure -opengl es2 -device linux-olimex-am335x-g++ -device-option CROSS_COMPILE=/home/micke/gcc-linaro-arm-linux-gnueabihf-4.8-2013.09_linux/bin/arm-linux-gnueabihf- -opensource -confirm-license -optimized-qmake -reduce-exports -debug -make libs -prefix /opt/qt5.3.2

I want to get a cross compilation version of QT for the new AM3352 board so I can remote deploy the QT applications.

habanas

Can you send your qmake configuration
So for install opengl es2 you can use this link : http://linux-sunxi.org/Mali_binary_driver and folow each step.