Powering the LIME2 via USB_OTG

Started by mboes, November 29, 2014, 05:40:57 pm

Previous topic - Next topic

mboes

November 29, 2014, 05:40:57 pm Last Edit: November 29, 2014, 06:43:54 pm by mboes
Hi,

I purchased two LIME2 boards this week. I can't boot either of them using the USB_OTG connector and I'm dumbfounded. I've tried several different mini-USB-to-type-A cables but none work. Nothing happens (no green light, no red light) on the board when I plug the cable in, or when I press the PWR button (for 5 seconds or more), no matter the USB port I try on my desktop computer, or even using a 4A USB hub plugged to the wall socket.

What am I doing wrong?

I should add that these boards are the A20-OLinuXIno-LIME2-4GB model, so with an onboard NAND chip (hence no need for an SSD card I presume).

https://www.olimex.com/Products/OLinuXino/A20/A20-OLinuXIno-LIME2-4GB/open-source-hardware

MBR

Did you try to power it by the DC barrel connector?

JohnS

I expect it can't get good enough power via USB.

+1 to try proper power via power jack.  Use a good supply at least stable 2A and don't power anything else until tested.

John

mboes

I haven't tried powering the board via a DC barrel connector, but I'm having a hard time finding an adaptor of the right voltage. I've tried a number of different USB ports. Has anyone else had any success powering via USB, or is everyone using the DC barrel connector?

quidame

I own a a10-OLinuXino-Lime and a a20-Lime2. For both, supplying power through
USB-OTG works as well as through the DC barrel. The red LED beside the DC barrel
does not light when the board is powered from USB OTG (or from battery), but all
works fine (also battery charging). So yes, there is nothing showing that the
system is running or not; but it is (it should).

sapiensantiquus

December 07, 2014, 04:43:01 am #5 Last Edit: December 07, 2014, 04:47:49 am by sapiensantiquus
I have a similiar problem. Just got the LIME this week, and it seemingly doesn't stay powered. I'm using a 5V 2A power supply (with the USB OTG). I'm trying to use the Debian image on a SD card (I've tried both releases). It seems like it starts to boot, I see a green light on, and I see the Linux logo and Olimex appears on the screen, but then light turns off, and nothing appears on the screen again.

JohnS

December 07, 2014, 05:11:47 pm #6 Last Edit: December 08, 2014, 08:21:55 pm by JohnS
Maybe the supply doesn't work as it claims.

Often they don't hold the voltas (edit: I mean volts) up properly.

John

MBR

December 08, 2014, 06:20:51 pm #7 Last Edit: December 08, 2014, 06:23:03 pm by MBR
To get "hard" 5V power source with large maximal current for testing, try a PC power sources (PSU), especialy an old one from time of Skt370 and SktA (the ones without four-wire yellow-and-black auxiliary 12V "P4" cable), because they had very strong 5V output (on modern PSUs, the strong one is the 12V output). You can find 5V between red (positive) and black (negative ground) wires and to power the PSU on, connect the green and (any) black wires on the main 20/24 pin connector with piece of wire (my favorite is a half of a metalic paperclip :-) ).

kpapak

I see strange behaviour in my LIME2 board regarding its power up via the USB OTG in NAND mode. Both SD boot and NAND flash boot work properly when I power up the board via the DC barrel.

When I boot from the SD card I can power up the LIME2 board via the USB OTG connector. Then, I can successfully do SSH login via the USB OTG port (or the Ethernet port). So far so good.

But, when I boot from the NAND flash I cannot power up LIME2 via the USB OTG. The green led does not flash, neither I can do SSH login (USB OTG or Ethernet). I connect the DC barrel and the board becomes functional. Then, I remove the DC barrel and the board still remains powered up (via the USB OTG).

Could you explain this weird behaviour and provide a proper solution how to power up the MOST expensive flavor (NAND) of the LIME2 board using only the USB OTG?

Kostas

Iñigo

Hi,

Same happens to me. I have the NAND version. When I tried to install the OS I via the OTG nothing happens so I used the barrel and it works nice.

In that moment I supposed that it was because the port was used for installing the img but always I've tried to power it from the OTG port it never boots.

I thing it is a design bug in the NAND version.

What I would like to know if there are plans to correct it for the future.

Iñigo

JohnS

January 22, 2016, 11:16:17 am #10 Last Edit: January 22, 2016, 11:21:05 am by JohnS
In case it's hardware then it's maybe that board needs too much start-up power.  (I'm doubtful it's this reason.)
Else if hardware, perhaps PMU or BROM, so no fix is likely.

To me it looks like software, however.  Might be uboot, or kernel.  Depending on your skills may be easy/hard to find/fix.

I'd maybe try a few versions of Android / uboot and only then Linux to see if it always happens / to get any clues.  And then start looking in depth to find why / how to fix.  printk may be useful

Might be worth trying OTG cable both with and again without ID in case one works and not the other.

John