A20 Micro - USB OTG problem

Started by vbdasc, January 14, 2016, 07:12:54 pm

Previous topic - Next topic

vbdasc

January 14, 2016, 07:12:54 pm Last Edit: January 14, 2016, 07:17:29 pm by vbdasc
I have a problem with the USB OTG port on a newly bought A20 Olinuxino Micro. Basically, the problem is that it works when it wants, for both powering the board and controlling it with SSH through RNDIS. The first couple of days it mostly worked, but after 20 or 30 boots I noticed that the SSH shell sometimes stopped working; at the same time, the RNDIS network connection icon in my Windows PC indicated "no connection" or "disabled" state, After rebooting the PC, the A20 Micro board or both the problem usually disappeared. Lately, this started happening more often; and also the USB OTG started to be unable to power the board. Basically, I plug the USB cable, the board powers for a second and then switches off. I tried three different PCs, as well as two 5V wall chargers with USB output, with the same luck. So I had to resort to a wall charger with barrel connector, which powers the board fine, and SSH through the Ethernet port. But is it possible for the USB OTG port to deteriorate over time or is it some sort of coincidence? Thanks in advance.

P.S. I forgot to say that I use the Debian 2G Jessie release 11 standard image, if it matters for the RNDIS issue.

soenke

My guess is, that the mainboard of your PCs is not supplying enough power. Some chips cant be run at max. performance all the time so yes, it is possible that this problem deteriorates over time or maybe your USB-Chip is simply overheating.

Some mainboards have explicit "power ports" which can deliver more than just those 5W or can at least sustain this over a longer period of time.

The past shows that it is way more stable to use a quality 5V-power supply with at least 2A than to use OTG for powering these boards.

MBR

IMHO the easiest way to diagnose is to use a powered USB hub - it the problem goes away, it was really a power issue.