Wifi issues on A13-OLINUXINO-WIFI board

Started by hoyle, June 23, 2013, 07:33:38 pm

Previous topic - Next topic

hoyle

I have just got myself a A13-OLINUXINO-WIFI board with 7inch touch screen. I'm new to working with this kit so have started out just seeing the basics of what it can do, i've put the android 800x480 image on the board and the touch screen it all works perfectly.

The problem im having now is working out an issue with the wifi im not sure if it is a hardware or software issue. the board connects for a while then disconnects then reconnects and so on.

Any help and advice would be much appreciated.

agustin_nrtk

I have the same problem and I think it's a hardware problem.
The WiFi module warms up!

jwischka

Are you running Android or Linux? FWIW, I experienced this behavior before disabling the power save and standby functionality in the kernel.

hoyle

agustin_nrtk glad im not the only one on the hard ware side of things i'm looking at possable cooling techniques will post when i work something out.

jwischka i'm running android, i'm looking into adjusting the kernel, any recomendations on best programs would be much apeciated

thanks for both your replies

JohnS

Are you sure it's not Android causing it?  It really does sound to be the cause.

John

hoyle

I think it is android causing the problem, im looking at differant ways to sort out the issue.

LubOlimex

Hey guys,

We've been hearing about this problem but strange enough this WIFI disconnects never happen over here (and we have a number of A13 boards connected almost always).

@agustin_nrtk - the warming is normal, considering the number of PCB layers and the dimensions

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

hoyle

I've been doing a bit of research and found that there is an issue with some android devices and the BT Home Hub 3, which happens to be the one I have, if anyone else has the disconection issue with BT Home Hub 3 I'd be intrested to hear about it and if anyone has sorted it out. my next plan is to see if the wifi from my A13 will conect to my phone and run through that if it does i know its he Home Hub3

modlfo

Hi I'm having the same problem. I use the debian image provided by Olimex. I didn't have this problem before, the WIFI was working great, but suddenly start happening.

Any solution yet?

hoyle

Still trying to sort this problem will post solution anf fix as soon as

leo16781

Hi All ,

I'm planning to buy A13-OLINUXINO-WIFI board for my development / learning purpose. After going through this thread , I find that this board has WIFI issues and it also does not have ethenet . Is there any alternative to for connecting to internet with board ?

Also is there any other issues with this board ?

Please let me know all your reviews and comments .

olimex

I count 3 people with issue out of thousands A13-WIFI users, is this a problem? they may have WIFI router incompatibility or software issue or power supply issue

jwischka

Quote from: olimex on July 17, 2013, 04:06:00 pm
I count 3 people with issue out of thousands A13-WIFI users, is this a problem? they may have WIFI router incompatibility or software issue or power supply issue


I experienced the issues with 3 different routers, so I suspect that's not the problem. Again, to me it seemed like there might be an issue with waking from power save, as the problems disappeared when I disabled that in the kernel - but honestly I didn't spend any real time trying to figure out what the problem was, especially after disabling power save fixed it.

Personally, I would be much more concerned about the high rate of dropped packets on the wireless adapter, and the low throughput issues in general.

Clem

Same issue here tried on both Debian and Android with multiple AP.

I Hope it's just a software issue...

jwischka

Quote from: Clem on July 17, 2013, 07:33:43 pm
Same issue here tried on both Debian and Android with multiple AP.

I Hope it's just a software issue...


Clem - you might try the fix at the bottom of this page and see if it works for you, if you're not running a kernel with power save disabled by default.