June 02, 2020, 03:56:11 pm

Recent posts

Pages 1 2 3 4 5 ... 10
ESP32 / ESP32 Pro Memory Map
Last post by 247it - May 29, 2020, 04:29:40 pm
Could you tell me how the memory is mapped between the 32Mb SPI flash
and the 32Mb PSRAM please

Do you have any example programs and/or a sample partitions\default.csv

ESP32 / Re: ESP32-EVB ethernet looses ...
Last post by SejnyM - May 29, 2020, 02:25:24 pm
SSR relay solve problem. No contacts = no bouncing/arcing
ESP32 / Re: ESP32 PRO Pinout
Last post by 247it - May 29, 2020, 01:34:45 pm
Can I ask which IO pins are free on the ESP32 pro please ?
A20 / A20-OLinuXino-Lime2 as GPRS mo...
Last post by mbosschaert - May 29, 2020, 12:52:48 pm
I'm trying to build a system to remotely monitor my holiday house. There is no telephone landline but 4G GSM/GPRS is fairly good. Over the last 2 years I did some testing but have not been able to build a solid system.

The hardware I used:
  • A2-OlinuXino-Lime2
  • MOD-WIFI-AR9271

The software used:
  • a20-lime2_mainline_uboot_sunxi_kernel_3.4.103_jessie_eMMC_rel_15.img
  • wvdial
  • hostapd
  • and all required drivers for the hardware, like atheros-firmware,etc
  • usb-modeswitch (to make sure the MOD-USB3G is recognized as modem, not as storage)

With this setup the system usually remained stable for a couple of days or weeks, but suffered from frequent drops in ppp connection. To ultimately be able to have connection on a daily basis I programmed random reboots and random MAC-changing as the GSM provider apparently does not like continuous connections.

As finally this system was not reliable enough (completely failed to connect to the provider after some weeks with no apparent causes in the log files) I decided to rebuild it with the newest buster image of Olimex (A20-OLinuXino-buster-minimal-20200417-095756). Also I moved from wvdial to pppconfig as I could not solve the Device-busy warnings other than by rebooting.

So currently I'm rebuilding the system and I'm at the point that the wifi accesspoint (hostapd, iptables maquerading and dnsmasq) works fine. The pppd configuration, triggered by pppconfig, works by starting and stopping with pon/poff. And the GPRS connection seems to be fairly stable, as far as tested. Actually this topic is written while connected through the system which now actually functions as a wifi/GPRS router. The only hurdle I have to take now is the fact that the device (ttyUSB0) is not ready at the moment that the network interface ppp0 is activated. Even though the interface is configured as auto-start (auto ppp0), and pppd is configured as 'persistent' the connection is not initiated.

How can I get around this and make sure that /dev/ttyUSB0 is registered before pppd gets started.

Here some backgound info:
dmesg | grep ttyUSB:

May 26 22:49:37 A20-OLinuXino-HA-001 pppd[998]: Connect: ppp0 <--> /dev/ttyUSB0
May 26 22:50:35 A20-OLinuXino-HA-001 pppd[1158]: Connect: ppp0 <--> /dev/ttyUSB0
May 28 23:56:13 A20-OLinuXino-HA-001 kernel: [   29.136033] usb 4-1: GSM modem (1-port) converter now attached to ttyUSB0
May 28 23:56:13 A20-OLinuXino-HA-001 kernel: [   29.137834] usb 4-1: GSM modem (1-port) converter now attached to ttyUSB1
May 28 23:56:13 A20-OLinuXino-HA-001 kernel: [   29.141601] usb 4-1: GSM modem (1-port) converter now attached to ttyUSB2
May 28 23:56:33 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590702993.9922] modem["ttyUSB2"]: modem state changed, 'disabled' --> 'enabling' (reason: user preference)
May 28 23:56:33 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590702993.9943] manager: (ttyUSB2): new Broadband device (/org/freedesktop/NetworkManager/Devices/6)
May 28 23:56:34 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590702993.9975] device (ttyUSB2): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
May 28 23:56:34 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590702994.0015] device (ttyUSB2): modem state 'enabling'
May 28 23:56:34 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590702994.0120] device (ttyUSB2): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
May 28 23:56:34 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590702994.8718] modem["ttyUSB2"]: modem state changed, 'enabling' --> 'searching' (reason: user-requested)
May 28 23:57:56 A20-OLinuXino-HA-001 NetworkManager[561]: <info>  [1590703076.3326] modem["ttyUSB2"]: modem state changed, 'searching' --> 'registered' (reason: unknown)

root@A20-OLinuXino-HA-001:/var/log# cat /etc/network/interfaces.d/ppp0
allow-hotplug ppp0
auto ppp0
iface ppp0 inet ppp
provider myProvider

cat /etc/ppp/chap-secrets
ppp     *       ppp
cat /etc/ppp/options
asyncmap 0
lcp-echo-interval 30
lcp-echo-failure 4
cat /etc/ppp/pap-secrets
*       hostname        ""      *
guest   hostname        "*"     -
master  hostname        "*"     -
root    hostname        "*"     -
support hostname        "*"     -
stats   hostname        "*"     -
"ppp" myProvider "ppp"
ppp     *       ppp
cat /etc/ppp/peers/myProvider
connect "/usr/sbin/chat -v -f /etc/chatscripts/myProvider"
user "ppp"
remotename myProvider
ipparam myProvider
cat /etc/chatscripts/myProvider
'' ATZ
OK AT+CGDCONT=1,"IP","internet.myProvider.com","",0,0
OK-AT-OK "ATDT*99*#"

Just for the context: if this is solved, the next steps will be to configure mosquitto (and my mosquitto clients who report status of mains power, temperature, etc) and to build 2 ssh tunnels to my local server. One tunnel to safely communicate mqtt messages. The other tunnel will be 'reverse' to enable to login from my local server and perform maintenance. Reason for the necessity remote tunnel is that my GPRS provider will not give me a fixed IP address.
A20 / Re: Install LXDE for Debian Bu...
Last post by LubOlimex - May 29, 2020, 11:44:01 am
Try to disable serial-getty service?

Or maybe you want auto-login?

There is some info about getty:


A20 / Re: Questions about new mainli...
Last post by LubOlimex - May 29, 2020, 11:32:02 am
Can you try apt update and apt upgrade and check if the serial issue persists?

You can't boot from external hard drive but you can transfer the file system there. I've added in our list of features requested, will see what we can do it to add in the scripts as an option to copy the file system to a hard drive.
A20 / Re: Problem at boot
Last post by Tibo - May 29, 2020, 11:22:43 am

I bought one, it works fine now.

Thanks !
ESP32 / Re: ESP32-EVB ethernet looses ...
Last post by LubOlimex - May 29, 2020, 11:07:42 am
Sounds like the typical problem with electromechanical relays when switching big loads. Sparking and so on. And this is combined with the poor behavior of the Ethernet chip after ESP32-EVB board reset, which sometimes doesn't start (an issue that persist only in ESP32-EVB of all Olimex-made ESP32 boards and we are currently unable to solve it without major changes in the hardware specifications of the board).

Distance between relays and solenoid might play a role. Try increasing the distance as a test.

Try adding RC snubber, read here: https://electronics.stackexchange.com/questions/42131/how-to-design-an-rc-snubber-for-a-solenoid-relay-driving-an-inductive-load

Check more for more ideas about typical problems with such relays: https://delcon.fi/typical-problems-relating-electromechanical-relays-and-optocouplers

A20 / Re: Install LXDE for Debian Bu...
Last post by zeallin - May 29, 2020, 05:32:16 am
Hello my friend,

I have spent several days tested the latest version of A20 images. They are downloaded from http://images.olimex.com/release/a20/:

Hardware: Olimex A20 LIME2 1GB / T2

Ubuntu Bionic:
Source: A20-OLinuXino-bionic-minimal-20200417-095800.img.7z

- 1. boot after about 10 hrs, desktop become very very slow
- 1.1 Open a terminal need to wait more than 1 min

- 1.2 Console command very very slow
- 1.2.1 Try df command at 15:41:21

- 1.2.2 No response until 15:42:43

The time panel freezed at 15:42:43 after then....

- 1.3 Can not connected to WIFI

Debian Buster:
Source: A20-OLinuXino-buster-base-20200417-113854.img.7z

I used to test the minimal version of Buster and it doesn't have X. After then I tried the base version and found that it have Xfce4 installed. I think this difference should be documented and announce to developers.

For the Buster image, it have a strange problem.
- 1. Sometimes when boot or reboot it ran into a login console, but actually we can not login. It freezed after entered the username "olimex".

But after reboot again, it can boot to X normally

- I have successfully install LXDE Core to Buster

- Test with Panasonic TH-43HX750W, which supports CEC 1.4
- By installed v4l-utils, cec-ctl command works perfectly from /dev/cec0 (Both Bionic and Buster)

Some Conclusion:
- Both Bionic and Buster (base) runs Xfce but not running smoothly in 1080p
- Xfce in Bionic run slower and slower as time goes by
- Buster base boot to console login randomly, but after reboot may become normal

For our development, we currently go for Buster base with LXDE-Core, but need to find a way to prevent it boot to console login. Any suggestions will be very appreciate!

PIC / Re: PIC-WEB development
Last post by ArnoldGoat - May 29, 2020, 04:02:06 am
Thanks, but the 64-bit driver will not load into my Windows 10. The links indicate that early versions of the Microchip ICD2 aren't compatible. Maybe the same thing applies to the Olimex one? It does however work with a USB-to-serial adaptor, but I will get the PIC-KIT3.

Please confirm PIC-KIT3 will work with PIC-WEB Rev A and IDELAB 8.92 before I buy.

A second question, if I may?

I have 2 PIC-WEB cards, but they have the same MAC address, so I can only have one on my network at a time, unless it is possible to reset the MAC address. Can I?
Pages 1 2 3 4 5 ... 10