MSP430-JTAG-ISO-MK2 "target communication error"

Started by mzeotech, January 27, 2020, 11:37:17 AM

Previous topic - Next topic


Good afternoon. I am your client from Ukraine
I use a translator.
Faced such a problem when writing a program to the microcontroller, the programmer began to generate an error "target communication error"
I have 5 devices. 2 of them a week ago, not at the first attempt, but they were successfully stitched. But now they will not flash.

Attaching photo


What is the state of the LEDs - they can further indicate the source of the issue? Refer to page 11 of this document:

What is the target chip exactly?

Are you using stand-alone mode?

Check if these thread applies:
Technical support and documentation manager at Olimex


-the yellow LED blinks while trying to record


-Yes, I use stand-alone mode

-looked that topic before creating your own. Unfortunately, changing the values of "erase" and "blank" to 0 - did not give anything


Surely similar cases were with other users. Please help me figure it out.


are you sure your chip is not locked? if the JTAG fuese is burn there will be no more communication, MSP430 jtag fuse physically separates the JTAG


Quote from: olimex on January 29, 2020, 06:15:32 PMare you sure your chip is not locked? if the JTAG fuese is burn there will be no more communication, MSP430 jtag fuse physically separates the JTAG
Means the chip fuse I'm trying to flash? How to check it?
I have chips purchased in 2014, 2018, 2020
I used to remember exactly, then they could be re-flashed. Even a week ago, one of the old chips was reflashed.

I still think something happened to the programmer.

For example, when I connect it to the computer, in debugger mode - in the device manager it appears as "usb serial divice", and the Olimex MSP Programmer does not see it.


Did you use the same PC and the same JTAG in debugger mode successfully before?

Maybe you changed the USB port at some point? This might lead to drivers being blocked, if that is the case either try the other USB ports of the PC or re-install the drivers (this requires temporarily disabling the Windows Device Signature enforcement). Also it is not clear if the unit works with USB 3.0 ports.
Technical support and documentation manager at Olimex


No, I have never used the programmer in debug mode before. I always copied the firmware to a flash card and in stand alone mode, flashed soldered products.

I tried other ports and port 3.0 - everywhere the device connects as "usb serial divice (com6)"

upd / downloaded the driver and program on another pc and he saw the programmer. But if I try to write the program to the chip, it displays the message "could not write to device flash CODE memory!"


Tested today with similar target MSP430F1611, worked fine here. Make sure you have placed newest DLLs in the Olimex MSP430 programmer software folder. Refer to the three pictures here:


In my pictures you can see I successfully read and programmed MSP430F1611. So the problem should not be in the environment, and it shouldn't be a compatibility problem between the programmer and the environment.

The problem can be in the firmware version used so make sure you have placed same dll (version in Olimex MSP430 programmer's folder, as seen in my screenshot). Then try to program again. Also make sure the settings of the Olimex MSP430 programmer (ticks and checks and selections) are the same as my screenshot. If you have done these two configurations similar to me and the problem remains then probably the chip is locked for further programming or programming is not possible for some reason.

If the problem remains and you can't identify it, my advice is to try with a brand new chip and check if that one can be read and programmed at least one time. If the does - then the issue is somewhere in the code. If a brand new chip doesn't program then probably MSP430-JTAG-ISO-MK2 is somehow damaged. Consider reading our warranty and returns policy here:
Technical support and documentation manager at Olimex