MSP430-JTAG-ISO-MK2 Doesn't mount in Mass Storage mode

Started by skot, November 27, 2019, 05:33:17 AM

Previous topic - Next topic


I'm running Windows 8.1.

Whenever I put my MSP430-JTAG-ISO-MK2 in Mass Storage mode, I get a message in Windows "You need to format the disk in drive E: before you can use it."

If I click format, it fails.

My goal here is to use the device in standalone mode to read firmware from my MSP430F5359, and then be able to mount the MSP430-JTAG-ISO-MK2 in mass storage mode so I can read the OPJ file. I believe this is what is suggested in the MSP430-JTAG-ISO-MK2 user's manual on page 20.


I should add that Ideally I could load new firmware onto the MSP430-JTAG-ISO-MK2 using mass storage mode, that I could then program in the field using standalone mode.


It is quite likely that the SD card inside either got disconnected by mechanical force or got somehow damaged under unknown circumstances.
My recommendations are:
1. Try to upload latest firmware for the MSP430-JTAG-ISO-MK2. It is located here: ; please refer to page 7 of the user's manual for instructions how to do it:

If it still doesn't work as supposed after try the following:

2. Try to open the box carefully and check if the SD card is properly set in place or if it works. Try to format it. If it doesn't work at all just replace it with another SD card. Note that we don't recommend opening the device, so if you think you lack the required skills I recommend you to return the board for a repair. More information about warranty and off-warranty repairs might be found here:

If the problem persists please contact us over for further instructions or support.
Technical support and documentation manager at Olimex


1. I went through the process of uploading the latest firmware (2.007) as indicated on pg. 7 of the manual. CCS (Version 6.0.0) programs/debugs my MSP430 fine when in debugger mode, however I am not prompted for firmware update.

2. I think the SD Card is seated properly. In standalone mode I can read and write from internal memory to my MSP430F5359.

* I tried removing the SD card from the MSP430-JTAG-ISO-MK2 and formatting it in my computer as MS-DOS (FAT) which worked.
* I then replaced the SD Card in the MSP430-JTAG-ISO-MK2 and put it in mass storage mode. The mass storage mounted on my computer and was empty as expected.
* Next I put the MSP430-JTAG-ISO-MK2 in standalone mode and read the firmware from my MSP430F5359
* then I put the MSP430-JTAG-ISO-MK2 in mass storage mode and my computer was unable to read the volume, as before.

I also tried the above process with a new SD Card, and had the same result.



What bugs me is that it reads fine. If it is a hardware problem - the whole SD card part would not work. The stand-alone mode would not read the target successfully. Why just the mass storage mode doesn't work? As I see it, this would happen only if it is some problem with the USB cable, the mass storage drivers, the USB port, insufficient powering from the USB, something like that.

I feel like the USB mass storage drivers are wrong or missing in Windows 8. Can you try to go to "Device Manager" and find the entry for the ISO-MK2 (when connected to the PC and set in Mass Storage Mode, of course) - then right-click over it and uninstall. Then disconnect and re-connect the JTAG-ISO-MK2, hopefully this time the proper drivers would get installed.

Might be worth testing with another USB cable or port, if possible with another PC too, that would be a definitive test.

I tested it today - I followed the algorithm that you described - it doesn't behave like that here. Don't have the same chip but I tested with MSP430FR5739 and MSP430F2274. I also tested on two computers with native Windows 7 and Windows 10. You can check it here:
Technical support and documentation manager at Olimex