STMP157 + EVB Backup?

Started by bobart, May 31, 2024, 10:38:37 AM

Previous topic - Next topic


I have cut the first boot; the installation of the olimage... I didn't know that it corrupt the board...
Now I can't install the olimage on my STMP157 with his evb socket... I have a ttyUSB0 which appear, I can connect to this port, I do it  with screen software, and  I see just an underscore which toggle without keyboard acces...?
I tried to do a backup with connected the backup pin with the closest pin... No way.

Thanks for your help.
PS: I haven't find the category to pôst about the RT1010py ucontroller?


Which board exactly do you have? We have STMP157-SOM and STMP157-BASE-SOM...

Re-write the card with the latest official image and try again? Refer to the Olimage guide here:
Technical support and documentation manager at Olimex


Hi LubOlimex,

I have the STMP157-BASE-SOM and his EVB . The USB-serial BB-CH340T for the link.
I have rewrited twice the sdCard...
AT the first connection, I wasn't on a computer with a web acces, it was just to test... I didn't known, I stopped the alimentation during the process, after seen the boot starting...   :P
I tried alls differents kinds of the boot switch... Does it change anything? I use the sd-card configuration (boot0-on, boot1-off, boot3-on, gnd-on).

Thanks a lots.


Boot selection jumper is described in the schematic, download the schematic export and look at the left side in the middle (in the "Boot Selection" box):
Technical support and documentation manager at Olimex