Olimex STMP1 LIME - Error starting up

Started by Gaël, May 21, 2024, 03:04:58 PM

Previous topic - Next topic

Gaël

Hi Olimex!

I have random boot error at starting up with SMTP1 LIME.

On micro power cuts, some boards don't restart.
On 20 STMP157-OLinuXino-LIME2H-EXT (Rev_B) boards in production approximately 5 boards remain frozen after thunderstorm (its are distributed in several places so its do not suffer exactly the same power cuts).

I never have this problem when I reboot a board with a "shutdown -r now" (or "shutdown -r 00:00").

I did some tests and after some power cuts, the board stay frozen on :

U-Boot SPL 2021.04+olimex-1-20240312.134658 (Mar 12 2024 - 13:48:01 +0000)
Model: STM32MP1 OLinuXino-LIME
Init AXP209 PMIC
VDD Core set to: 1350 mv

When the board is frozen, the reset button don't help, the error returns.
A quick power cut doesn't help either.
For the error to disappear, the board need to be unplugged several seconds.
Quick power cuts seems to cause the problem every time.

NB1 : I tried with 1 A and 2 A power supply.

NB2 : I can't use LiPo battery to protect boards against micro power cuts because LiPo are not safe enough in the hot environments where boards are used (wood boiler).

NB3 : I did some tests with the https://ftp.olimex.com/TEMP/SOM-NO-AXP209/STM32MP1-OLinuXino-SOM-bullseye-minimal-20240328-133932.img.7z and I can't reproduce the problem with this image even with quick power cuts.

LubOlimex

The quick power cycle issue is expected behavior. I can replicate it on every board 100% of the time myself. It can't be fixed completely. There are few workarounds like using a battery or another source of power or disabling AXP209.

Using the modified SOM image without the AXP209 support on the LIME2 board would will lead to problems. The boards are different.

I can ask our Linux developers to make image for the STMP LIME2 board without AXP209 support (similar to the image we made for the STMP SOM board), however can you describe what interfaces and connectors of the LIME board do you use in your setup? Some things will not work without the AXP209 support. I believe the HDMI will not work among others.
Technical support and documentation manager at Olimex

Gaël

> Using the modified SOM image without the AXP209 support on the LIME2 board would will lead to problems. The boards are different.

Indeed I notice a lot of problems with the SOM image but I was able to see that the startup problem disappeared.

> I can ask our Linux developers to make image for the STMP LIME2 board without AXP209 support (similar to the image we made for the STMP SOM board), however can you describe what interfaces and connectors of the LIME board do you use in your setup?

I never use the HDMI and the LiPo battery connector.
I always use the ethernet interface and MicroSD card connector.
MicroSD cards will be replaced by Flash modules soon.
I often use USB port (for Modbus with RS485 or RS232 converter).
I use CAN bus sometimes.