powerlan unreacheable while charging

Started by binutzu, September 02, 2020, 10:12:17 PM

Previous topic - Next topic


Hello Olimex and users,

every time i charge my Teres-I at home (i tried various sockets) my powerlan stops working and the computers connected to it become unreachable. As soon as i disconnect Teres from the charger i can ping again the powerlan connected machines.

I know power chargers and other electrical appliances may cause problems to powerlan networks - but you know, in my household it only happens with Teres ...

What could be the reason for disturbing the powerlan?

I thought to try out another power supply, for example a USB (3A) one together with an adapter cable (USB to coax). What is the exact coax plug dimension i need to look for? What are the chances of solving my issue?

Thanks in advance


Technical support and documentation manager at Olimex


Thanks for the information.

I was wondering if the compatible power adapter offered now by Olimex as spare part is a newer/different version than the one i already have? I bought my kit right after the launch in 2017.


if you can locate 5V 3A adapter which do not affect your powerlan, the easiest way is to cut the TERES-I adapter cable and to solder it to the new adapter


I can confirm that using another power supply solved my problem and the battery charges fine.
Fortunately, no cutting: found a cable with USB and coax connectors and used a USB power supply.