Welcome, Guest

Author Topic: MSP-430-JTAG-ISO-MK2 Stuck in Debugger mode  (Read 1139 times)

Flukefixer

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
MSP-430-JTAG-ISO-MK2 Stuck in Debugger mode
« on: March 31, 2017, 05:37:42 PM »
Hi. I have just bought an MSP430-JTAG-ISO-MK2 and it appears to be stuck in debugger mode. At power on (either via USB or +12DC) it goes straight into the Debugger mode (MCU UNKNOWN, Power EXT etc.) rather than displaying the main menu as shown on page 12 of the user's manual. If I press the MODE button I do then see the main menu screen with arrows at either side of >debugger<. I can scroll to Mass storage or Stand alone. If I select either of those the unit 'initialises' as it does when first powered up but still comes back in debugger mode. I have read and verified an MSP430F149 using the basic Olimex programmer software so that does seem to work ok. The LCD display viewing angle seems wrong. The background dots (those not being driven) are very visible unless viewed from about 45 degrees 'upwards' rather than straight ahead. Voltage regulator VR1 is getting very warm (too hot to keep a finger on). The DC-DC converter is a bit warm, as it the main NXP micro. The green RDY light is flashing most of the time, even during the read/verify that has worked. RDY is only solid green during the 'initialise' stages. Any suggestions or advice please?
« Last Edit: March 31, 2017, 06:06:27 PM by Flukefixer »

Flukefixer

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
Re: MSP-430-JTAG-ISO-MK2 Stuck in Debugger mode
« Reply #1 on: April 01, 2017, 03:04:38 AM »
Ok I solved it. The SD card is faulty. I put in another one which then got formatted (without warning!) and the Stand alone and Mass storage modes now work as they should. The unit remembers what mode it was in when last powered off and does not display the main menu as the manual states that it will. The warm components and slightly odd viewing angle must be normal and not part of the fault symptoms. I tried swapping back to the 'old' SD card again and the problem returned. Case solved I think.