Welcome, Guest

Author Topic: LPC-P1343 bootloader curreption  (Read 2823 times)

raman

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
LPC-P1343 bootloader curreption
« on: September 09, 2016, 09:21:56 AM »
Hi
    my LPC-P1343 board bootloader stops working suddenly after writing flash with new hex file, how to restore it?

JohnS

  • Hero Member
  • *****
  • Posts: 1674
  • Karma: +33/-45
Re: LPC-P1343 bootloader curreption
« Reply #1 on: September 09, 2016, 02:58:11 PM »
I suspect the bootloader is fine as it's in ROM.

What did you do, in detail, that resulted in the situation now?

John

raman

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: LPC-P1343 bootloader curreption
« Reply #2 on: September 12, 2016, 09:37:26 AM »
Hi JhonS
         Thanks, i just copied new hex file in it's flash, but after removing jumper and reset, my program not working as expected, then i tried to copy new bin file but this time my windows7 not detected my board it is telling USB Device not recogonized

JohnS

  • Hero Member
  • *****
  • Posts: 1674
  • Karma: +33/-45
Re: LPC-P1343 bootloader curreption
« Reply #3 on: September 12, 2016, 01:01:48 PM »
If you follow the CPU maker's (I suppose nxp's) instructions I expect all will work.

(As I use Linux and never managed to do what you've done I would refer to their instructions.)

John

raman

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
Re: LPC-P1343 bootloader curreption
« Reply #4 on: September 12, 2016, 03:21:02 PM »
Hi JhoneS
           Now i able to see my controller flash on both windows and Linux, but my board not go to run mode after roving jumper and reset, it always go to program mode and flash appears, USB LED is always light ON, is there any way to resolve it? and do you have experience with this board, on Linux i used mtools to delete and copy my bin/hex files, also which file is correct BIN or HEX used to run, i tried both but no luck.

 Also after writing my hex/bin file and reset my file disappear and then firmware.bin with size of 32KB appears default at all the time, i don't know whether my file written or not? 
« Last Edit: September 12, 2016, 03:40:07 PM by raman »

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1753
  • Karma: +46/-2
Re: LPC-P1343 bootloader curreption
« Reply #5 on: September 22, 2016, 01:38:16 PM »
Hey,

As mentioned in the user's manual we have tested the bootloader only with *.bin files created by IAR EW for ARM. I'm not sure if binaries generated by other software tools or converted files would work at all.

To upload a file made with IAR EW for ARM close jumper BLD_E – then press the RESET button - there would be new disk driver visible in "My Computer". Inside this drive you must place firmware.bin. Demo firmware files might be found in this archive https://www.olimex.com/Products/ARM/NXP/LPC-P1343/resources/LPC-P1343_Examples.zip - they are usually located in sub-folder "Exe", for example you may find few example binaries in LPC-P1343_VirtualComPort_LEDs&Buttons\Flash Debug\Exe folder.

Then open jumper BLD_E and press RESET again to execute the code from firmware.bin.

Consider getting a SWD debugger tool that would solve similar problems and will greatly speed up your development pace. Furthermore, most debuggers can be used with almost any ARM chip or general purpose development boards (like LPC-P1343).

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex