LPC-P1343 flash programming issue over USB issue

Started by raman, July 19, 2016, 02:41:46 PM

Previous topic - Next topic


Hi All
       My LPC-P1343 board suddenly stops flash programming option, windows didn't recognize it, it says  one of USB port is malfunctioning, what is issue with this board?, can i use your coocox jtag debuger for programming?.



Did it work in the beginning?

If it worked in the beginning and stopped at some point without any changes to the hardware setup (cables, USB ports, etc) - then it is probably your code that might have caused it.

Quotecan i use your coocox jtag debuger for programming?.

Yes, you can use ARM-JTAG-COOCOX with LPC-P1343 - LPC1300 are supported by CooCox software and the tools related to CooCox.

Best regards,
Technical support and documentation manager at Olimex


Ok, first i want to program the flash so that, can i use serial FTDI TTL cable for this with LPC ISP program?


Hello Lub
            Now i am able to see my controller flash on both windows and Linux, but my board not go to run mode after roving jumper and reset, it always go to program mode and flash appears, USB LED is always light ON, is there any way to resolve it? and do you have experience with this board, on Linux i used mtools to delete and copy my bin/hex files, also which file is correct BIN or HEX used to run, i tried both but no luck.

Also after writing my hex/bin file and reset my file disappear and then firmware.bin with size of 32KB appears default at all the time, i don't know whether my file written or not?