[IMAGE] A13(-WIFI) Debian (now Ubuntu) + xfce flashable (Updated: 08 Mar: R18)

Started by jwischka, December 17, 2012, 06:36:15 am

Previous topic - Next topic

saand

There is some great info in this thread
so i put the image and some info about it into the wiki.

jwischka, feel free to edit the wiki or let me know if anything is wrong with the info put in and i can modify.

davidefa

December 22, 2012, 01:21:32 pm #16 Last Edit: December 22, 2012, 07:35:53 pm by davidefa
Thanks for the image uploaded jwischka.
I have disabled the screensavers too ( they where eating up to 50% cpu time )
Regarding the 'freezing' problem I think is related to the journaled ext3 filesystem ( iotop shows a process journald that writes frequently to the disk )
So I converted the filesistem to ext4 and disabled the journaling in the following way ( searched on google convert ext3 to ext4 )
1) insert the sdcard in a linux pc
2) check the ext3 partition: sudo fsck.ext3 /dev/mmcblk0p2
3) convert to ext4: sudo tune2fs -O extents,uninit_bg,dir_index /dev/mmcblk0p2
4) check the converted ext4 partition: sudo fsck.ext4 -yfD /dev/mmcblk0p2
5) disable journaling: sudo tune2fs -O ^has_journal /dev/mmcblk0p2
6) insert the sdcard in olinuxino and restart
( added the following line to /etc/fstab to select option noatime for root filesystem: /dev/rootfs  /  ext4  defaults,noatime,commit=60 0 1 )

I'd like to setup the italian keyboard so I followed these steps:
1) installed console-data: sudo apt-get install console-data
2) configured keyboard layout: sudo dpkg-reconfigure console-data
after this step the keyboard is correctly configured, but when I restart olinuxino the keybord reverts to us style and I have to rerun dpkg-reconfigure ( which is annoying )
I have tried with: sudo dpkg-reconfigure keyboard-configuration but it does not work


jwischka

Quote from: davidefa on December 22, 2012, 01:21:32 pm
Thanks for the image uploaded jwischka.
I have disabled the screensavers too ( they where eating up to 50% cpu time )
Regarding the 'freezing' problem I think is related to the journaled ext3 filesystem ( iotop shows a process journald that writes frequently to the disk )
So I converted the filesistem to ext4 and disabled the journaling in the following way ( searched on google convert ext3 to ext4 )
1) insert the sdcard in a linux pc
2) check the ext3 partition: sudo fsck.ext3 - /dev/mmcblk0p2
3) convert to ext4: sudo tune2fs -O extents,uninit_bg,dir_index /dev/mmcblk0p2
4) check the converted ext4 partition: sudo fsck.ext4 -yfD /dev/mmcblk0p2
5) disable journaling: sudo tune2fs -O ^has_journal /dev/mmcblk0p2
6) insert the sdcard in olinuxino and restart
( added the following line to /etc/fstab to select option noatime for root filesystem: /dev/rootfs  /  ext4  defaults,noatime,commit=60 0 1 )

I'd like to setup the italian keyboard so I followed these steps:
1) installed console-data: sudo apt-get install console-data
2) configured keyboard layout: sudo dpkg-reconfigure console-data
after this step the keyboard is correctly configured, but when I restart olinuxino the keybord reverts to us style and I have to rerun dpkg-reconfigure ( which is annoying )
I have tried with: sudo dpkg-reconfigure keyboard-configuration but it does not work


The I/O wait times on this board are quite bad, no matter what file system you are using, though things are helped quite a bit by having a fast card. I haven't tried moving to ext4, but if your experience suggests it's better, I may do that for the next release. I suspect there are probably some lower level issues as well (kernel/driver problems) that are causing things to be as slow as they are when it comes to disk I/O.

As to the keyboard issues, have you tried configuring things in /etc/rc.local to reconfigure on boot?

I don't have my board with me (and won't for a week or two), but I can try to look at it when I get back.

Also, it seems you guys have made Dropbox suspend my public files for a while - which is fine, just not something I've ever had a problem with before. I've updated the link with one on my own server.

mike1968

Hello jwischka,
I am not able to connect to my wlan.
iget this Error:

Listening on LPF/wlan1/48:02:2a:ea:10:83
Sending on   LPF/wlan1/48:02:2a:ea:10:83
Sending on   Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
Failed to bring up wlan1.
done.

i make following changes in the /etc/networks/interfaces file:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto wlan1
iface wlan1 inet dhcp
    wpa-ssid "mike"
    wpa-key-mgmt WPA-PSK
    wpa-psk *1111111111111*

please help

best regards
Michael

jwischka

sudo ifconfig

What is the output?


Quote from: mike1968 on December 22, 2012, 10:44:59 pm
Hello jwischka,
I am not able to connect to my wlan.
iget this Error:

Listening on LPF/wlan1/48:02:2a:ea:10:83
Sending on   LPF/wlan1/48:02:2a:ea:10:83
Sending on   Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 10
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
Failed to bring up wlan1.
done.

i make following changes in the /etc/networks/interfaces file:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto wlan1
iface wlan1 inet dhcp
    wpa-ssid "mike"
    wpa-key-mgmt WPA-PSK
    wpa-psk *1111111111111*

please help

best regards
Michael

mike1968

i get this output.

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr 48:02:2a:ea:10:83
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:86 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

jwischka

Have you tried taking the security off your network and seeing if you can connect then? Also, might check to make sure you don't have an inadvertent space after your ssid or password?


Quote from: mike1968 on December 22, 2012, 11:31:00 pm
i get this output.

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan1     Link encap:Ethernet  HWaddr 48:02:2a:ea:10:83
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:86 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

mike1968

how can i change the subnet-mask ??

Sending on   Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3  8)

jwischka

Quote from: mike1968 on December 23, 2012, 12:15:43 am
how can i change the subnet-mask ??

Sending on   Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3  8)


That's not the issue - 255.255.255.255 means it's sending things out without respect to what network you are on, which is what you want - since you don't have a network yet. It's a broadcast packet, not an actual packet to be routed.

Again, did you try with no security settings? My suspicion is an incorrect password, specifically one with a space after it.

mike1968

Well, I disable all security settings but nothing change.

same error massage:

istening on LPF/wlan1/48:02:2a:ea:10:83
Sending on   LPF/wlan1/48:02:2a:ea:10:83
Sending on   Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
Failed to bring up wlan1.

jwischka

Sorry, I should have seen this before. You don't have quotes around your SSID/password do you?

so, should look like:

wpa-ssid mike
wpa-psk thisismypassword

Quote from: mike1968 on December 23, 2012, 12:34:22 am
Well, I disable all security settings but nothing change.

same error massage:

istening on LPF/wlan1/48:02:2a:ea:10:83
Sending on   LPF/wlan1/48:02:2a:ea:10:83
Sending on   Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
Unable to obtain a lease on first try.  Exiting.
Failed to bring up wlan1.

David Goadby

Mike, the default Ethernet interface appears to be eth2.

Check out this forum entry: https://www.olimex.com/forum/index.php?topic=301.0

David

saand

Hi is anyone else using this version 2 image and using a VGA screen?

when i installed the image i had no vga output. To get it to work i had to copy both the script file and the uImage file from a working VGA image i had.

if anyone else has VGA working let me know otherwise ill upload the files so that the VGA output can be incorporated in the next version

jwischka

Updated to version 3.

Get current version (R3) here.

Changelog:
Updated kernel to 3.0.57.
Changed FS to ext4, but left journaling intact. Journaling is fairly important when you may lose power at any point in time.
Updated all packages to latest version.


jwischka

Updated to version 4.

Kernel recompiled with proper I2C timings. i2c-tools are not installed, but I'll try to remember to do that on the next release.

New u-boot should give us an additional 64MB of memory to work with. I'll try to track down what's eating 80MB of ram that doesn't need to be in a future release.

Also, VGA support should be working now (had to add some things back into the kernel to get it to compile), but I may pare that down later, so no guarantees going forward.