Welcome, Guest

Author Topic: Debugger XDS100V3 Unable to detects CC2640  (Read 2559 times)

sevender

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Debugger XDS100V3 Unable to detects CC2640
« on: May 27, 2016, 04:17:01 PM »
Hello

I Purchaesd the debugger from olimex for my project, which is stopped for the production due to CC2640 MCU+BLE is not able to detected.

while trying to flash CC2640 target board using a XDS110 v3 rec C Debugger using SmartRF Flash Programmer 2 (v1.7.2) , but in the connected pair columm UNKNOW is coming .then we tried with "CC26xx/CC13xx Forced mass erase"  but FAILED operation is coming.

In debugger , 20 pin ARM connector is being used by placing 20 to 10 pin conveter and  then 10 to 6 pin converter as target board has 6 pin of nails to flash.

I tried the same setup to flash the CC2640 with 20 pin of  Smart RF evaluaton board 06 , It works. From this it could be concluded that some issue is from debugger board side .

Kindly suggest the following points :

share the schematic of XDS110 v3 rec C .

suggest how to flash board with debugger.??

At the Pin 1 of debugger 1.6 V is coming , which should be 3,3 as Vref as mentioned in datasheet .


PLZ reply soon

Reference links

www.ti.com/.../TMDSEMU100v2U-ARM

www.tag-connect.com/.../TC2030-CTX.pdf ?               (10 to 6 pin converter cable)

www.embeddedartists.com/.../acc_jtag_adapter_kit.php             (10  to 6 pin conveter)



Thanks in advance

LubOlimex

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1752
  • Karma: +45/-2
Re: Debugger XDS100V3 Unable to detects CC2640
« Reply #1 on: May 27, 2016, 05:02:00 PM »
Hey,

Are you using the proper connector? I used the ARM_JTAG connector and had the ARM_JTAG_E jumper closed. J4 and J5 jumpers were open.

Did you modify device_info.xml as suggested in the FAQ section at the bottom of the product page: https://www.olimex.com/Products/DSP/Emulators/TMS320-XDS100-V3/ ?

I've personally tested CC2650 and XDS100-V3 and they work fine.

Best regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex