Welcome, Guest

Author Topic: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page  (Read 4334 times)

CH

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« on: September 10, 2015, 04:02:25 AM »
I am trying to develop own web page using PIC-WEB rev c.
I have tried on TCPIP stack v5.31, which is worked fine with everything, including load the default web page, upload my own index.htm.

However, when I loaded the TCPIP stack v5.42 prebuilt.hex, I got the default IP is 169.254.1.1. (where v5.31 default IP is 192.168.0.30). For v5.42, I cannot load the web pages. When I ping it, the host is unreachable. However, the data package is sent with no loss. I totally no idea why I cannot load the default web page for v5.42.

I tried to search for quite a long time about the version varies but unfortunately the information is very limited.
Hope to seek for help if anyone had experienced this problem before.

Thanks in advance.
« Last Edit: September 10, 2015, 04:04:17 AM by CH »

JohnS

  • Hero Member
  • *****
  • Posts: 1719
  • Karma: +33/-48
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #1 on: September 10, 2015, 08:56:40 AM »
Sounds like your network/PC is/are set up suitable for the previous address.

Either change the address or look up TCP/IP info and have fun with it :)

John

CH

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #2 on: September 10, 2015, 09:12:15 AM »
Hi John,
I have changed the IP address of the board, still cannot load the default web page.  :'(

Stanimir5F

  • Jr. Member
  • **
  • Posts: 80
  • Karma: +2/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #3 on: September 16, 2015, 03:44:13 PM »
Hello, CH!

Since I can't replicate your problem, I would like to know a little bit more details.

What is the IP address you are trying to connect?
How do you get that IP address?
Do you use Microchip Ethernet Discoverer tool?
Did you upload the webpage for the 5.42 firmware or you are not able to do this?

As you describe it seems like you are trying to connect the default IP address but the DHCP gives the PIC-WEB different one.

Stan, Olimex
May the Source be with You!

CH

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #4 on: September 23, 2015, 06:21:03 AM »
Hi Stan!

Thank you for the prompt reply.

I am trying to connect to 10.0.0.199.
The default IP from the firmware is 169.254.1.1. (from the user manual the IP address is 192.168.0.30)

After I loaded the 5.42 prebuilt.hex file into the olimex pic-web rev. c board, it gave me the default IP as 169.254.1.1. Since my network is 10.0.0.xxx so I will need to change the IP address to 10.0.0.199 in order to load the webpage.
For both IP addresses, I unable to connect to the default webpage.

Yes, I used Microchip Ethernet Discoverer tool, but it only can search the IP address for the first time. After I reconnect the board, it failed to search any IP address.

But with v5.31, it works fine when loading the webpage.

p/s: I didn't make any changes on the firmware.

Thank you for your kind attention and looking for your advice!


Stanimir5F

  • Jr. Member
  • **
  • Posts: 80
  • Karma: +2/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #5 on: September 23, 2015, 09:43:25 AM »
Hello again!

I'm not sure if I can help you however I have one idea about the problem

It's not surprising that you can't connect the webpage when the Microchip Ethernet discoverer tool could not find the PIC-WEB (probably because of invalid network configuration).

As long as I understand you don't use DHCP (either no DHCP or disabled) but instead you set manually an IP address to "10.0.0.199". If so then did you set the subnet mask and gateway address? I have always worked with "192.168.*.*" subnet and never with "10.*.*.*" using PIC-WEB so I can't guarantee this will work. But since this ("10.*") is a class A network (instead of class B for "169.*" and class C for "192.*") I suppose the mask should be "255.0.0.0" instead of the one by default "255.255.0.0" and the gateway must be in the same subnet. Did you change these settings together with the IP?
If no - you can do this using the RS232 interface (or if you prefer you can also change them inside the code but it's not recommended). During reset hold the user button and a configuration menu will be shown on the terminal (baudrate 19200) where you can change the settings (either for DHCP enable/disable and the IP/Mask).

Stan, Olimex
May the Source be with You!

CH

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #6 on: September 23, 2015, 11:40:23 AM »
Hi Stan,

Yes, I disable DHCP and set manually the static IP address.
I have changed the subnet mask and gateway address as well.

I did the same setting to v5.31.
It works fine with v5.31 but sadly v5.42 failed to do so.

I have no idea why it cannot work since both of the procedures are the same except the TCPIP stack version.

Stanimir5F

  • Jr. Member
  • **
  • Posts: 80
  • Karma: +2/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #7 on: September 23, 2015, 02:33:12 PM »
I forgot that you mention that with 5.31 it works fine.

I'll be honest I have no ideas how to proceed with this problem since I have never before encounter it and I can't replicate it now.

I know it's a shot in the dark but still you can try to compare the TCPIP configuration files between these two projects (and more specific "Application Options" section) and test different options.

Another thing you can try is to test with the original project from Microchip Solutions released on 2013-06-15. C18-PICDN2_ETH97.mcp was the starting point of the project on our website. You can check it and see whether it will work or not with the basic project without changes. Of course the microcontroller and pinout of some peripherals are different but you can try whether it will connect or not.

I know it's a long shot but I have no other idea. I'm sorry about that.

Stan, Olimex

PS: Can you test the application on another router with 192.* address and DHCP server?
« Last Edit: September 23, 2015, 02:42:26 PM by Stanimir5F »
May the Source be with You!

CH

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: TCPIP Stack 5.42 cannot work on Olimex PIC-WEB web page
« Reply #8 on: September 25, 2015, 11:22:11 AM »
Stan, thanks for your reply.

I am trying to compare the TCPIP files and finding other solutions.
Anyhow, appreciate your reply and thank you very much!  :)

Regards,
CH