July 13, 2024, 12:08:26 AM

PIC WEB - first problem

Started by elettrorider, October 18, 2015, 01:32:09 AM

Previous topic - Next topic


Hi to all.
i have a new pic-web vers. C and i move my first steps with this.
Why if i load the pre-built .bin image this works fine and if i load a MPFS image from the sources its don't work fine? These are the same verision, 5.42...
In the second case the dinamic variables are static and not change the value. The led instead works fine.

Thanks in advance.


Hello, Stefano!

Since it works here without problem I would like to ask you few things just to make sure about some details.

1) Do you use the tool inside the example archive MPFS2.jar (the one located in "Microchip\TCPIP Stack\Utilities")?
2) Which directory are you trying to compile into image? You have to select "Olimex_PIC-WEB_WebPages2", not "WebPages2", which the original from the Microchip TCP/IP stack.
3) Did you make any changes in the webpage files (particularly "status.xml")?
4) Can you compare the prebuilt and the generated images (for example with notepad++)? Are they the same?

Stan, Olimex
May the Source be with You!


Hello Stan,
thanks for your reply.

1)Yes, i use the tools MPFS2.jar inside the example;
2)I tried to compile into .bin image both "Olimex_PIC-WEB_WebPages2" and "WebPages2". Are different but both not work fine  (there are not choices for .bin unlike the manual).
3) i didn't make any change in htm pages...
4) i try to see if there is differences



Fixed it!
It is a banal error (but if you don't know.....)
The name of the .bin image must be "MFPSImg.bin" in my experiments i numbered this with _1, _2, _3 etc...

See you for the next problem! :-)