Problem using MSP430-JTAG-ISO-MK2 with an external target supply

Started by Chester Gillon, November 25, 2012, 02:06:01 pm

Previous topic - Next topic

Chester Gillon

I have been attempting to use MSP430-JTAG-ISO-MK2 with a MSP430-CCRFLCD powered from an external supply (the POUT jumper is connected on the MSP430-CCRFLCD). In this configuration both CCS 5.2 and the Olimex MSP430 Programmer report that they can't identify the target device. The MSP430-JTAG-ISO-MK2 has the latest V2.0.0.5 firmware.

If the external supply is removed from the MSP430-CCRFLCD, and the PIN jumper is connected then the MSP430-JTAG-ISO-MK2 can identify the CC430F5137 on the MSP430-CCRFLCD.

Is there a known problem with MSP430-JTAG-ISO-MK2 not working with targets powered from an external power supply?

(A MSP430-JTAG-TINY-V2 does work with the MSP430-CCRFLCD powered from an external supply)

LubOlimex

Hey Chester,

Thanks for the explanation!

We checked couple of situations like the one described by you. It seems there is some problem with the power profiling algorithm of the firmware. It does not properly recognize whether the chip is powered! It shows 0.7V processor power even when the processor is powered by 3.3V.

We are investigating the issue and hopefully will release a patch soon.

We look forward to more constructive feedback from you.

Regards,
Lub/OLIMEX
Technical support and documentation manager at Olimex

canpunar

Hi All,
We also have the same problem.
We have some custom designed boards (msp430f148, msp430f2252, msp430f5510, msp430f5527,... ) that can be programmed (read/write) via JTAG properly with MSP430-JTAG-ISO (unfortunately it is OBSOLETE now) using IAR EW and Olimex MSP Programmer.

We bought and installed MSP430-JTAG-ISO-MK2 (firmware V2.0.0.5).
In stand alone mode, reading parameters we choose : "IF JTAG, Vt:3.3V", we see the same error, "Can't find target" (external powered, processor 3.3V exist in the board). In this case, if we try many times re-powering the board while trying to read, the programmer can succeed to read the code properly with a small possibility.

Of course, the same problem occurs as a debugger via IAR EW.
We are waiting the corrected firmware for MSP430-JTAG-ISO-MK2.

Best Regards,
Ibrahim

canpunar

Hi,
MSP430-JTAG-ISO-MK2 firmware version 2.006 solved the problem.

Thanks...

Ibrahim