Welcome, Guest

Author Topic: olimexino-STM32 and libmaple  (Read 2730 times)

krbonne

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
olimexino-STM32 and libmaple
« on: December 07, 2014, 03:59:12 PM »
Hi,

I would like to try out libmaple (i.e. not the maple IDE but the standand-alone tools) on my olimexino-stm32.

I managed to get the tools compiled and can compile and upload some of the example applications, but when I run them the board, it doesn't do anything. I seams to hang up (no reaction, no blinking LED, no USB activation, ...)

When I compile / upload the application using the mapple IDE, it does work OK. So it looks like a difference in the compile-process that seams that causes this.

I already tried using the "arm-none-aebi-gcc" tools that came with the IDE and changing the options in the makefile, but no success.



The libmaple enviroment is the latest one I cloned from git (git://github.com/leaflabs/libmaple.git)



Has anybody had any success running libmaple on the olimexino-stm32?
Or anybody with any simular issues?


My development host is a ubuntu 14.04.


Cheerio! Kr. Bonne.