the board don't boot on the microSd card

Started by fredoph, June 03, 2014, 10:39:52 am

Previous topic - Next topic

fredoph

Hi

When I boot the OlinuxinoA20 for the first time with the debian image on the microSd card, all works fine.
But when I rewrite the debian image in the micro SD Card the A20 boot directly the android system which is on the nand. The green light stays always off.
The SD Card can be seen in the file explorer of android.
I don't have the UART serial cable.
I successfully flash the last android image on the nand but the A20 still boot on the android and the system and the green light stay off.
Can you help me ?
Best regards.

dave-at-axon

What is the FEX file setting set to for booting?

This entry dictates what the boot device will be.

fredoph

Hi,

I'm back to home.
Here is the beginning of the script.bin file which is on the fat partition of the micro SdCard :

[product]
version = "100"
machine = "OlinuXino-A20"

[platform]
eraseflag = 0

[target]
boot_clock = 912
dcdc2_vol = 1400
dcdc3_vol = 1250
ldo2_vol = 3000
ldo3_vol = 2800
ldo4_vol = 2800
power_start = 0
storage_type = 1

[clock]
pll4 = 300
pll6 = 600
pll7 = 297
pll8 = 336

[card_boot]
logical_start = 40960
sprite_gpio0 =

[card0_boot_para]
card_ctrl = 0
card_high_speed = 1
card_line = 4
sdc_d1 = port:PF00<2><1><default><default>
sdc_d0 = port:PF01<2><1><default><default>
sdc_clk = port:PF02<2><1><default><default>
sdc_cmd = port:PF03<2><1><default><default>
sdc_d3 = port:PF04<2><1><default><default>
sdc_d2 = port:PF05<2><1><default><default>

[card2_boot_para]
card_ctrl = 2
card_high_speed = 1
card_line = 4
sdc_cmd = port:PC06<3><1><default><default>
sdc_clk = port:PC07<3><1><default><default>
sdc_d0 = port:PC08<3><1><default><default>
sdc_d1 = port:PC09<3><1><default><default>
sdc_d2 = port:PC10<3><1><default><default>
sdc_d3 = port:PC11<3><1><default><default>

fredoph

Hi,

Maybe this is my fault because I started this tutorial without the completed.

www.olimex.com/forum/index.php?topic=2028.0

And after the board began to boot only from the nand.

Is there a solution ?

Thanks a lot.

dave-at-axon

This might help.

http://linux-sunxi.org/Fex_Guide#

storage_type=1 is for SDCARD.

This is used when the system is write the image. Phoenix Suit for example uses this to create an image in the SD is this is 1 or NAND if this is 0. The default on boot is to check the SD for uboot and if present, it boots from SD so make sure if you want to use NAND that the SD does not have any boot on it.

fredoph

Thanks for your reply.

I just want to return to the initial configuration and boot from a fresh debian on micro SDcard without any own modification.
I have extract the fex file from the script.bin file which was write on the mSDcard with the official debian image.
But even when I flash the nand with the official android nand image, it doesn't work.

What's wrong ?

Best.

fredoph