MSP430-JTAG-TINY-V2 and TI SmartRF Studio

Started by eldoradofm, May 06, 2014, 08:17:35 PM

Previous topic - Next topic


How can i get SmartRF Studio to work with the MSP430-JTAG-TINY-V2?
When i use Windows drivers + MSP430-JTAG-TINY-V2 firmware version drivers and latest DLL's it doesn't find it.
When i use MSP430 JTAG drivers ver. it finds it but wants an update. When i do that update it doesn't find it anymore.

Does anyone have a solution? I want to use it with a CC430F5137.



It is strange that this question get asked so often considering that TI themselves don't list TI430UIF debugger at the SmartRF supported tools section.

I don't know what the upgrade has done to the firmware of the debuggerr, You shouldn't upgarde it as stated here:

Please also check this thread

Best regards,
Technical support and documentation manager at Olimex


Hello Lub/OLIMEX,

I've read those threads and i can't find a solution there.

And in the last thread they use another device to do the thing that is not a fix for the MSP430-JTAG-TINY-V2.

If i don't do the upgrade with RF studio the program doesn't recognize the device.

So is there maybe a driver update or something like that to make this work or any other solution?

Here a screenshot of the problem:

and what happens when i click open control panel:

Best regards


Hello eldoradofm,

Did you replace the default MSP430.dll with the one you downloaded for MSP430-JTAG-TINY as suggested? Do you see something similar to the two pictures of this album:

The MSP430-JTAG-TINY can be used with any development IDE supports the original TI MSP-FET430UIF and MSP430-USBFET hardware platforms because MSP430.dll which is provided with MSP430-JTAG-TINY-V2 is 100% compliant to Texas Instruments MSP430.dll v2.

Best regards,
Technical support and documentation manager at Olimex


Hello Lub/OLIMEX,

Yes i replaced the MSP430.dll
I don't want to use the Flash Programmer, i want to use the Device Control panel to communicate directly with the CC430F5137. I know that it works with the MSP-FET430UIF but so far not with the MSP430-JTAG-TINY-V2.

Maybe someone at Olimex can try to get it working with the Olimex MSP430-CCRF board.

1. Get the software:
2. Install driver for MSP430-JTAG-TINY-V2 Windows drivers + MSP430-JTAG-TINY-V2 firmware version
3. Replace HIL.dll, MSP430.dll, olimex.dll.
4. Start SmartRF studio and click Find Device
5. List of connected devices is empty... should not be that way.
6. From MSP430 JTAG drivers ver. -26-JUL-2011 Place MSP430.dll and SiUSBXp.dll in the BIN folder.
7. Start SmartRF studio again and click Find Device
8. Now it sees a device (see previous screenshot) and wants a firmware update.
But firmware update doesn't work and starting without a firmware update also doesn't work.

I hope someone at OLIMEX can test this and perhaps build a new MSP430.dll file that does work with SmartRF studio.

Best regards,


I have the same problem. SmartRF Studio uses version 3 of MSP430.dll. OLIMEX's MSP430.dll is version 2. Therefore it won't work without updating the firmware since version 3 is incompatible with version 2.

Is a new piece of hardware required to support version 3?


I'm having the same issue. I may add that the SmartRF seems to recognize the MSP430-JTAG-TINY-V2 however doesn't recognize the chip: if Flash Programmer from within SmartRF studio is started, it shows the device name as UNKNOWN, as shown here:

(I get the same result if I completely disconnect the MSP430-JTAG-TINY-V2 from the target).

I have tried also older version of SmartRF Studio (6.13.1) and normally it says "Enumeration failed" except directly after firmware upgrade (now matter to which version) when it says "Unknown chip id: 0x0000".

BTW: my hardware seems to be OK as it works without any issue with Olimex MSP430 Programmer, CCS5 and Eclipse+mspdebug.


Try this:

In short, run IAR, try to download any project to your chip and agree to update firmware TINY. It helped me with EMBlaocks, probably it might help with RF Studio.