WHY module folder is different of $(uname -r) in Archlinux listed on Olimex ?

Started by flavigny, November 09, 2012, 07:12:21 PM

Previous topic - Next topic


Me again,
I am alwways playing with Archlinux as mentioned in OlinuxMaxi web page by this link: https://www.olimex.com/Products/OLinuXino/iMX233/_resources/ARCH-README.TXT
Note that the text page have no version nor date. I have downloaded two days ago.

Module folder contains driver for Pl2303, namely:
[root@oli serial]# pwd
[root@oli serial]# ls -al pl2303.ko.gz
-rw-r--r-- 1 root root 8678 May 21 09:04 pl2303.ko.gz
[root@oli serial]#

modinfo, modprobe, insmod do nothing

I observe that folder name differs from uname -r who said: 2.6.35-5-ARCH+

So I tried to rename folder to $(uname -r)
now, modinfo, modprobe answers normaly.

Of course, problem is not solved!
Renaming the folder give access to modules, but inside versionmagic value is "3.1...." and using a module aborts with "Exec format error"

Could Olimex confirm if I am confused or fix it if there is a bug.