ArchLinux + USB-WiFi

Started by idragoev, November 06, 2012, 02:21:27 PM

Previous topic - Next topic


I just have my Olinuxino Micro + WiFi dongle + Micro SD card with Arch Linux on it.
How to setup the wireless network? I see the ipconfig but I do not have ifup/ifdown, etc. Is there a tutorial for thaT?



It depends on the USB WiFi module you are using, and whether the drivers are available.

I've written up some note on setting up an ArchLinuxARM image on our dev blog at

The problem with a Micro is that you don't have network access to install drivers before you get the WiFi working.  So to get an initial image prepared, you need to either:
- use a Maxi to prepare the SD card (like I did)
- use a WiFi module with built in drivers and unsecure WiFi network
- use a USB ethernet module with built in drivers for initial config
- load all the files on the SD using a separate Linux machine

Sorry I couldn't provide an easier solution.



Hi all,

Kean, thanks for the reply on this topic! The tutorial you suggested is great, however I find it a little bit confusing in some of the steps. Please, can you make it more clear for me:

  • How can I transfer a file to the board over the Ethernet
This is wanted in step 9) where the blog says that I need the Realtek 8192cu driver for the Wifi, and it gives a command: "unzip && mkdir -p /lib/modules/`uname -r`/kernel/drivers/net/wireless/rtl818x/ && cp 8192cu.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless/rtl818x/ && depmod –a"

So where should I execute this? I guess if I get the 8192cu.ko on the board I would be able to execute the second part of the command and everything will be fine.

So, I tried to find out how to get the file on the board. I tried two things:

  • to mount my network hard drive to the board (this works with a Raspberry Pi) using cifs: mount -t cifs <IP>:/path ... it didn't work and I spent a few hours trying to make it work with no success
  • I tried to use minicom. I have used minicom before but I have no idea why it isn't working now. I tried all the uploading types(zmode/xmode/kermit/ascii).. so I am surely missing something in the set up

Any ideas? I'm sure it is something stupid that I'm missing, but I have no idea what it is.

(When I tried to transfer the file through the USB - the board kept on restarting and I didn't make it work either)



Hi again,

I think I figured it out using picocom which I found here:

Thanks for the nice tutorial there and I also think it would be good to have a wiki :)