SOLVED!!! smartrf studio 7 and JTAG-TINY-V2

Started by stelios, September 22, 2013, 02:32:20 PM

Previous topic - Next topic


Is there a possibility to make smartrf studio 7 to recognize a JTAG-TINY-V2 connected to a MSP430-CCRF?
I tried various combinations of MSP430.dll (olimex, tiV2, tiV3 etc.) and USB drivers without luck. The only sign was that with olimex dll v2.0.0.7 and firmware v1.0.4.2 an upgrade prompt appeared (although port was COM0), after upgrade tiny-v2 was not recognized any more.
Thank you in advance.


Hey stelios,

SMARTRF STUDIO should work with our JTAGs since it uses MSP430.dll protocol. I see it is recognized in the Studio over here:

By the way you can use our free programmer software, it has CC430F5137 support out-of-the-box. Just remember to place the latest firmware in its main install folder to be able to program it.

Best regards,
Technical support and documentation manager at Olimex


I tried again but I can't make smartrf studio to recognize tiny-v2. I tried with all msp430.dll olimex and ti old and latest.
With Olimex programmer I have no problems at all as with CCS and IAR too, it works PERFECTLY.
By the way what do you mean  by "remember to place the latest firmware in its main install folder to be able to program it" I thought firmware for tiny-v2 is contained in the msp430.dll and is programmed in it if the current firmware is older.


 ;) ;) ;) I found a workaround in order to connect MSP430-CCRF to smartrf studio. Smartrf studio recognizes the inexpensive TI MSP430 Launchpad, so I connected the Spy-By-Wire from Launchpad (all jumpers removed) to the corresponding pins on the MSP430-CCRF JTAG connector plus Ground, put the USB cable on PC and everything worked as expected  ;) ;) ;).