Welcome, Guest

Author Topic: Audio works but no video signal on A13-olinuxino-micro  (Read 3984 times)

nsingh

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Audio works but no video signal on A13-olinuxino-micro
« on: September 22, 2015, 06:33:41 PM »
Hi
I am trying to play video on VGA monitor using A13-olinuxino-micro board, but the message I got on the screen is shown below.
I am getting only audio output from 3mm audio jack but didn't get video signal on VGA monitor.
I have A13_Micro_Debian_kernel_34_79_100kHz_I2C_WIFI_USB_LAN_X_touch_third_release image file[/b] installed on my SD card.
I followed these steps to play video:

# apt-get install libvdpau-dev
$ git clone https://github.com/linux-sunxi/libvdpau-sunxi.git
$ cd libvdpau-sunxi
$ make
# make install

prepare permissions:
# chmod 777 /dev/cedar_dev /dev/disp
$ export VDPAU_DRIVER=sunxi

download the sintel trailer and/or big bugs bunny:
$ wget http://download.blender.org/durian/trailer/sintel_trailer-1080p.mp4


watch the movie:

$ mplayer -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau -ao alsa:device=hw=0.0 sintel_trailer-1080p.mp4


The message I get after followed these steps:

MPlayer svn r34540 (Debian), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing sintel_trailer-1080p.mp4.
libavformat version 53.21.1 (external)
Mismatching header version 53.19.0
libavformat file format detected.
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO:  [H264]  1920x1080  24bpp  24.000 fps  2108.4 kbps (257.4 kbyte/s)
Clip info:
 major_brand: isom
 minor_version: 512
 compatible_brands: isomiso2avc1mp41
 creation_time: 1970-01-01 00:00:00
 title: Sintel Trailer
 artist: Durian Open Movie Team
 encoder: Lavf52.62.0
 copyright: (c) copyright Blender Foundation | durian.blender.org
 description: Trailer for the Sintel open movie project
Load subtitles in ./
vo: couldn't open the X11 display ()!
Error opening/initializing the selected video_out (-vo) device.

==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
AUDIO: 48000 Hz, 2 ch, s16le, 126.7 kbit/8.25% (ratio: 15836->192000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   5.3 (05.3) of 52.2 (52.2)  2.1%


MPlayer interrupted by signal 2 in module: play_audio
A:   5.3 (05.3) of 52.2 (52.2)  2.1%

Exiting... (Quit)


Can anyone help me to solve this issue.
Thanks in advance.

MBR

  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +19/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #1 on: September 22, 2015, 08:11:10 PM »
Do you start the mplayer from the console/shh/telnet/whatever or from some kind of XTerminal, already running in the X Window? Because if you don't start from X Winows, you must have the enviromental variable DISPAY set, for example by someting like export DISPLAY=:0.0 (for bash and compatible, otherwise consult you shell's man page).
« Last Edit: September 22, 2015, 08:56:02 PM by MBR »

nsingh

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #2 on: September 22, 2015, 10:19:21 PM »
yes i am writing the export DISPLAY=:0 command to enable X11 support.
But still the video is not running.
only it plays the audio.

Gerrit

  • Full Member
  • ***
  • Posts: 245
  • Karma: +7/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #3 on: September 22, 2015, 11:54:13 PM »
it is still not clear if you are running in a graphical environment or not, X must run of course, and if you use a Olimex  image you don't have to install or compile vdpau that is already done

nsingh

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #4 on: September 23, 2015, 12:08:24 AM »
I am using olimex image:  A13_Micro_Debian_kernel_34_79_100kHz_I2C_WIFI_USB_LAN_X_touch_third_release.img
And how can I check whether X windows is ON or OFF.

or how I can make it ON to run hardware accelerated videos.
Can you please advise me the steps to run a video on A13-olinuxino-micro board with VGA monitor as display device.

thanks in advance.

MBR

  • Sr. Member
  • ****
  • Posts: 256
  • Karma: +19/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #5 on: September 23, 2015, 11:15:32 PM »
You could check the running X Server by process listing (by ps/top/htop/looking into the /proc directories/whatewer) for a process with name like /usr/bin/X. If the X Server starts alone (by starting the X from commandline), without xstart or some kind of display manager, the screen should display a gray-looking patern of black-white pixel checkerboard.

And for start, you should check if the Mplayer runs at least without the hardware acceleration, with parameter -vo x11 (for a plain X11 output) instead the -vo vdpau.

nsingh

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #6 on: September 24, 2015, 07:04:32 PM »
Hi MBR

I checked the x-server in the process listing (top), but it is not running.
I tried using startx command, and the display on monitor changes to debian linux wallpaper. But nothing shown up on terminal.
So I have to exit running the X-server before trying typing my mplayer command.

Secondly I tried to run mplayer without hardware acceleration using -vo x11 , but again it doesn't respond.
Please advise some solution.
thanks

Gerrit

  • Full Member
  • ***
  • Posts: 245
  • Karma: +7/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #7 on: September 24, 2015, 11:54:36 PM »
I use an older version myself, but for testing i put the the image you mention on a SD card, and powered the board up, then it starts up a graphical environment (LXDE) as user olimex, the background is a picture called spectrum_rgb , in the menu i open "Sound & Video / SMPlayer" then i open a mp4 (h264) movie and it plays with picture and sound, and using the vdpau driver, i did not change or install anything extra, it works right out off the box

nsingh

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #8 on: September 25, 2015, 10:45:33 PM »
Hi Gerrit

thanks for your post, but I already tried playing videos like that.
My query is to play video on A13-micro using VGA monitor when you connect your board through Serial Console to your computer. And when I give command from the serial console to the A13micro board:
mplayer -fs -vo vdpau .......................?
It should play video on VGA screen.

I am trying this way and getting errors like:
vo: couldn't open the X11 display (:0)!
Error opening/initializing the selected video_out (-vo) device.



I tried export DISPLAY=:0.0 command before writing mplayer command, but didn't get success.
and my Xorg is also running. I can't get what the problem is?

Can someone help me to get out of this.
thanks

Gerrit

  • Full Member
  • ***
  • Posts: 245
  • Karma: +7/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #9 on: September 26, 2015, 12:37:10 AM »
You get this error because you run mplayer not as the same user that as X, (olimex as you did not add any other user) you can login as this user on the console or open a terminal on the VGA screen and do

Code: [Select]
xhost + this gives other users and host also access to the display

I also noticed DISPLAY=":0" works better then DISPLAY="0:0"

nsingh

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Audio works but no video signal on A13-olinuxino-micro
« Reply #10 on: September 28, 2015, 08:18:12 PM »
Thanks
It works out for me..
Now I can play video on A13-olinuxino module from the serial console.