Olimex Support Forum

Microcontrollers => AVR => Topic started by: lhern034 on January 15, 2015, 12:07:32 PM

Title: Unable to connect to tool AVRISP mkII
Post by: lhern034 on January 15, 2015, 12:07:32 PM
Hello,  I was attempting to write a program into the ATMEGA1284 using the programmer AVR-ISP-MK2 by Olimex with my windows 7 and windows 8 computers but the AtmelStudio can not read it.

The error message reads:

Unable to connect to tool AVRISP mkII (000200212345)
Timestamp:   2015-01-15 01:55:39.480
Severity:      ERROR
ComponentId:   20100
StatusCode:   1
ModuleName:   TCF (TCF command: Tool:connect failed.)

Could not establish communication with the tool


Is there a way I can fix this? I tried updating the firmware but, it still does not read it. I am using Atmel Studio 6.2.

 :o





Title: Re: Unable to connect to tool AVRISP mkII
Post by: majesticra on February 28, 2015, 10:11:36 PM
The same for me
The system is win 8.1

Timestamp:   2015-02-28 23:01:01.183
Severity:      ERROR
ComponentId:   20100
StatusCode:   1
ModuleName:   TCF (TCF command: Tool:connect failed.)

Could not establish communication with the tool.

If I select the device in atmel studio or call atprogram it hands and then the error appears.

I have tried:
1. Update firmware driver
2. Downgrade atmel driver bundle
3. Reinstall IDE
4. Use USB2.0 to connect the device
5. Reinstall libusb
6. Uninstall, delete drivers



At the same time the device WORKS on old laptop with win 8.1. But I can't figure out what is wrong on the new system

Update
Done! Working! After 3-d time of doing this
https://www.olimex.com/forum/index.php?topic=4188.0

What was the difference this time:
Driver verification disabled from cmd (with administrative privelegies) by:
Code: [Select]
bcdedit -set loadoptions DDISABLE_INTEGRITY_CHECKS
bcdedit -set TESTSIGNING ON

(To enable it back)
Code: [Select]
bcdedit /deletevalue loadoptions
bcdedit -set TESTSIGNING OFF

Carefully restarted after each step
Title: Re: Unable to connect to tool AVRISP mkII
Post by: Ant2N on May 19, 2015, 12:53:33 PM
I might have a simpler solution to the problem. The reason of this error is that Atmel Studio 6.2 expects the AVRISP to run the libusb drivers, which apparently wasn't the case previously.

To fix this error:

- Download Zadig: http://zadig.akeo.ie/. Zadig is a USB driver manager for Windows, and saved me a hundred times this year. The last version comes with the libusb-win32 (v1.2.6.0) driver embedded.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Replace its current driver by libusb-win32 (v1.2.6.0)

That's it! No restart required :)

Let me know if somebody had the same issue and was able to solve it this way.
Title: Re: Unable to connect to tool AVRISP mkII
Post by: Stub Mandrel on May 22, 2015, 10:58:06 PM
I have registered with this forum just to say a big thanks for your driver fix for the AVR ISPII  - It worked, and I was pulling my hair out.

Stub
Title: Re: Unable to connect to tool AVRISP mkII
Post by: canislupus on May 30, 2015, 12:39:53 PM
I might have a simpler solution to the problem. The reason of this error is that Atmel Studio 6.2 expects the AVRISP to run the libusb drivers, which apparently wasn't the case previously.

To fix this error:

- Download Zadig: http://zadig.akeo.ie/. Zadig is a USB driver manager for Windows, and saved me a hundred times this year. The last version comes with the libusb-win32 (v1.2.6.0) driver embedded.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Replace its current driver by libusb-win32 (v1.2.6.0)

That's it! No restart required :)

Let me know if somebody had the same issue and was able to solve it this way.

good job! been searching for a fix for months and this does it.
Title: Re: Unable to connect to tool AVRISP mkII
Post by: lanerebel on June 01, 2015, 06:20:43 AM
So after being completely unable to get avrdude working with the AVR ISP MKII on my Mac, I'm trying it now in a Windows 8.1 Pro VM. I'm trying the Zadig approach, I replaced the AVR Studio-installed drivers with libusb-win32, but when I try to "Run" in AVR Studio (6.2 I believe) I get:

Could not write message to libusb0 connection: libusb0-dll:err [_usb_reap_async] timeout error

I've replaced the firmware on the AVR ISP MKII back to what it was originally, instead of the "upgrade" for avrdude that I had on there before.

Has anyone solved this one?

Update

It turns out I did have to reboot after all. This worked great after that, thanks!
Title: Re: Unable to connect to tool AVRISP mkII
Post by: sati2del on August 26, 2015, 06:18:38 PM
I might have a simpler solution to the problem. The reason of this error is that Atmel Studio 6.2 expects the AVRISP to run the libusb drivers, which apparently wasn't the case previously.

To fix this error:

- Download Zadig: http://zadig.akeo.ie/. Zadig is a USB driver manager for Windows, and saved me a hundred times this year. The last version comes with the libusb-win32 (v1.2.6.0) driver embedded.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Replace its current driver by libusb-win32 (v1.2.6.0)

That's it! No restart required :)

Let me know if somebody had the same issue and was able to solve it this way.


awesome. works perfect. thank you
Title: Re: Unable to connect to tool AVRISP mkII
Post by: florins on September 24, 2015, 10:46:36 PM
Thank you Ant2N, my AVR ISP MKII works fine on Windows 10 x64 after I applied your solution. Much appreciated!
Title: Re: Unable to connect to tool AVRISP mkII
Post by: calipsoii on October 04, 2015, 08:17:34 PM
Registered here just to say that Ant2N's fix worked great.

Windows 10
Atmel Studio 7
AVR ISP mk II

Device recognized by Windows but Atmel Studio didn't show it connected. Tried all kinds of driver install/uninstall with no effect. Using Zadig to replace driver with libusb-win32 immediately fixed the issue. Atmel Studio 7 recognized device and performed a firmware upgrade without problems.

Thanks for the tip!
Title: Re: Unable to connect to tool AVRISP mkII
Post by: maredsous10 on October 26, 2015, 09:14:43 PM
Ant2N, thanks for posting that.  I had issues with atprogram.exe not functioning from the Atmel Studio 6.2 and 7.0 releases prior to trying your libusb drivers suggestion.  Haven't given the IDE tool a shot, yet

I wonder why Olimex doesn't have this on their their product page.   

https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/open-source-hardware

I might have a simpler solution to the problem. The reason of this error is that Atmel Studio 6.2 expects the AVRISP to run the libusb drivers, which apparently wasn't the case previously.

To fix this error:

- Download Zadig: http://zadig.akeo.ie/. Zadig is a USB driver manager for Windows, and saved me a hundred times this year. The last version comes with the libusb-win32 (v1.2.6.0) driver embedded.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Replace its current driver by libusb-win32 (v1.2.6.0)

That's it! No restart required :)

Let me know if somebody had the same issue and was able to solve it this way.

Title: Re: Unable to connect to tool AVRISP mkII
Post by: david_a on November 12, 2015, 04:56:36 AM
The Zadig solution did not work for me.
The error message looks close to what it did before but not exactly:

Unable to connect to tool AVRISP mkII

Timestamp:   2015-11-12 03:47:52.894
Severity:      ERROR
ComponentId:   20100
StatusCode:   131118
ModuleName:   TCF (TCF command: Tool:connect failed.)

Target not detected

I am trying to communicate with a XMEGA Xplained A1 through PDI and I have followed the instructions posted at avrfreaks for connecting the PDI correctly.
This is on Windows 8.1 pro.

Do anyone know what's wrong?

Regards
Title: Re: Unable to connect to tool AVRISP mkII
Post by: JohnS on November 12, 2015, 09:44:16 AM
Did you run it as Admin?

It always works...

John
Title: Re: Unable to connect to tool AVRISP mkII
Post by: david_a on November 12, 2015, 09:27:31 PM
No, but I did run both the driver changing software and Atmel Studio 6.2 again as admin and it was no change.
The power does at least get through to the board, I am going to try and see if AVRdude manages to communicate with the board.

Regards
Title: Re: Unable to connect to tool AVRISP mkII
Post by: JohnS on November 12, 2015, 10:34:47 PM
It may be the changes in Atmel 6.2 as others have posted about it being broken as installed.  I forget wht the fi is but it's been posted.

(I use Linux where using tools just works.)

John
Title: Re: Unable to connect to tool AVRISP mkII
Post by: david_a on November 16, 2015, 12:49:39 PM
Did these posts mention any solution to this problem or do I nee to change atmel studio version.
Atmel Studio 6.2 is the first and only atmel studio(AS) I have used and I know that 7 has come out, but in XMEGA documentation they recommend AS 4 or 5. Is these still relevant to people like me who are just getting into programming mcu's and focus is on XMEGA and PDI programming?

Regards
Title: Re: Unable to connect to tool AVRISP mkII
Post by: JohnS on November 16, 2015, 03:58:44 PM
Zadig worked except for one person (who didn't run it as admin as it needs, if I understand the post).

Using an earlier AS is easy, though, I expect.

Or just use Linux :)

John
Title: Re: Unable to connect to tool AVRISP mkII
Post by: david_a on November 17, 2015, 01:33:31 AM
I downloaded and installed both atmel studio 5.1 and 7(although 5.1 never did run) but that did not help so I started messing with the firmware of the AVRISP mkII and reading from its datasheet and a few sources online made me try the usual procedure outlined in the datasheet and after pressing the update button and uploading new firmware and having the green LED now shine red instead it still did not work.

After a few hours of uninstalling and deleting devices in the device manager and re-installing firmware's it finally worked and I have no idea how I did it this time and I am at this point very confused about the hole thing.

But now atmel studio 7 can upload built solutions to my XMEGA Xplained A1.

Regards
Title: Re: Unable to connect to tool AVRISP mkII
Post by: david_a on November 17, 2015, 01:38:09 AM
And to be clear, Zadig didn't work for me.
It was about an hour ago that I stopped trying to use Zadig, so when I did make it work somehow it had nothing to do with Zandig. But it seems as a good thing that it has worked for everybody else.

Regards
Title: Re: Unable to connect to tool AVRISP mkII
Post by: JohnS on November 17, 2015, 09:49:39 AM
Probably some combination(s) of Win X and AS Y that don't work but people often don't say their X & Y so impossible for anyone else to learn from their problems.

John
Title: Re: Unable to connect to tool AVRISP mkII
Post by: MarkDM on December 20, 2015, 10:16:11 PM
I use the MKII with Bascom-AVR. It works fine in Windows XP but not in W7.
I tried the solution with Zadig, but it did not help.
The driver always reverts back to "libusb0".
(after re-install to libusb-win32 and restart of Zadig)
 Is this normal ?
Title: Re: Unable to connect to tool AVRISP mkII
Post by: MarkDM on December 22, 2015, 10:28:52 AM
I did a firmwareupdate of the MKII. The problem is solved. My previous project was in XP. For W7 and the new libusb you need more recent firmware.
Case closed.
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on February 01, 2016, 05:02:30 PM
Hey,

Anyone with similar problems please try with these drivers: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/DRIVER-MK2-AS-6-7-W10.zip (https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/DRIVER-MK2-AS-6-7-W10.zip)

Best regards,
Lub/OLIMEX
Title: Re: Unable to connect to tool AVRISP mkII
Post by: Wolle on February 12, 2016, 07:08:58 PM
Hello,
I have the same problem like the others.

If I push "apply" under "Device Programming" in AtmelStudio7, I get the error:
Unable to connect to tool AVRISP mkII (0000A00128255)

Timestamp:   2016-02-12 17:28:22.289
Severity:      ERROR
ComponentId:   20100
StatusCode:   131103
ModuleName:   TCF (TCF command: Tool:connect failed.)

Could not read from libusb0 connection: libusb0-dll:err [_usb_reap_async] timeout error


I tried the "zadig 2.2" and also the driver, posted by LubOlimex (from February 01, 2016).
In my opinion the driver is Ok but the problem is still there.
I also tried it with Win7 64bit and Win10 64bit, but nothing was working and so I can`t use my OLIMEX Board to flash the Atmega8.

I hope anyone has a tip to slove the problem.


Sorry for my english and greets from Berlin
Kay

How can I insert a pic? sry
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on February 17, 2016, 08:42:12 AM
Hey Wolle,

In your case make sure to use these drivers: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/DRIVER-MK2-AS-6-7-W10.zip (https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/DRIVER-MK2-AS-6-7-W10.zip)

Properly installed drivers in Windows 7 and Windows 10 should look as this:

(http://i.imgur.com/UVkJyri.png)

Did you also update the firmware with the latest one (via Atmel Flip)? The latest firmware is found in this archive: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/AVR-ISP-MK2-Firmware-WindowsDrivers.zip (https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/AVR-ISP-MK2-Firmware-WindowsDrivers.zip)

Best regards,
Lub/OLIMEX

P.S. The forum doesn't support picture uploads - you need to host them to an image-hosting web-site and then link them in your post.
Title: Re: Unable to connect to tool AVRISP mkII
Post by: Wolle on March 01, 2016, 11:47:01 AM
Hello LubOlimex,

so many thanks for your answer.
Last week I got a new MKII (clone). This device was specify for Atmel Studio 6 and higher.
And it is working now.

Despite of the sucsess, I´m owning now 2 MKII clones witch aren´t working with Atmel Studio 6 or higher.

You gave me the tip to flash the firmware with Atmel flip.
Now my new problem.
One clone includes an "Atmega32 A AU" and the other one an "Atmega8A AU". But both types of this chips aren´t listed in Atmel Flip, so I can´t flash them or get any connection/link to them. Is there any possibility to flash the two clone with the firmware you were written down in the text below?

How can I flash them or are they for the recycle bin (wast) now?

Thank you so much.

Greets Wolle
Title: Re: Unable to connect to tool AVRISP mkII
Post by: nsk_artem on March 08, 2016, 02:31:18 PM
Great thanks! That works perfectly! But don't forget to reconnect your tool after changing driver (I forgot and so long I could't understand why it isn't working.)
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 24, 2016, 10:11:09 PM
Hi, I have Win10 on this laptop, Arduino IDE 1.6.7,the latests drivers for the MKII tooked from this site, firmware updated done via Flip,USB 2.0 port, but I'm still getting the same error message regarding "usb receive error"... This is what appears in the IDE's window:
"
avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2009 Joerg Wunsch

         System wide configuration file is "C:\arduino-1.6.7\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): Found AVRISP mkII, serno: 000200312345
avrdude: stk500v2_recv_mk2: error in USB receive"


With the old IDE 1.0.6, works perfectly(same Win10 and PC), but with the IDE 1.6.7 it doesn't...
Can someone to give me a clue how to solve this annoying problem ?
Thank you..
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on April 26, 2016, 09:25:15 AM
Follow the instructions from chapter "2.3 Quick setup" from the user's manual blindly. I also use Windows 10. I tested a programmer taken from the store and I followed the instructions. "Upload using programmer" in Arduino IDE 1.6.7 works fine.

Here is a picture from few minutes ago: http://i.imgur.com/bskccvw.png

Check your hardware connections. Very often people think that AVR-ISP-MK2 has 6-pin ISP connector, which is not the case - there is only 10-pin ISP connector.

Best regards,
Lub/OLIMEX
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 26, 2016, 04:54:35 PM
Hi,Lub....I did what the manual says,but I'll give another shot this evening..Maybe I did something wrong...Beeing in a middle of a project, I'll keep the 1.0.6 IDE on another PC, just in case...:)...I'll let you know about what's happening.Thanks for your support,Lub..
Best regards,
Costin


BTW, there are more than 2 years since I'm using this Olimex product, so forget about connectors mismatch..:)
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 26, 2016, 06:27:09 PM
Well, it doesn't works no matter I've done.
Steps i did :
1- updated the firmware again on the programmer, via Flip, hex taken from the manual's link,those for Avrdude...
2-deleted all the drivers for the programmer, updated from the drivers from the link,Device manager shows exactly like the manual's picture (libusb-win32, 27.01.206,Atmel,etc)...
3- Downloaded the Avrdude 6.2, the one is specified in the manual...
4- Launched avrdude, as administrator, but the error is the same.
   "avrdude: stk500v2_recv_mk2 : error in USB receive "
I really don't know ahat more things to do to make it works...
Any ideea, anything changed in hardware in the last two years ? ?
Best regards,
Costin
Title: Re: Unable to connect to tool AVRISP mkII
Post by: JohnS on April 26, 2016, 09:18:34 PM
Main change is that the IDE changed what it does when programming.

John
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 27, 2016, 09:21:12 AM
I agree with you,JohnS, but the weird thing here it's the fact that my programmer doesn't works even with Avrdude6.2 despite the fact the Lub's one works with both Avrdude6.2 and IDE 1.6.7...But with IDE 1.0.6 and WIN10 works fine, so cables and connections are out of discussion in this case...
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on April 27, 2016, 11:57:13 AM
Hey,

The whole thing with firmware and drivers is messy and specific for each system. I don't want to go into much details but the latest firmware for the tool doesn't require firmware change to use it with the latest AVRDUDE if you use Windows 10.

Just upload the latest firmware and test if Arduino IDE 1.6.7 works with it. I used the latest "AVR456-studio-AVRISP-MKII.hex". And I used these drivers: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/DRIVER-MK2-AS-6-7-W10.zip

If anybody that reads this uses Windows XP - you still need to perform firmware change, and you also can't use Atmel Studio 7 under XP, so don't even try. And you need to use drivers up to Jungo 11.0.0.0.

Furthermore, you can't use Windows 10 and AVR Studio 4 (at least I couldn't find any way to do it). Under Windows 10 you need to use Atmel Studio x.

Best regards,
Lub/OLIMEX
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 27, 2016, 05:50:21 PM
Lub, I have the same drivers and firmware as you mentioned in your reply,but still the same error in usb receive....I'm confused about you are using a non Avrdude firmware on the tool ...Like you said, some little things makes life messy...:)
Best regards,
Costin

PS where I can find the firmware loaded iinto "on-the shelf" tools ?
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 27, 2016, 06:10:13 PM
Furthermore, I have another question for you...In the Device manager, for the driver installed is mentioned "libusb-win32" , as is specified in manual or here in this topic, but in the "Readme" for the firmware you said is loaded into your tool( AVR456-studio-AVRISP-MKII.hex),says this

"Make sure any libusb or libusb-win32 drivers are removed and uninstalled completly
before you install the Atmel USB drivers else you would encouter driver mismatches."

So which one drivers must be on the computer ?  :-\
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on April 28, 2016, 11:59:56 AM
The driver should be the one from my previous post. It works for Windows 10 only. The image of "Windows Device Manger" with the driver installed is in this post: https://www.olimex.com/forum/index.php?topic=4065.msg21083#msg21083

We load the latest firmware during production. The latest firmware can be found in this archive: https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/AVR-ISP-MK2-Firmware-WindowsDrivers.zip - we use the elf file ("isp-mk2-06-01-2016.elf") and another programmer to download the elf to the boards. Then each board gets software tests and each programmer is tested if it actually programs a target.

Best regards,
Lub/OLIMEX
Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 29, 2016, 09:54:55 AM
OK, Lub...It seems I have two options. :)..Load the new elf into MKII or buy a new one, tested, and confirmed to work as specified (Ardu IDE 1.6.7, Atmel Studio 7 and Avrdude 6.2)...In the meantime, I'm wishing to you and to all readers of this topic,
Happy Easter,
Costin
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on April 29, 2016, 11:39:12 AM
Hey,

What happens when you try with Atmel Studio 7 (the recommended one for Windows 10)? Note that Atmel Studio 7 uses specific Windows 10 drivers that are incompatible with the drivers of previous studio versions. And if you want to use Atmel Studio 7 and Atmel Studio 6.x in the same machine you need to perform driver switch every time as explained officially here: http://atmel.force.com/support/articles/en_US/FAQ/Downgrading-tools-to-use-older-Jungo-driver (http://atmel.force.com/support/articles/en_US/FAQ/Downgrading-tools-to-use-older-Jungo-driver)

About AVRDUDE try with with the latest stand-alone AVRDUDE - not the one included in Arduino IDE. This would show if the problem is in the AVRDUDE configuration or somewhere else. I've shared a one compiled for Windows here: https://drive.google.com/open?id=0B7WHuNCASY8cOGV4dVVLdDlieVk (https://drive.google.com/open?id=0B7WHuNCASY8cOGV4dVVLdDlieVk)

Best regards,
Lub/OLIMEX

Title: Re: Unable to connect to tool AVRISP mkII
Post by: .Costin on April 30, 2016, 06:53:51 AM
Well, it works fine with Atmel Studio 7 with the firmware uploaded as you said ( AVR456-studio-AVRISP-MKII.hex),it recognize it from the start and I was able to write an Arduino board with a sketch transferred into Studio 7. Regarding Avrdude I had tried the stand-alone 6.2 version ( after changing the apropriate firmware in the tool and the drivers for Avrdude- libusb-win32), but the error was there.Anyway the picture for the correct driver is the same with yours..I'll try today again and I'll let you know.The main program I'm using is Arduino's IDE...
Best regards,
Costin
Title: Re: Unable to connect to tool AVRISP mkII
Post by: aneeshn.etrx@gmail.com on April 30, 2016, 03:15:54 PM
Hi,

I am unable to connect the avr MkII to avr studio 6.2.
IT gives error when i click on apply in the device programming.
the device manager shows the device (MkII) but cannot connect..
I am using windows 7 and studio 6.2. I even tried zadig but it creates some error in the device manager..
mkii with yellow marking..
Title: Re: Unable to connect to tool AVRISP mkII
Post by: JonnyK on May 25, 2016, 05:48:37 PM
I am unable to connect the avr MkII to avr studio 6.2.

I couldn't get online and followed all the steps (flip to update firmware, use libusb-win32, studion 7 latest build, win 7). Turns out I was reading the pin out wrong. I was following the diagram below...

https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/isp-mk2-layout-connectors.png (https://www.olimex.com/Products/AVR/Programmers/AVR-ISP-MK2/resources/isp-mk2-layout-connectors.png)

Which is the pin out ON THE PROGRAMMER looking at it. But looking at the cord to hook in jumpers you get the mirrior.

So a TPI connection for a ATtiny goes from...

ON THE PROGRAMMER
|1,2|
[3,4|
|5,6| 

ON BH6S CONNECTOR
|2,1|
|4,3-]
|6,5]

Same mirror with the ICSP10 and PDI. Yea... pretty stupid of me. 
Title: Re: Unable to connect to tool AVRISP mkII
Post by: Kvazzy on July 27, 2016, 03:52:53 PM
Hi.
I have did all procedures, but have no good result. I'm getting this message:

Timestamp:   2016-07-27 15:40:26.065
Severity:      ERROR
ComponentId:   20000
StatusCode:   0

Unable to connect to tool context: 'Atmel.VsIde.AvrStudio.Services.TargetService.TCF.Internal.Services.Remote.ToolProxy+ToolContext'.

Please, help me with that.

I might have a simpler solution to the problem. The reason of this error is that Atmel Studio 6.2 expects the AVRISP to run the libusb drivers, which apparently wasn't the case previously.

To fix this error:

- Download Zadig: http://zadig.akeo.ie/. Zadig is a USB driver manager for Windows, and saved me a hundred times this year. The last version comes with the libusb-win32 (v1.2.6.0) driver embedded.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Replace its current driver by libusb-win32 (v1.2.6.0)

That's it! No restart required :)

Let me know if somebody had the same issue and was able to solve it this way.
Title: Re: Unable to connect to tool AVRISP mkII
Post by: LubOlimex on July 28, 2016, 01:50:39 PM
Hey Kvazzy,

Please share more info.

1. What is your operating system exactly?

2. What is the exactly Atmel Studio version that you use?

Best regards,
Lub/OLIMEX
Title: Re: Unable to connect to tool AVRISP mkII
Post by: tngotran on January 13, 2017, 08:33:40 AM
I might have a simpler solution to the problem. The reason of this error is that Atmel Studio 6.2 expects the AVRISP to run the libusb drivers, which apparently wasn't the case previously.

To fix this error:

- Download Zadig: http://zadig.akeo.ie/. Zadig is a USB driver manager for Windows, and saved me a hundred times this year. The last version comes with the libusb-win32 (v1.2.6.0) driver embedded.

- Open Zadig, Options, List All Devices. The AVRISP mkII device should appear in the list.
- Replace its current driver by libusb-win32 (v1.2.6.0)

That's it! No restart required :)

Let me know if somebody had the same issue and was able to solve it this way.

Perfect solution :) thanks