Welcome, Guest

Author Topic: pic32-t795h and "failed to get device id"  (Read 7839 times)

Gregor1971

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
pic32-t795h and "failed to get device id"
« on: March 02, 2013, 01:30:59 PM »
Hello,

i want to use a pic32-t795h and run rtems or freetos on it. So i'm forced to reprogramm the bootloader etc. To do so i try to use a pickit3.

Everything seems to work great until i try to programm the board. MPLAB X tells me that it is able to connect to the pickit3. The last message is "Failed to get device id". Look at the bottom of the post for further details.

Because the pickit3 does not fit to the connector, i just connected the pins just one to one by a extension. The extension is about 10 cm long. Could this be a problem?

Another thing is, that the documentation of the pickit3 recommends a resistor (4,7 to 10k Ohm) between Vdd and Vpp. This resistor is missing in the schematics of the board. Could this disturb the communikation between the pickit and the pic32-t795h?

Any contructive answer is apreciated.

Kind regards
Gregor

MPLAB IPE Messages:

Connecting to MPLAB PICkit 3...
Firmware Suite Version.....01.28.40
Firmware type..............PIC32MX


Downloading Firmware...
Downloading AP...
AP download complete
Firmware Suite Version.....01.28.40
Firmware type..............PIC32MX

Target detected
Failed to get Device ID

Lurch

  • Sr. Member
  • ****
  • Posts: 272
  • Karma: +11/-0
Re: pic32-t795h and "failed to get device id"
« Reply #1 on: March 02, 2013, 03:26:09 PM »
The schematic (in PIC32-T795_Rev-C.pdf) shows a diode and a 4.7K Ohm resistor between MCLR and Vdd - look at the Box labeled "Buttons" at the bottom of the schematic. So that isn't the problem. I have an Olimex ICSP adapter that fits the connector, so I was able to program the chip. I used an external 5V power supply connected to pins 5V_ext and GND, not the Pickit3 power. Otherwise you just have to be sure that you pick PIC32795F512H, not the L version. Worked fine. Too bad the connector doesn't fit directly, but that's life.

Gregor1971

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: pic32-t795h and "failed to get device id"
« Reply #2 on: March 02, 2013, 06:20:58 PM »
Hi,

the resistor and the diode are there. So i didn't read the schematics correctly. After pressing the pickit3 onto the connector with some more power, it worked. Now it works with my extension to. A little frustrating.  :o

Ok, now the board answers, but the device ID (0xe000) does not match the expexted one (0x700).

Do you have any idea here?

Kind Regards,
Gregor


Gregor1971

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
Re: pic32-t795h and "failed to get device id"
« Reply #3 on: March 02, 2013, 06:48:06 PM »
Just an edit...

After some trys the device id is correctly received...

Now it is time to define the settings correctly and to start programming.


Regards,
Gregor