Is the ESP32-POE still supported

Started by Smashcat, February 07, 2024, 08:26:10 AM

Previous topic - Next topic


I have 30 or so of these - originally bought for a project a couple of years ago, but never used (made some customs board instead at the time). Just tried using one with the Arduino IDE, all up to date, but it seems like the old lan8710 on the board is no longer supported. Examples do not work, tried various settings, including the lan8720 driver. At best it gives "wrong chip ID".

Just wanted to check if it's a bit of a waste of time with these boards now, or if they can be disposed of. I have way too much hardware here and clearing space  ;D


Of course they are supported both by us and by the Arduino package.

In Arduino IDE make sure to select Olimex ESP32-POE. Then try the project from  File -> Examples -> ESP32 section -> Ethernet -> ETH_LAN8720.

Let me know how it goes and what are the messages you get. If hte issue remains tell us also which version of Arduino IDE package for ESP32 are you using? And also which is the hardware revision of the ESP32-POE boards you have (as printed on the boards themselves)?
Technical support and documentation manager at Olimex