August 16, 2022, 03:46:33 am

Adruino and LoRa-STM32WL-DevKit

Started by airheadbit, April 15, 2022, 09:30:06 pm

Previous topic - Next topic

airheadbit

I installed https://raw.githubusercontent.com/OLIMEX/Arduino_configurations/master/STM/package_olimex_stm_index.json but discovered only two STM32 parts, no STM32WLxx  parts. Why? I tried to use openocd to debug with STM32CubeIDE but it fails, I tried to use STM32CubeProgrammer to program the STM32WL device but it can not connect to a STlink or USB or UART device of the LoRa-STM32WL-DevKit.

And it just keeps getting worse:


The message has the following error or errors that must be corrected before continuing:
    The letters you typed don't match the letters that were shown in the picture.


LubOlimex

April 18, 2022, 09:26:50 am #1 Last Edit: April 19, 2022, 10:48:28 am by LubOlimex
We provide no Arduino demo or support for LoRa-STM32WL-DevKit. The file you linked "package_olimex_stm_index.json" was created long time ago for older chips and boards like Olimex STM32-E407. It wasn't updated for LoRa-STM32WL-DevKit, hence why there is no configuration for LoRa-STM32WL-DevKit. We haven't done any work in regard of Arduino IDE.

This is the only demo we provide for LoRa-STM32WL-DevKIT: https://github.com/OLIMEX/LoRa-STM32WL-DevKIT/tree/main/SOFTWARE/BB-STM32WLE-WAN

It was made with CubeIDE and other customers reported it builds fine (here: https://github.com/OLIMEX/LoRa-STM32WL-DevKIT/issues/1). I also built it myself and it builds fine: https://www.olimex.com/forum/index.php?topic=8680.msg33631#msg33631
Technical support and documentation manager at Olimex