June 19, 2024, 12:18:26 AM

ESP32-POE no link

Started by talesmaschio, December 21, 2021, 08:54:58 PM

Previous topic - Next topic


Hello all,

A few days ago I received 4 units of the ESP32-POE version G. I uploaded Tasmota as usual, and judging by the serial logs all seems ok.

Problem is, when connected through WiFi I get an IP address but I cannot access the web interface or even ping any of them. When connected through Ethernet I don't even get a link, led stays off at the switch side.

I also have an older ESP32-POE-ISO which works perfectly with the same version of Tasmota.

I tried both PoE and external USB power (one at a time) and I also tried different switches. Am I doing something wrong? Or, have you identified any issue with these new version G boards?

Thank you in advance for any reply.



Ok, finally got them working. I had more than one problem, so it's hard to pinpoint exactly what happened. Finally after a lot of tweaking in tasmota config files I managed to compile a working firmware. And I probably had a bad USB cable.

I totally forgot that I would never get a link on ethernet before properly configuring the corresponding GPIOs, sorry for that.

And, of four ESP32-POE boards that I got, only two are actually working. One of them is in a reset loop (watchdog) and the last one has a non working USB port.

It was a long couple of days.

Merry Xmas everyone!


can you check the demo examples from the product web page, just to be sure that hardware is working? we have no experience with tasmota, but as you write it may be configuration, watch dog etc issues related to it.