DRAM:Timeout initialising DRAM

Started by tbalthazar, November 02, 2021, 12:35:03 PM

Previous topic - Next topic



I'm trying too boot my Lime 1.
I tried flashing the focal minimal and buster minimal images I found here on 2 different SD card (1 brand new, 1 older), using Etcher.
I connected the serial cable and I'm using screen to try to understand what's happening.

With the 2 cards and 2 images, I get the same error message:
U-Boot SPL 2021.04+olimex-1-20210821.121541 (Aug 21 2021 - 12:16:45 +0000)
DRAM:Timeout initialising DRAM

resetting ...

Any idea what it means?


What exactly are:

1) the board;

2) the board variant;

3) the hardware revision, as printed on the board?

I tested here, the latest A10 boards seem to work fine with these images. Maybe you have older revision that experiences some issues with these images.
Technical support and documentation manager at Olimex


Thanks for your answer. I didn't realize there were different revisions of the Lime 1.
It looks like mine is a A10 Rev E, with an A20 Dual-Core T (F610BA 6763) CPU. I bought it in January 2016.
Here's a picture of the board:

Are some older images available somewhere?


You posted in "A10" sub-forum but you have "A20" board. Your board is A20-OLinuXino-LIME, hardware revision E.

Can you send me the initial start up log (I need to know how the board gets recognized by the image which is printed at start; upload the log somewhere and post the link here)? Maybe you would need to configure the image manually, set the exact board version and revision in the U-boot via tools we have provided. This is explained in chapter 7 "U-boot tools") in this document:


The same document contains more information about where you can download images. Let me know if something is not clear.
Technical support and documentation manager at Olimex