Support status in Debian 11 (bullseye)

Started by kuleszdl, August 21, 2021, 07:52:05 PM

Previous topic - Next topic



I installed official Debian bullseye with sysvinit (not from the Olimex image) on one of my A64-oLinuXino boards today. I am happy to report that - unlike with earlier versions - the OS seems to work reliable without the need to manually replace DTB files. Two issues still persist:

- Entering the the disk encryption password via serial does not work (workaround: use a usb keyboard or enter it over the network via dropbear).
- Power consumption in idle remains high (2W in idle with network attached).
- Several errors are reported on bootup in dmesg (e.g. "sun50i-a64-pinctrl 1c20800.pinctrl: Couldn't get bank PH regulator")

I didn't try the new SCP (crust?) firmware to reduce power usage yet. Anyways, the system is finally not freezing anymore when using only software from the official Debian distribution which is great step forward!


Thanks for this feedback.

With which version of the board did you succeed?

I have several A64-OLinuXino-2Ge8G-IND but could not manage to run the official Debian Bullseye on it.
Last time I tried the debian-installer, the installation worked with no issue but it could not start afterwards. It was stuck on "Starting kernel...".

I managed to make it start by changing the dtb but it was still buggy and unstable. See or my blog post (in French) (I wrote it before Bullseye was released, but the behavior was still the same last time I checked)


We are currently testing bullseye images, expect official release.
Technical support and documentation manager at Olimex