A64-OLinuXino-2Ge8G-IND - Ethernet connection unreliable

Started by antonio.pisano, June 25, 2021, 12:18:48 PM

Previous topic - Next topic


Dear Olimex,

I am working on a A64-OLinuXino-2Ge8G-IND for a project. The board was bought around last month, together with the official Ubuntu image SD card, which I am using to boot it and work.

I had some trouble getting the ethernet card recognized, but then found the issue was described in


and suggested fix worked.

However, now connection is very unreliable. I managed to get an IP address from DHCP, but just minutes of SSH afterwards, my connection froze. I then tried to assign a static IP address, but result was the same: only a few seconds of connection and then board was offline.

If one pings the board from another host in the same subnet, some packets might get through, must most of them won't. I cannot reproduce the same packets loss on other hosts in the subnet.

I have so far tried with a different cable, with the same result. We will try to move to a different ethernet plug in another room, however the plug we are using now is used on a daily basis without any issue so far.

Do you have any suggestion to help me troubleshoot the problem?

Thanks in advance



Make sure to also check the board directly via the UART debug pins. Do not rely only on the remote SSH connection to debug the issue.
Technical support and documentation manager at Olimex


I have indeed managed to start the board only thanks to the debug pins, accessing the console from the serial cable. The board is responsive over the serial console and is responsive via the graphical user interface that appears on the screen. I do not access it via SSH only.

What else could I look for?


It can be something in the network settings, remove any firewalls or QoS and test again.

Make sure to check the state of the PTH jumper on top of the board, make sure it is disconnected, there is no connection between the two pins.

Also did you try to re-write the image? Since the Ethernet disconnects it would be hard to run apt update and apt upgrade so try to re-write the image. Get the focal base image from here:


I recommend using the free version of Balena Etcher to re-write the image.

Best regards,
Technical support and documentation manager at Olimex


Changing location to the board did not improve the situation with the official image. I have then tried flashing the latest Debian-based Armbian Image https://redirect.armbian.com/lime-a64/Buster_current

Connection seem to work fine now...

On the official image, dmesg output would report a "eth_lpi not found" message. This seems at least partially related with a PineBook report I have found here https://forum.pine64.org/showthread.php?tid=7092

Hopefully the Armbian image will do the trick for me. Many thanks anyway!



Interesting... Glad that the Armbian image works but we generally only support and recommend the Olimage. Other Linux images might lack support for some of the hardware. Maybe check the Ethernet network settings in the Armbian image and compare with the settings in Olimage? Maybe it is something related to the default settings.
Technical support and documentation manager at Olimex


As it turns out, Armbian also shows issues... it just happened a bit later. I have the feeling this might have to do with the combination between Gigabit ethernet and 100MBit switch. I am still not sure, because we do have other Gigabit devices in the network that work fine... but maybe it is a combination of this + specific limitations of the board (?)

A problem that might be related is mentioned on the Armbian forums: https://forum.armbian.com/topic/12294-h2h3-old-problem-link-eth0-is-updown-syndrom/

I will try today to follow the ethtool suggestion mentioned in the post, starting from the lowest speed and proceding upwards, and see if this does any good.

What kind of network settings do you suggest to check? Are there best practices in this kind of situation you feel like recommending? (e.g. commands or setups to try out, expected results and so on...).

Thanks in advance