Xenomai for A13 - A10

Started by crubille, February 04, 2013, 10:55:17 pm

Previous topic - Next topic

awallin

Quote from: Tele on August 17, 2013, 01:05:27 am

If you are interested:
https://code.google.com/p/a13-olinuxino/downloads/list

SUNXI Linux Kernel v3.4.12-r4 patched with Xenomai 2.6.2.1
Build instructions on that page.

After making you can find 'uImage' in the directory:
arch/arm/boot

You can find kernel modules in the directory:
out


Thanks!
I've tried compiling this, and also looking at the instructions from:
https://www.olimex.com/wiki/Build_Bootable_SD_Card_with_Debian

In your instructions the first "make ARCH=arm a13_defconfig" is missing? Is that needed?
I tried this:

make ARCH=arm a13_defconfig
make ARCH=arm menuconfig   # no changes just exit
make -j4 ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- uImage
# check for uImage
ls -l arch/arm/boot/uImage
make -j4 ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- INSTALL_MOD_PATH=out modules
make -j4 ARCH=arm CROSS_COMPILE=arm-linux-gnueabi- INSTALL_MOD_PATH=out modules_install
# check for modules
ls -l out/lib/modules/3.4.12


I got an uImage, and the modules directory also shows some new alias, alias.bin, etc. files generated.

I can try booting my A13 with this later.
I now also got an A10s board. Are there many required modifications to make this work on the A10s?

regards,
AW

Tele

Hi Awa,

Quote from: awallin on August 26, 2013, 11:55:06 pm
...
In your instructions the first "make ARCH=arm a13_defconfig" is missing? Is that needed?
...

No, its not missing.
This is how it works:
In the kernel's dir you can find a file named .config
That is the configuration of the kernel, the makefile use it when you're building the kernel. When you do

make ARCH=arm menuconfig

then you actually edit that .config file

At the start, when you get or download a kernel source from somewhere, there is no .config file at all, its missing. Then you can do something like that:

make ARCH=arm a13_defconfig

That command simply copies a default config file from 'arch/arm/configs/a13_defconfig' -> '.config'
so now you have a default .config, you can edit it with 'make ARM=arm menuconfig' command, then you can start the build as you just described.
That a13_defconfig is a general configuration for A13 SoC (there are many, not just OLinuXino A13).
I have refined that, specifically for the Oli card and for this real-time purpose. You can find a .config in my tarball, that is much-much better than a13_defconfig, you can trust me.
Otherwise your description about kernel building is perfect, just skip that 1st line (make ARCH=arm a13_defconfig) if you want MY configuration, not something crap.
Sorry for the long explanation, at least now you understand what you are doing.

Quote from: awallin on August 26, 2013, 11:55:06 pm
...Are there many required modifications to make this work on the A10s?...

No, probably not so many, it would be quite easy and quick, if I had an A10 card. But I have no sorry. Patching a kernel blindly is not so nice. I'm gonna check what can I do for you, and I keep you posted.

Tele

Its ok, its been ported to A10.

I uploaded to
https://googledrive.com/host/0B6AyoNCq1rZmbGthdUk0RkpSenM

It was tested on Hackberry A10 only (on a remote way),
that is a very similar card to Cubieboard and Marsboard.
Most likely it works on OlimeXino A10s, and (maybe with slight modification on A20)
with an appropriate config file.

Someone should test it on OLimeXino A10s, and attach the good configuration.
And then this should be moved to the A10s section.
Actually it doesn't belong here, we are in A13 section now.

jeroends

Hello,

I think I've got xenomai finally running on a A13 micro. But what are the next steps because I'm missing some part. I supose I need to download the xenomai source and compile the test programs?
For now I'm using the 3.4.24 kernel and used a 3.4.29 .config file (the one provide by iso9660), only this morning I'm getting some strange kernel messages:

SysRq : HELP : loglevel(0-9) reBoot Crash terminate-all-tasks(E) memory-full-oom-kill(F) kill-all-tasks(I) thaw-filesystems(J) saK show-memory-usage(M) nice-all-RT-tasks(N) powerOff show-registers(P) show-all-timers(Q) unRaw Sync show-task-states(T) Unmount show-blocked-tasks(W)

Are those coming from Xenomai?

Tele

Quote from: jeroends on September 11, 2013, 09:15:43 am
...I supose I need to download the xenomai source and compile the test programs?...


Yes that would be the next step.

About your errors:
Maybe its because of xenomai, maybe it has nothing to do with xenomai, I don't know. But I have just mentioned 2-3 comments before that I found 3.4.24 and 3.4.29 unstable with xenomai. They crashed at least once or more a day. Then I moved to 3.4.12 kernel and this kind of instability disappeared, its stable like a pig, I used it for months, by now.

jeroends

Ok, I'll try to recompile the 3.4.12 version with the .config used in the 3.4.29 version (worked for the 3.4.24 kernel) because the compiled kernel with your .config didn't boot (it did compile without errors).

There are some things I don't get quite well:
I suppose I don't have to run the "prepare kernel" script anymore when applying the provided patch (or using the kernel source provided)? Or can I use that script and provide the patch with the "--adeos=patch" option?
It's just that I don't know where to start compiling the xenomai source code ...

Tele

Quote
...3.4.12 version with the .config used in the 3.4.29 version...


It won't work, you have have to edit manually after that, I remember for example, the drivers/usb/ehci configuration is different. Maybe the best if you edit the menuconfigs side by side(3.4.12 - 3.4.29), comparing the menus.

Quote..Or can I use that script and provide the patch with the "--adeos=patch" option?

I don't know which patch file you used, but probably you don't have to use xenomai's prepare anymore. Easy to check btw.:
If arch/arm/xenomai directory does exist, then your linux source is ready to compile. Why is this?
I have applied various patches to the kernel, then I have run xenomai's prepare, then I've made a
diff -Naur original last > xyz.patch
so my patch includes the original xenomai's prepare.
You can see how its done if you download that:
https://googledrive.com/host/0B6AyoNCq1rZmbGthdUk0RkpSenM
and you extract the linux-sunxi...tar.gz, then you check the doit.sh script (read the comments), you will understand everything, so easy it is, no rocket science at all.

The only annoying part is making a good configuration .config. Each kernel version each card needs a different one, there is no general solution. Not so hard but a niggling-pedantic-doddering job.

jeroends

Ok,
stuck at another point, while booting the kernel, it panics with:
Unable to handle kernel paging request at virtual address da000008

As I 've read in the thread, uMinded had the same error and was going to explain what he did to avoid this, but ...

Tele

...but uMinded forgot to explain what was the reason. I see.

Sorry, this is too few information to help.

What kind of u-boot you use, what is in your script.fex/bin, what is in your uEnv.txt, whats your kernel .config, and bootlog.
Any of these can cause serious things, like your panic. Even if everything seems ok, but ext4 filsystem got damaged somehow on your SD card (improper shutdown?), that could make the trouble.(had to do fsck on SD partitions)

jeroends

QuoteSorry, this is too few information to help.

Ok, you've got a point  :).
I'll start with the beginning.
- The filesystem used on my card is the debian image which could be downloaded at the site (wiki). Pretty standard
- I've used it before, so it isn't that standard anymore (one of my following steps: start back from zero would problably be a good thing).
- The version of uboot is, as above, back the standard delivered one (does it needs to be recompiled?).
- What differs from the original fex file is that I created the spidev device and I disabled the camera interface.
- There's no uEnv.txt present (as there isn't one on the provided image)
- Toolchain used is the standard arm-linux-gnueabi- in ubuntu

What I did the first time (trying to) compile the kernel is line by line comparisation of the .config file used in the 3.4.29 and the 3.4.12 kernel using menuconfig. What happend then is a compiler error on the usb ehci part. Next I gave your .config a shot (knowing the previous time I 've used it it wouldn't boot, but would compile). The only thing I've changed now was the kernel line parameter (setted to the right amount of memory since this differs from the maxi-micro).

bootlog: http://leachy.homeip.net/olinuxino/files/xenomai/log.txt
.config: http://leachy.homeip.net/olinuxino/files/xenomai/config

Another remark what I was thinking of, isn't the A13 supposed to be sun5i instead of sun4i?

Tele

I'm sorry Jero, I totally forgot about your question.

Now I see the problem. The thing what you have downloaded :
https://googledrive.com/host/0B6AyoNCq1rZmbGthdUk0RkpSenM
is a xeno kernel indeed, and its good for A10 and A13 as well, but its configured for a Hackberry A10 card at the moment. This is because someone said he had an Olimex A10s and wanted to test it, but I had no A10s, Hackberry was the only card to test it.
Of course sun4i means A10 system, and A13 needs sun5i kernel, you're right about that.
Not a surprise, if it doesn't work on your card, not at all

Your task is now:
porting your existing and good 3.4.24 kernel .config to 3.4.12 kernel. If you can do that, then copy that config in the ./patches-v3.4.12-r3/3.4.12-config (overwrite) the run doit.sh again.

The best way to port a .config, if you open 2 terminal windows and run the menuconfigs side by side, comparing each submenus and values. It takes some time, but its quite safe method.

Comparing the .config text files is much harder, and there is much more place to make a mistake, even if you use good gui comparators like meld or kdiff, because usually they rename the config parameters, so you wont find the matching parameter pairs.

If nothing works, then a possible starting point is arc/arm/configs/a13_defconfig , you modify it for your needs, because that one always works.

jeroends

QuoteYour task is now:
porting your existing and good 3.4.24 kernel .config to 3.4.12 kernel. If you can do that, then copy that config in the ./patches-v3.4.12-r3/3.4.12-config (overwrite) the run doit.sh again.


Thanks for the reply, I think this is the part that I 'm missing. I already compared the configs but I still wasn't able to create a working kernel. But I didn't know I had to overwrite it in the patches.

Will try that next week because the compared config is already deleted (I began to gave up on it  ;)) and I don't have the time the next couple of days.

Will keep you posted ...

Greg

March 19, 2014, 02:27:12 am #192 Last Edit: March 21, 2014, 12:48:28 am by Greg
Hi,
did anyone successfully run Xenomai on A10s, I am trying but no luck. Which kernel should I start?
I tried Linux-3.4.29-ipipe, compiled with some warnings, but does not start at all (Starting kernel... is last line).
I am using linaro-arm-linux cross-compiler. I would try crossNG but can't find Tele's config file mentioned in tutorial (https://code.google.com/p/a13-olinuxino/wiki/CrossNG). I have some basic experience on Linux i386 but I am beginner with these boards so every clue will be helpful.


Greg

March 21, 2014, 12:36:17 am #194 Last Edit: March 22, 2014, 03:46:25 am by Greg
Thx for quick reply, Booting stalled at root partition mounting:


(...)
Starting kernel ...

[    0.000000] Booting Linux on physical CPU 0
[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Linux version 3.4.12-xenomai (root@debian) (gcc version 4.7.3 20130102 (prerelease) (crosstool-NG linaro-1.13.1-4.7-2013.01-20130125 - Linaro GCC 2013.01) ) #1 PREEMPT Thu Mar 20 10:51:07 UTC 2014
[    0.000000] CPU: ARMv7 Processor [413fc082] revision 2 (ARMv7), cr=10c5387d
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] Machine: sun4i
[    0.000000] Memory cut off:
[    0.000000] MALI : 0x5c000000 - 0x5fffffff  (  64 MB)
[    0.000000] Ignoring unrecognised tag 0x00000000
[    0.000000] Memory Reserved:
[    0.000000] SYS  : 0x43000000 - 0x4300ffff  (  64 kB)
[    0.000000] VE   : 0x44000000 - 0x48ffffff  (  80 MB)
[    0.000000] G2D  : 0x58000000 - 0x58ffffff  (  16 MB)
[    0.000000] LCD  : 0x5a000000 - 0x5bffffff  (  32 MB)
[    0.000000] Memory policy: ECC disabled, Data cache writeback
[    0.000000] chip-id: Unknown (AW1625 revision A)
[    0.000000] On node 0 totalpages: 114688
[    0.000000] free_area_init_node: node 0, pgdat c0923f84, node_mem_map c09d8000
[    0.000000]   Normal zone: 896 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 113792 pages, LIFO batch:31
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 113792
[    0.000000] Kernel command line: console=ttyS0,115200 root=/dev/mmcblk0p2 rootwait loglevel=8 panic=10
[    0.000000] PID hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Memory: 448MB = 448MB total
[    0.000000] Memory: 313504k/313504k available, 145248k reserved, 0K highmem
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0xffff0000 - 0xffff1000   (   4 kB)
[    0.000000]     fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
[    0.000000]     vmalloc : 0xdc800000 - 0xff000000   ( 552 MB)
[    0.000000]     lowmem  : 0xc0000000 - 0xdc000000   ( 448 MB)
[    0.000000]     pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)
[    0.000000]     modules : 0xbf000000 - 0xbfe00000   (  14 MB)
[    0.000000]       .text : 0xc0008000 - 0xc0898294   (8769 kB)
[    0.000000]       .init : 0xc0899000 - 0xc08c5000   ( 176 kB)
[    0.000000]       .data : 0xc08c6000 - 0xc0927480   ( 390 kB)
[    0.000000]        .bss : 0xc09274a4 - 0xc09d7198   ( 704 kB)
[    0.000000] NR_IRQS:96
[    0.000000] timer0: Periodic Mode
[    0.000000] I-pipe, 24.000 MHz clocksource
[    0.000000] sched_clock: 32 bits at 100 Hz, resolution 10000000ns, wraps every 4294967286ms
[    0.000000] Interrupt pipeline (release #4)
[    0.000000] Console: colour dummy device 80x30
[    0.000000] Calibrating delay loop... 1001.88 BogoMIPS (lpj=5009408)
[    0.090000] pid_max: default: 32768 minimum: 301
[    0.090000] Mount-cache hash table entries: 512
[    0.090000] Initializing cgroup subsys cpuacct
[    0.090000] Initializing cgroup subsys devices
[    0.090000] Initializing cgroup subsys freezer
[    0.090000] Initializing cgroup subsys blkio
[    0.090000] CPU: Testing write buffer coherency: ok
[    0.090000] hw perfevents: enabled with ARMv7 Cortex-A8 PMU driver, 5 counters available
[    0.090000] Setting up static identity map for 0x405d6110 - 0x405d6168
[    0.090000] devtmpfs: initialized
[    0.090000] dummy:
[    0.090000] NET: Registered protocol family 16
[    0.090000] hw-breakpoint: debug architecture 0x4 unsupported.
[    0.090000] SYS-CLK : setting 've_pll (AW_SYS_CLK_PLL4)' to rate = 960000000 Hz
[    0.090000] SYS-CLK : setting 'sata_pll (AW_SYS_CLK_PLL6)' to rate = 1200000000 Hz
[    0.090000] [ccmu] try to set apb1 parent to sata_pll failed!
[    0.090000] SYS-CLK : setting 'apb1 (AW_SYS_CLK_APB1)' to rate = 24000000 Hz
[    0.090000] SOFTWINNER DMA Driver, (c) 2003-2004,2006 Simtec Electronics
[    0.090000] Initialize DMAC OK
[    0.100000] bio: create slab <bio-0> at 0
[    0.100000] SCSI subsystem initialized
[    0.100000] libata version 3.00 loaded.
[    0.100000] usbcore: registered new interface driver usbfs
[    0.100000] usbcore: registered new interface driver hub
[    0.100000] usbcore: registered new device driver usb
[    0.100000] Linux video capture interface: v2.00
[    0.100000] Advanced Linux Sound Architecture Driver Version 1.0.25.
[    0.100000] cfg80211: Calling CRDA to update world regulatory domain
[    0.100000] Init eGon pin module V2.0
[    0.100000] Switching to clocksource ipipe_tsc
[    0.120000] FS-Cache: Loaded
[    0.120000] CacheFiles: Loaded
[    0.120000] WRN:L142(drivers/usb/sun4i_usb/manager/usb_manager.c):ERR: get usbc(2) enable failed
[    0.120000] WRN:L148(drivers/usb/sun4i_usb/manager/usb_manager.c):ERR: get usbc(2) port type failed
[    0.120000] WRN:L154(drivers/usb/sun4i_usb/manager/usb_manager.c):ERR: get usbc(2) detect type failed
[    0.120000] WRN:L160(drivers/usb/sun4i_usb/manager/usb_manager.c):ERR: get usbc(2) id failed
[    0.120000] WRN:L166(drivers/usb/sun4i_usb/manager/usb_manager.c):ERR: get usbc(2) det_vbus failed
[    0.120000] WRN:L172(drivers/usb/sun4i_usb/manager/usb_manager.c):ERR: get usbc(2) drv_vbus failed
[    0.140000] sw_hcd_host0 sw_hcd_host0: sw_hcd host driver
[    0.140000] sw_hcd_host0 sw_hcd_host0: new USB bus registered, assigned bus number 1
[    0.150000] hub 1-0:1.0: USB hub found
[    0.150000] hub 1-0:1.0: 1 port detected
[    0.150000] NET: Registered protocol family 2
[    0.150000] IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.150000] TCP established hash table entries: 16384 (order: 5, 131072 bytes)
[    0.150000] TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
[    0.150000] TCP: Hash tables configured (established 16384 bind 16384)
[    0.150000] TCP: reno registered
[    0.150000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.150000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.150000] NET: Registered protocol family 1
[    0.150000] RPC: Registered named UNIX socket transport module.
[    0.150000] RPC: Registered udp transport module.
[    0.150000] RPC: Registered tcp transport module.
[    0.150000] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.150000] [pm]aw_pm_init!
[    0.150000] I-pipe: head domain Xenomai registered.
[    0.150000] Xenomai: hal/arm started.
[    0.150000] Xenomai: scheduling class idle registered.
[    0.150000] Xenomai: scheduling class rt registered.
[    0.150000] Xenomai: real-time nucleus v2.6.2.1 (Day At The Beach) loaded.
[    0.150000] Xenomai: debug mode enabled.
[    0.150000] Xenomai: starting native API services.
[    0.150000] Xenomai: starting POSIX services.
[    0.150000] Xenomai: starting RTDM services.
[    0.160000] NTFS driver 2.1.30 [Flags: R/W].
[    0.160000] fuse init (API version 7.18)
[    0.160000] msgmni has been set to 612
[    0.160000] alg: No test for stdrng (krng)
[    0.160000] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.160000] io scheduler noop registered
[    0.160000] io scheduler deadline registered
[    0.160000] io scheduler cfq registered (default)
[    0.160000] sunxi disp driver loaded (/dev/disp api 1.0)
[    0.160000] Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
[    0.160000] [uart]: failed to get uart4's used information
[    0.160000] [uart]: failed to get uart5's used information
[    0.160000] [uart]: failed to get uart6's used information
[    0.160000] [uart]: failed to get uart7's used information
[    0.160000] [uart]: used uart info.: 0x0d
[    0.160000] [uart]: serial probe 0 irq 1 mapbase 0x01c28000
[    0.170000] sunxi-uart.0: ttyS0 at MMIO 0x1c28000 (irq = 1) is a U6_16550A
[    0.180000] console [ttyS0] enabled
[    0.180000] [uart]: serial probe 2 irq 3 mapbase 0x01c28800
[    0.200000] sunxi-uart.2: ttyS1 at MMIO 0x1c28800 (irq = 3) is a U6_16550A
[    0.200000] [uart]: serial probe 3 irq 4 mapbase 0x01c28c00
[    0.220000] sunxi-uart.3: ttyS2 at MMIO 0x1c28c00 (irq = 4) is a U6_16550A
[    0.230000] G2D: drv_g2d_init
[    0.230000] G2D: g2dmem: g2d_start=58000000, g2d_size=1000000
[    0.230000] G2D: head:d8000000,tail:d9000000
[    0.240000] G2D: Module initialized.major:251
[    0.240000] brd: module loaded
[    0.250000] loop: module loaded
[    0.250000] 'Low Performance USB Block' driver is deprecated. Please switch to usb-storage
[    0.260000] usbcore: registered new interface driver ub
[    0.270000] [NAND]nand driver, init.
[    0.270000] cmu_clk is 432
[    0.270000] nand clk init end
[    0.280000] offset 0xc:  0x2e141
[    0.280000] offset 0x14:  0x8200000a
[    0.280000] [NAND] nand gpio_request
[    0.290000] [NAND] nand driver version: 0x2 0x9
[    0.290000] nand interrupte register ok
[    0.300000] ret of NFC_ChangMode is 0
[    0.300000] dma_hdle  is 0
[    0.300000] dma_hdle  is 10000008
[    0.310000] [SCAN_ERR] search nand physical architecture parameter failed!
[    0.310000] [NAND]init_blklayer fail
[    0.320000] [spi]: sw spi init !!
[    0.320000] [spi]: sw spi init fetch spi0 uning configuration failed
[    0.330000] [spi]: sw spi init fetch spi3 uning configuration failed
[    0.330000] [spi]: Get spi devices number failed
[    0.340000] [spi]: register spi devices board info failed
[    0.340000] spi: cannot find any using configuration for                     all 4 spi controllers, return directly!
[    0.350000] usbcore: registered new interface driver rtl8187
[    0.360000] usbcore: registered new interface driver rtl8192cu
[    0.360000] usbcore: registered new interface driver rndis_wlan
[    0.370000] usbcore: registered new interface driver ath9k_htc
[    0.380000] usbcore: registered new interface driver asix
[    0.380000] usbcore: registered new interface driver cdc_ether
[    0.390000] usbcore: registered new interface driver rndis_host
[    0.390000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.400000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.410000] WRN:L120(drivers/usb/host/sw_hci_sun4i.c):ERR: get usbc2 enable failed
[    0.410000] WRN:L127(drivers/usb/host/sw_hci_sun4i.c):ERR: get usbc2(usbc2) id failed
[    0.420000] WRN:L120(drivers/usb/host/sw_hci_sun4i.c):ERR: get usbc2 enable failed
[    0.430000] WRN:L127(drivers/usb/host/sw_hci_sun4i.c):ERR: get usbc2(usbc2) id failed
[    0.440000] WRN:L716(drivers/usb/host/sw_hci_sun4i.c):ERR: gpio_request failed
[    0.440000] WRN:L1087(drivers/usb/host/sw_hci_sun4i.c):ERR: usb2 alloc_pin failed
[    0.450000] usbcore: registered new interface driver cdc_wdm
[    0.460000] Initializing USB Mass Storage driver...
[    0.460000] usbcore: registered new interface driver usb-storage
[    0.470000] USB Mass Storage support registered.
[    0.470000] usbcore: registered new interface driver usbserial
[    0.480000] usbserial: USB Serial Driver core
[    0.480000] usbcore: registered new interface driver ftdi_sio
[    0.490000] USB Serial support registered for FTDI USB Serial Device
[    0.500000] ftdi_sio: v1.6.0:USB FTDI Serial Converters Driver
[    0.500000] usbcore: registered new interface driver pl2303
[    0.510000] USB Serial support registered for pl2303
[    0.510000] mousedev: PS/2 mouse device common for all mice
[    0.520000] usbcore: registered new interface driver usbtouchscreen
[    0.520000] sun4i-ts.c: sun4i_ts_init: start ...
[    0.530000] rtp_used == 1.
[    0.530000] sun4i-ts: tp_screen_size is 5 inch.
[    0.540000] sun4i-ts: tp_regidity_level is 5.
[    0.540000] sun4i-ts: tp_press_threshold_enable is 0.
[    0.550000] sun4i-ts: rtp_sensitive_level is 15.
[    0.550000] sun4i-ts: rtp_exchange_x_y_flag is 0.
[    0.560000] sun4i-ts.c: sun4i_ts_probe: start...
[    0.560000] begin get platform resourec
[    0.560000] input: sun4i-ts as /devices/platform/sun4i-ts/input/input0
[    0.570000] tp init
[    0.570000] sun4i-ts.c: sun4i_ts_probe: end
[    0.580000] sunxi RTC version 0.1
[    0.580000] sunxi-rtc sunxi-rtc: sunxi_rtc_probe tmp_data = 380239881
[    0.590000] [RTC] ERR: Set LOSC to external failed!!!
[    0.590000] [RTC] WARNING: Rtc time will be wrong!!
[    0.600000] sunxi-rtc sunxi-rtc: rtc core: registered rtc as rtc0
[    0.600000] i2c /dev entries driver
[    0.610000] !!! base_Addr = 0xf1c2ac00
[    0.610000] config i2c gpio with gpio_config api
[    0.620000] twi0, apb clock = 24000000
[    0.620000] axp_mfd 0-0030: AXP (CHIP ID: 0x05) detected
[    0.630000] I2C: i2c-0: AW16XX I2C adapter
[    0.630000] **********start************
[    0.640000] 0x40
[    0.640000] 0xf8
[    0.640000] 0x28
[    0.640000] 0x0
[    0.640000] 0x0
[    0.640000] **********end************
[    0.650000] !!! base_Addr = 0xf1c2b000
[    0.650000] twi1, apb clock = 24000000
[    0.660000] I2C: i2c-1: AW16XX I2C adapter
[    0.660000] **********start************
[    0.660000] 0x40
[    0.670000] 0xf8
[    0.670000] 0x58
[    0.670000] 0x0
[    0.670000] 0x0
[    0.670000] **********end************
[    0.680000] !!! base_Addr = 0xf1c2b400
[    0.680000] twi2, apb clock = 24000000
[    0.690000] I2C: i2c-2: AW16XX I2C adapter
[    0.690000] **********start************
[    0.690000] 0x40
[    0.700000] 0xf8
[    0.700000] 0x59
[    0.700000] 0x0
[    0.700000] 0x0
[    0.700000] **********end************
[    0.710000] [cedar dev]: install start!!!
[    0.710000] cedar_dev: can't get major 150
[    0.710000] [ace_drv] start!!!
[    0.720000] [ace_drv] init end!!!
[    0.720000] [pa_drv] start!!!
[    0.720000] [pa_drv] init end!!!
[    0.730000] axp20_ldo1: 1300 mV
[    0.730000] axp20_ldo2: 1800 <--> 3300 mV at 3000 mV
[    0.740000] axp20_ldo3: 700 <--> 3500 mV at 3300 mV
[    0.740000] axp20_ldo4: 1250 <--> 3300 mV at 3300 mV
[    0.750000] axp20_buck2: 700 <--> 2275 mV at 1400 mV
[    0.760000] axp20_buck3: 700 <--> 3500 mV at 1200 mV
[    0.760000] axp20_ldoio0: 1800 <--> 3300 mV at 1800 mV
[    0.770000] input: axp20-supplyer as /devices/platform/sun4i-i2c.0/i2c-0/0-0030/axp20-supplyer.28/input/input1
[    0.790000] axp20_ldo2: Failed to create debugfs directory
[    0.800000] sunxi_wdt: sunxi WatchDog Timer Driver v1.0
[    0.800000] sunxi_wdt: initialized (timeout=23s, nowayout=0)
[    0.810000] [mmc_pm]: no sdio card used in configuration
[    0.820000] [mmc]: sunximmc_init
[    0.820000] sunximmc_init fetch mmc3 using configuration failed
[    0.820000] [mmc]: sunxi mmc controller using config : 0x3
[    0.830000] [mmc]: sunxi-mmc.0: pdev->name: sunxi-mmc, pdev->id: 0
[    0.840000] [mmc]: mmc 0 power off !!
[    0.840000] [mmc]: mmc0 Probe: base:0xf1c0f000 irq:32 dma:0 pdes:0xd9948000, ret 0.
[    0.850000] [mmc]: mmc 0 power on !!
[    0.850000] [mmc]: sunxi-mmc.1: pdev->name: sunxi-mmc, pdev->id: 1
[    0.860000] [mmc]: mmc 1 power off !!
[    0.860000] [mmc]: mmc1 Probe: base:0xf1c10000 irq:33 dma:0 pdes:0xd9ad0000, ret 0.
[    0.870000] usbcore: registered new interface driver usbhid
[    0.880000] usbhid: USB HID core driver
[    0.880000] usbcore: registered new interface driver r8712u
[    0.890000] enter sun4i Audio codec!!!
[    0.890000] [mmc]: sdxc_request_done(L1113): smc 0 err, cmd 52,  RTO !!
[    0.900000] [mmc]: sdxc_request_done(L1113): smc 0 err, cmd 52,  RTO !!
[    0.910000] sun4i audio support initialized
[    0.910000] sun4i Audio codec successfully loaded..
[    0.920000] soc-audio soc-audio.0: ASoC machine sun4i-sndhdmi should use snd_soc_register_card()
[    0.930000] [mmc]: sdxc_request_done(L1113): smc 0 err, cmd 5,  RTO !!
[    0.930000] asoc: sndhdmi <-> sun4i-hdmiaudio.0 mapping ok
[    0.940000] [mmc]: sdxc_request_done(L1113): smc 0 err, cmd 5,  RTO !!
[    0.950000] [SPDIF]sun4i-spdif cannot find any using configuration for controllers, return directly!
[    0.960000] [mmc]: sdxc_request_done(L1113): smc 0 err, cmd 5,  RTO !!
[    0.960000] [SPDIF]sndspdif cannot find any using configuration for controllers, return directly!
[    0.970000] [mmc]: sdxc_request_done(L1113): smc 0 err, cmd 5,  RTO !!
[    0.980000] [SPDIF]sun4i_sndspdif cannot find any using configuration for controllers, return directly!
[    0.990000] [I2S]sun4i-i2s cannot find any using configuration for controllers, return directly!
[    1.000000] [I2S]sndi2s cannot find any using configuration for controllers, return directly!
[    1.010000] [I2S]sun4i_sndi2s cannot find any using configuration for controllers, return directly!
[    1.020000] IPv4 over IPv4 tunneling driver
[    1.020000] TCP: cubic registered
[    1.030000] Initializing XFRM netlink socket
[    1.030000] NET: Registered protocol family 17
[    1.040000] NET: Registered protocol family 15
[    1.040000] 8021q: 802.1Q VLAN Support v1.8
[    1.040000] lib80211: common routines for IEEE802.11 drivers
[    1.050000] lib80211_crypt: registered algorithm 'NULL'
[    1.060000] [mmc_pm]: No sdio card, please check your config !!
[    1.060000] VFP support v0.3: implementor 41 architecture 3 part 30 variant c rev 3
[    1.070000] Registering SWP/SWPB emulation handler
[    1.070000] SYS-CLK : setting 'video_pll0 (AW_SYS_CLK_PLL3)' to rate = 297000000 Hz
[    1.070000] SYS-CLK : SysClkDiv AXI 1 - AHB 1 - APB 1
[    1.070000] SYS-CLK : SysClk CPU = 1008000000 Hz, AXI = 504000000 Hz,  AHB = 252000000 Hz,  APB0 = 126000000 Hz, APB1 = 24000000 Hz
[    1.080000] [DISP] lcd1_para.lcd_used not exit
[    1.190000] mmc0: new high speed SDHC card at address 0003
[    1.210000] mmcblk0: mmc0:0003 SB08G 7.21 GiB
[    1.210000]  mmcblk0: p1 p2 p3
[    1.210000] mmcblk0: p3 size 7749632 extends beyond EOD, truncated
[    1.750000] Console: switching to colour frame buffer device 160x45
[    1.770000] axp20_buck3: incomplete constraints, leaving on
[    1.770000] axp20_buck2: incomplete constraints, leaving on
[    1.780000] axp20_ldo4: incomplete constraints, leaving on
[    1.780000] axp20_ldo3: incomplete constraints, leaving on
[    1.790000] axp20_ldo2: incomplete constraints, leaving on
[    1.800000] sunxi-rtc sunxi-rtc: hctosys: unable to read the hardware clock
[    1.800000] ALSA device list:
[    1.810000]   #0: sun4i-CODEC  Audio Codec
[    1.810000]   #1: sun4i-sndhdmi
[    1.810000] >>> no handle, treat it handle over
[    1.820000] EXT3-fs (mmcblk0p2): error: couldn't mount because of unsupported optional features (240)
[    1.840000] EXT2-fs (mmcblk0p2): error: couldn't mount because of unsupported optional features (240)

Complete log: https://www.dropbox.com/s/pibk60sr8zua5sl/putty_20.03.220249.log
Kernel is fitted into system based on Official Olimex Debian SD Image, script.bin not changed.
mmcblk0p2 is EXT4.
During building I found few objects for sun4i, can it cause a problems for A10s(SUN5I) ?
Edit:
File system changed to EXT3 and it is mounting properly but getting kernel panic after mmc data errors.
New boot log: https://www.dropbox.com/s/39qb80jxz2vk0qx/putty_22.03.013606.log
Tested on 2 different SD cards with above results.