Firefox crash after upgrade

Started by KeesZagers, March 10, 2021, 04:51:05 PM

Previous topic - Next topic


A few years ago I bought a TERES laptop kit and it worked quite well, in fact only used it as a Firefox browser. Now I wanted to start a new project with it and I thought it is best to start with a new clean system. So downloaded the latest image:
Installed it and everything worked again. Also no problem with Firefox.
As the image is already quite old I looked for updates and upgraded everything with sudo apt upgrade. No problem so far. However if I start Firefox now I always get a message that the tab crashed. Have others also experienced this? And maybe know the reason and still better: have a solution for the problem?


OK, others no problems with it???
Now re-installed the same image and no upgrade. This works for now. But ...
Are new ready-to-use images expected in the near future?
What can I expect from the other older images that are on the FTP server?


Never reinstall a working system ... :D

I flashed it and tried it out today and i can confirm the issue with Firefox. Not nice.
I wanted anyway to revert the eMMC back to a more stable image because latest Armbian was powering off on me out of the blue - no idea why and i don't have the time to look into it.
So i'll use xenial with Chrome till the Firefox issue is fixed. It could be an old kernel +  GFX acceleration thing. Or something to disable in FF.

Looking forward to get a working debian bullseye install on SD card with mainline kernel.


I've been flashing and trying it today and confirmed the Firefox issue. Not good.
In both cases, I would like to return the eMMC back to a more secure picture because the last Armbian was dripping me out from the blue.
But I'll use Chrome xenial before the Firefox problem is solved. It could be an old acceleration kernel + GFX thing. Or uninstall something in FF.