How to debug "Starting kernel ..." of Bullseye debian-installer?

Started by mossroy, March 03, 2021, 04:09:38 pm

Previous topic - Next topic

mossroy

Debian Bullseye will ship with a kernel 5.10, which should support Olinuxino A64 boards (at least for most features, see https://linux-sunxi.org/Linux_mainlining_effort).

I tried the debian-installer (daily images from https://d-i.debian.org/daily-images/arm64/daily/netboot/SD-card-images/ , I tested version of March 1st 2021). The installation works, but :
  • The board does not restart by itself at the end of the installation (it is stuck on a line saying it's asking the board to reboot, after all steps are finished). It is minor
  • On startup, it is stuck on "Starting kernel ...". It is of course a blocker

The kernel unfortunately does not give any feedback on what's wrong.
I tried adding "earlyprintk loglevel=7" boot parameters in u-boot before startup (in the u-boot prompt, and even by re-generating a modified boot.scr with mkimage), but did not manage to have debug information on startup.

Anybody would know how to have more information? Or has succeeded in installing Debian Bullseye on a Olinuxino A64 board?
The answer might be somewhere in the commits of https://github.com/OLIMEX/linux-olimex/ or https://github.com/OLIMEX/olimage
Maybe some DTB or DTB overlays need to be added and configured ? Should we open a bug on Debian side?

Excerpt from serial console :

Quote from: undefinedFound U-Boot script /boot.scr
2226 bytes read in 1 ms (2.1 MiB/s)
## Executing script at 4fc00000
26990448 bytes read in 1198 ms (21.5 MiB/s)
28249 bytes read in 5 ms (5.4 MiB/s)
27081515 bytes read in 1205 ms (21.4 MiB/s)
Booting Debian 5.10.0-3-arm64 from mmc 0:1...
## Flattened Device Tree blob at 4fa00000
  Booting using the fdt blob at 0x4fa00000
  Loading Ramdisk to 4862c000, end 49fffb2b ... OK
  Loading Device Tree to 0000000048622000, end 000000004862be58 ... OK

Starting kernel ...