A64 audio input line-in

Started by gennariello, January 26, 2021, 06:36:08 PM

Previous topic - Next topic



I need to forward sound from the 3.5mm jack input (AUX cable) to the onboard speaker connector (I need to create a sort of loop).
I can play sound from filesystem, but I'm unable to register any kind of sound using the line-IN input.
I've tried recording from all sound cards listed with "arecord -L"; linux creates a file but I can't hear any sound if I play it. Which sound card is the correct one?

My board is A64-OLinuXino-1Ge16GW and I'm using the official focal OS image.

Can anyone help me?
Thank you very much,


There are two jumpers behind the line in connector. Factory are soldered to "mic in". You have to move to "ine in". Then try again with alsamixer settings. Sorry, i do not have a board here. Will test it tomorow at the office.


As Brian pointed out by default the connector is set to MIC IN (not LINE IN).
Technical support and documentation manager at Olimex


Hi all and thank you for your replies.

You are right, I need to switch the jumper... but since the default is connected to mic-in, using a line-in input I think I should record noise, not absence of sound.
I've also tried with a microphone and no sound can be recorded.
I think I'm wrong also in others configuration.

Is the following the right sound card?
    sun50i-a64-audio, 1c22c00.dai-sun8i sun8i-0
    Default Audio Device


Hi gennariello, I got my first A64-OLinuXino-1G recently and I struggled to figure out how to get the mic to work, so perhaps I can help.

There are an amazing amount of options in alsamixer that are new to me. In the end, the main trick was to enable capture for Mic1 and AIF1 Data Digital ADC (by pressing the space bar) and also unmute Mic1 and AIF1 Slot 0, but perhaps some other settings also needed to be adjusted. Here's a screenshot of my alsamixer settings. I'm using an Olimex mic and headphones.

By the way, I want to set some of these up for friends so we can play music together online with Jamulus.