A64 boot from eMMC

Started by vikas, November 02, 2020, 01:22:26 am

Previous topic - Next topic

vikas

hello,
I am trying to boot from eMMC(16GB). I am using A64-OLinuXino-bionic-base-20201008-215447.img through SD card(8GB) to boot A64. But when used olinuxino-sd-to-emmc to write SD card contents to emmc, no boot. Got error:

U-Boot SPL 2020.01+olimex-1-20200701.165703 (Jan 30 2020 - 11:10:18 +0000)
DRAM: 1024 MiB
MMC Device 1 not found
Trying to boot from MMC2
MMC Device 1 not found
spl: could not find mmc device 1. error: -19
SPL: failed to boot from all boot devices
### ERROR ### Please RESET the board ###

I also tried dd command to write .img file, got same error as above.

Please check and suggest.

Regards,
Vikas

LubOlimex

There are newer images now (A64-OLinuXino-bionic-base-20201029-135151.img.7z), also when you first boot make sure to have access to internet and update and upgrade with:

apt update
apt upgrade

After the update and upgrade test the eMMC installation again and let me know how it goes.
Technical support and documentation manager at Olimex

vikas

Hello,

After update and upgrade. Now When run command to write eMMC get error:

root@a64-olinuxino:~# olinuxino-sd-to-emmc

Detecting board...

Detecting the root device...
Root partition:         /dev/mmcblk0p1
Root device:            /dev/mmcblk0

Detecting eMMC device...
eMMC partition:         /dev/mmcblk1p1
eMMC device:            /dev/mmcblk1

Checking disk size...
Required blocks:        9084640
Available blocks:       30535680

Unmount target device...
umount: /dev/mmcblk1p1: not mounted.

Copying MBR record...
[  128.306090] sunxi-mmc 1c11000.mmc: data error, sending stop command
[  128.329316] sunxi-mmc 1c11000.mmc: data error, sending stop command
[  128.352658] sunxi-mmc 1c11000.mmc: data error, sending stop command
[  128.376045] sunxi-mmc 1c11000.mmc: data error, sending stop command
[  128.399550] sunxi-mmc 1c11000.mmc: data error, sending stop command
[  128.461014] sunxi-mmc 1c11000.mmc: data error, sending stop command
[  129.465564] sunxi-mmc 1c11000.mmc: send stop command failed

Earlier, step #root@a64-olinuxino:~# olinuxino-sd-to-emmc, used to get complete, but now  "sunxi-mmc 1c11000.mmc: data error"

Best Regards,
Vikas

LubOlimex

November 02, 2020, 03:05:32 pm #3 Last Edit: November 02, 2020, 03:07:52 pm by LubOlimex
Did you try to run it a few times or just once? Can you try to run it a few times? Also after the first power up and update and upgrade, please reboot the board (if you haven't already).
Technical support and documentation manager at Olimex

vikas

Hello,

After update,upgrade,reboot, I tried  olinuxino-sd-to-emmc and reboot multiple times, but failed at every time with log sunxi-mmc 1c11000.mmc: data error, sending stop command

LubOlimex

November 02, 2020, 04:58:30 pm #5 Last Edit: November 03, 2020, 08:26:52 am by LubOlimex
Indeed, it seems currently the software support for that eMMC is not properly working in the latest Olimex images. The developers seem to be aware and are working on a solution since they don't want to lower the speed. The only workaround currently is modifying the position of the PWR_PC1 jumper at the bottom that would make the eMMC work at 3.3V instead of 1.8V. However, working at 3.3V also means that the fastest speeds would be unreachable.

Edit: modifying PWR_PC1 is kind of tricky and probably requires advanced soldering experience - it requires disconnecting the original position (cutting) and soldering together the pads of the new position. I wouldn't recommend it if you are not certain in your soldering skills.
Technical support and documentation manager at Olimex