A20-OLinuXino-Lime2 - Debian - Unable to boot after upgrade

Started by adamrichard, May 22, 2022, 10:32:22 am

Previous topic - Next topic

adamrichard

For some days now I have the board mentioned in the subject, the goal is to have a webserver, git server, and maybe lateron something like a mini-personal-cloud for my family.

Yesterday me and my brother finally decided which OS to use - and dd-ed the SD card with the Armbian/Debian Vanilla Jessie Server image (Armbian_5.10_Lime2_Debian_jessie_4.5.2). Some hours later after installing apache2 and trying things out I thought it would be a good idea to do an apt-get upgrade for security reasons before exposing the server to "the world". Unfortunately it was not: The device is not booting any longer after the upgrade. This is the log output of /var/log/apt/term.log (I mounted the SD card at the Linux system on my notebook ): gb whatsapp

It seems the upgrade routine tried to create a new initrd image, but failed: When I look into the /boot/ directory on the SD card, there really is no file "initrd.img-4.5.5-sunxi" (and from my (admittedly not very deep) linux knowledge there *should* be such a file ^^) and also not the old version 4.5.2.

LubOlimex

Try our Olimage, it is described here:

https://github.com/OLIMEX/OLINUXINO/blob/master/DOCUMENTS/OLIMAGE/Olimage-guide.pdf

If you stick with Armbian make sure to also post in the Armbian forums, since we no longer maintain it, you would have better chances for someone knowledgable to help you there.
Technical support and documentation manager at Olimex