A64 - Enable SPI0 on UEXT

Started by oli_sbr, July 05, 2020, 07:18:03 PM

Previous topic - Next topic



I want to use the A64-OLinuXino-1Ge16GW on a project where I need a lot of UART.
UART0 is used for debug purposes, UART2 and 3 are available on external connectors.
(by the way, I have an issue with UART3 not working : https://www.olimex.com/forum/index.php?topic=7671.msg29065#msg29065)

I want to add more UART in the future. I plan to use a NXP SC16IS762 dual UART with the SPI interface on UEXT. A kernel driver is available, which is nice. Nevertheless, I can't enable SPI0 on UEXT.

I have tried to enable spi-spidev overlay to make some tests, with armbian-config (Armbian 20.05.2 Buster, kernel 5.4.43-sunxi64).
After reboot, there is no
I also tried spi-add-cs1 overlay with the same result.

I don't have any SPI Flash on the board.



Looking at the link of the UART port problem it seems you are using Armbian image, right?

Try the Olimage and try the "olinuxino-overlay" script. You can get it from here:


If you wonder which release to get, get the bionic base 7z archive.

You can further inspect the scripts we use here:

Technical support and documentation manager at Olimex


Hello Lub,

I got /dev/spidev0.0 appears with the Olimage and proper overlay, which is nice.
I will dive further to make it work as wanted.

Thank you.