USB and eMMC not working with current Armbian images

Started by rinni, December 18, 2019, 08:51:00 PM

Previous topic - Next topic


Ok, thanks for the quick clarification. As the USB port never worked, it seems to be a case of warranty - should I contact to handle the details? I already got a RMA number, thanks!



I have the exact same problem as initially described : USB not working with the stable armbian image on A64-OLinuXino-2Ge8G-IND. I'm trying "focal version" at the moment (but I tried buster also). With the olimex image (A64-OLinuXino-bionic-base-20200701-182325), USB works fine. I'd rather have armbian though. What can I do?

Thank you for your help


The reason we made Olimex images is that Armbian is trying to cover 100 boards form 50 different vendors and every time they touch something it breaks tens of boards, so we had to patch over their images to work.
we did this for a while then decided to make our own image where everything on our boards works.

USB is not the only issue in A64 Armbian images. Armbian guys do great work, but they have no ability to test all 100 boards they support, so they just make changes and compile their images. In most of the times most of the peripherials will work.

If you want to go with Armbian you have to test and make sure everything is working by yourself i.e. become part of Armbian team for given board.


We only support these mainline images for the A64 board:

> I'd rather have armbian though. What can I do?

Probably report the issue to the Armbian team, but overall it is open-software effort and community, you might need to fix it yourself.

You can have a look at our sources and compare with Armbian sources and apply the required changes to get the USB part to the same state.

It is highly recommended to start with the build scripts since it contains the process of building the image and what is taken from where:
Technical support and documentation manager at Olimex


Thankyou for your answers.
I don't mind leaving armbian, but it use to provide better hardware acceleration support. It seems it's no longer the case (or at least for this board)
Then, I booted from your recommanded image (A64-OLinuXino-buster-base-20200701-182450.img), but all videos are stuttering. Is there a simple way to make videplayback work?
Sorry, perhaps I should have started a new thread...


Please can you give me some more info about this. More specifically:

1. Are you using an LCD or HDMI or what video output medium?

2. How do you play the video (via some player or via browser or how)?

3. Is it the same video on both Linux images? What kind of video that it is (resolution, bit rate, format/container)?

4. Which Armbian image do you use exactly?

Any extra information that would let me test at similar conditions here is more than welcome.
Technical support and documentation manager at Olimex